aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-02 09:28:38 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-02 09:28:38 +0000
commit46e449fa1cf136f7c17c469e4df76a5dd35fa7ad (patch)
tree7c86cd0d42f9bbe8e505c35596dee022618af654 /ftp
parentd57c60dd4bee643992cc6519be88d1d970c0e45a (diff)
downloadports-46e449fa1cf136f7c17c469e4df76a5dd35fa7ad.tar.gz
ports-46e449fa1cf136f7c17c469e4df76a5dd35fa7ad.zip
ftp/lftp: fix build on GCC architectures
C++11 compiler is necessary: In file included from FileAccess.cc:1029: ftpclass.h:123: error: ISO C++ forbids initialization of member 'cepr_supported' ftpclass.h:123: error: making 'cepr_supported' static ftpclass.h:123: error: ISO C++ forbids in-class initialization of non-const static member 'cepr_supported' MFH: 2020Q1
Notes
Notes: svn path=/head/; revision=521815
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index b15529ac127f..75fcda5de246 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -22,7 +22,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libidn2.so:dns/libidn2
-USES= charsetfix iconv libtool localbase readline shebangfix
+USES= compiler:c++11-lang charsetfix iconv libtool localbase \
+ readline shebangfix
GNU_CONFIGURE= yes
PORTDOCS= AUTHORS BUGS ChangeLog FAQ FEATURES INSTALL \