aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 22:14:37 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 22:14:37 +0000
commit5c308752363fa3273ee9d42d259af4b3691f2105 (patch)
tree816bc10550959a784dbbc3937bfa537ec5be00bd /ftp
parent0c25fde6e73614a7d2dd793cd71e2cb379839061 (diff)
downloadports-5c308752363fa3273ee9d42d259af4b3691f2105.tar.gz
ports-5c308752363fa3273ee9d42d259af4b3691f2105.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/yafc/Makefile16
-rw-r--r--ftp/yafc/distinfo6
-rw-r--r--ftp/yafc/files/patch-src::ftp::rfile.c74
3 files changed, 15 insertions, 81 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index d0386b2120f7..723911b1a3b0 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= yafc
-PORTVERSION= 1.1
+PORTVERSION= 1.1.1
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,13 +21,21 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-socks4=no --with-socks5=no --with-krb4=no \
--with-krb5=no --with-gssapi=no
-PLIST_FILES= bin/yafc %%EXAMPLESDIR%%/inputrc.sample %%EXAMPLESDIR%%/yafcrc.sample
-PLIST_DIRS= %%EXAMPLESDIR%%
MAN1= yafc.1
INFO= yafc
+PLIST_FILES= bin/yafc \
+ %%EXAMPLESDIR%%/inputrc.sample \
+ %%EXAMPLESDIR%%/yafcrc.sample
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.sample ${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/yafc/distinfo b/ftp/yafc/distinfo
index 9a13588e7be9..a9c3561cab68 100644
--- a/ftp/yafc/distinfo
+++ b/ftp/yafc/distinfo
@@ -1,3 +1,3 @@
-MD5 (yafc-1.1.tar.bz2) = 877c21d9b70d89474d1a6478a21c1e51
-SHA256 (yafc-1.1.tar.bz2) = 5eb28b04f2e3166bddc2b3555d7e316278b0405c36284bec07a0c008ca7e94f5
-SIZE (yafc-1.1.tar.bz2) = 463528
+MD5 (yafc-1.1.1.tar.bz2) = 832d074183a36ee15b47553ed5962fce
+SHA256 (yafc-1.1.1.tar.bz2) = ab72b2ed89fb75dbe8ebd119458cf513392225f367cccfad881e9780aefcd7e6
+SIZE (yafc-1.1.1.tar.bz2) = 858991
diff --git a/ftp/yafc/files/patch-src::ftp::rfile.c b/ftp/yafc/files/patch-src::ftp::rfile.c
deleted file mode 100644
index 7d18c5b23d3f..000000000000
--- a/ftp/yafc/files/patch-src::ftp::rfile.c
+++ /dev/null
@@ -1,74 +0,0 @@
---- src/ftp/rfile.c.orig Thu May 20 20:10:52 2004
-+++ src/ftp/rfile.c Sun May 23 21:49:54 2004
-@@ -439,7 +439,11 @@
- free(saved_field[0]);
- f->owner = saved_field[1];
- f->group = saved_field[2];
-+#if 0
- f->size = atoll(saved_field[3]);
-+#else
-+ f->size = strtoll(saved_field[3], NULL, 10);
-+#endif
- free(saved_field[3]);
- m = saved_field[4];
- NEXT_FIELD2;
-@@ -453,7 +457,11 @@
- free(saved_field[0]);
- f->owner = saved_field[1];
- f->group = xstrdup("group");
-+#if 0
- f->size = atoll(saved_field[2]);
-+#else
-+ f->size = strtoll(saved_field[2], NULL, 10);
-+#endif
- free(saved_field[2]);
- m = saved_field[3];
- d = saved_field[4];
-@@ -465,7 +473,11 @@
- f->nhl = 0;
- f->owner = xstrdup("owner");;
- f->group = xstrdup("group");
-+#if 0
- f->size = atoll(saved_field[1]);
-+#else
-+ f->size = strtoll(saved_field[1], NULL, 10);
-+#endif
- free(saved_field[1]);
- m = saved_field[2];
- d = saved_field[3];
-@@ -480,7 +492,11 @@
- free(saved_field[0]);
- f->owner = saved_field[1];
- f->group = saved_field[2];
-+#if 0
- f->size = atoll(saved_field[3]);
-+#else
-+ f->size = strtoll(saved_field[3], NULL, 10);
-+#endif
- free(saved_field[3]);
- free(saved_field[4]);
-
-@@ -624,7 +640,11 @@
- f->perm[0] = 'd';
- f->size = 0L;
- } else {
-+#if 0
- f->size = (unsigned long long)atoll(e);
-+#else
-+ f->size = (unsigned long long)strtoll(e, NULL, 10);
-+#endif
- }
-
- f->nhl = 1;
-@@ -686,7 +706,11 @@
- * FTP" Internet draft, but PureFTPd uses it for some
- * reason for size of directories
- */
-+#if 0
- f->size = atoll(value);
-+#else
-+ f->size = strtoll(value, NULL, 10);
-+#endif
- else if(strcasecmp(factname, "type") == 0) {
- if(strcasecmp(value, "file") == 0)
- isdir = false;