aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2006-05-27 00:27:22 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2006-05-27 00:27:22 +0000
commit5c7496801d6849f3193dae168d459e5140e8c635 (patch)
treee38846a0e0df1e09433da0a3285e7e313186a0c8 /ftp
parent88553673493a0cf27907b07ebbba3316e8c86c51 (diff)
downloadports-5c7496801d6849f3193dae168d459e5140e8c635.tar.gz
ports-5c7496801d6849f3193dae168d459e5140e8c635.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wu-ftpd/Makefile9
-rw-r--r--ftp/wu-ftpd/files/ftpd.c-pam10
2 files changed, 18 insertions, 1 deletions
diff --git a/ftp/wu-ftpd/Makefile b/ftp/wu-ftpd/Makefile
index dd15cc3bca5e..3342e8c31f8f 100644
--- a/ftp/wu-ftpd/Makefile
+++ b/ftp/wu-ftpd/Makefile
@@ -21,10 +21,17 @@ COMMENT= A replacement ftp server for Un*x systems
CONFLICTS= wu-ftpd+ipv6-[0-9]* heimdal-[0-9]*
USE_AUTOTOOLS= autoconf:213
-CONFIGURE_ARGS= --enable-rfc931 --disable-pasvip --enable-opie \
+CONFIGURE_ARGS= --enable-rfc931 --disable-pasvip \
--enable-noop --disable-numericuid --enable-nlst-dirs \
--prefix=${PREFIX} --with-etc-dir=${PREFIX}/etc
+.if !defined(WITH_PAM)
+CONFIGURE_ARGS+= --enable-opie
+.else
+CONFIGURE_ARGS+= --enable-pam
+EXTRA_PATCHES+= ${FILESDIR}/ftpd.c-pam
+.endif
+
MAKE_ENV+= WARNINGS=-DSPT_TYPE=SPT_BUILTIN
MAN1= ftpcount.1 ftpwho.1
diff --git a/ftp/wu-ftpd/files/ftpd.c-pam b/ftp/wu-ftpd/files/ftpd.c-pam
new file mode 100644
index 000000000000..8049306979ce
--- /dev/null
+++ b/ftp/wu-ftpd/files/ftpd.c-pam
@@ -0,0 +1,10 @@
+--- src/ftpd.c.orig Fri Nov 30 01:56:11 2001
++++ src/ftpd.c Wed May 24 16:21:21 2006
+@@ -6926,6 +6926,7 @@
+ */
+
+ #include <security/pam_appl.h>
++#define PAM_ESTABLISH_CRED 0x1
+ /* Static variables used to communicate between the conversation function
+ * and the server_login function
+ */