aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2020-02-26 16:30:45 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2020-02-26 16:30:45 +0000
commite0364757922f2d1e77a240a77f12529702eec8f6 (patch)
tree1418e24f89591433126a95d685120e97b3d1dfba /ftp
parent21a766807a1401579df3a720b47933a8f0007e19 (diff)
downloadports-e0364757922f2d1e77a240a77f12529702eec8f6.tar.gz
ports-e0364757922f2d1e77a240a77f12529702eec8f6.zip
ftp/yafc: unbreak and update to 1.3.7
PR: 243843 Submitted by: m.ne [at] gmx net
Notes
Notes: svn path=/head/; revision=527172
Diffstat (limited to 'ftp')
-rw-r--r--ftp/yafc/Makefile41
-rw-r--r--ftp/yafc/distinfo5
-rw-r--r--ftp/yafc/files/patch-m4_glib-gettext.m413
3 files changed, 40 insertions, 19 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index 85f88f181168..765346c69c86 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -2,34 +2,42 @@
# $FreeBSD$
PORTNAME= yafc
-PORTVERSION= 1.2.5
-PORTREVISION= 4
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.7
CATEGORIES= ftp
-MASTER_SITES= http://www.yafc-ftp.com/downloads/
MAINTAINER= wg@FreeBSD.org
COMMENT= Yet another FTP client, similar to ftp(1)
-BROKEN= unfetchable
-
LICENSE= GPLv2+
-OPTIONS_DEFINE= BASH EXAMPLES NLS SSH READLINE
-OPTIONS_DEFAULT=BASH SSH
+BUILD_DEPENDS= glib>0:devel/glib20
+
+USES= autoreconf gmake makeinfo pkgconfig ssl tar:xz
+USE_GITHUB= yes
+GH_ACCOUNT= sebastinas
-USES= gmake ssl tar:xz
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-krb5=no \
+ --with-openssl=${OPENSSLBASE} \
+ --with-socks5=no \
+ --with-socks=no
CONFIGURE_ENV= ac_cv_ipv6=yes
-CONFIGURE_ARGS= --with-socks=no --with-socks5=no --with-krb4=no \
- --with-krb5=no --with-openssl=${OPENSSLBASE}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PORTEXAMPLES= inputrc yafcrc
+INFO= yafc
PLIST_FILES= bin/yafc \
man/man1/yafc.1.gz
-INFO= yafc
+PORTEXAMPLES= inputrc yafcrc
+
+OPTIONS_DEFINE= BASH EXAMPLES NLS READLINE SSH
+OPTIONS_DEFAULT= BASH SSH
+
+BASH_CONFIGURE_OFF= --with-bash-completion=no
+BASH_CONFIGURE_ON= --with-bash-completion=yes
+BASH_PLIST_FILES= etc/bash_completion.d/yafc
NLS_USES= gettext gnome
NLS_USE= GNOME=intltool
@@ -37,15 +45,14 @@ NLS_CONFIGURE_WITH= gettext=${LOCALBASE}
NLS_PLIST_FILES= share/locale/de/LC_MESSAGES/yafc.mo \
share/locale/sv/LC_MESSAGES/yafc.mo
-READLINE_USES= readline
-READLINE_CONFIGURE_WITH=readline
+READLINE_USES= readline
+READLINE_CONFIGURE_WITH= readline
SSH_LIB_DEPENDS= libssh.so:security/libssh
SSH_CONFIGURE_OFF= --without-ssh
-BASH_CONFIGURE_ON= --with-bash-completion=yes
-BASH_PLIST_FILES= etc/bash_completion.d/yafc
-BASH_CONFIGURE_OFF= --with-bash-completion=no
+pre-configure-NLS-on:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/glib-gettextize -f -c)
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/ftp/yafc/distinfo b/ftp/yafc/distinfo
index e09614c270bd..67a2e58a5116 100644
--- a/ftp/yafc/distinfo
+++ b/ftp/yafc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (yafc-1.2.5.tar.xz) = df93b1b8795b49852d555b57b775da4af4fe10baa420b0321f80689f94c45d81
-SIZE (yafc-1.2.5.tar.xz) = 364664
+TIMESTAMP = 1579745625
+SHA256 (sebastinas-yafc-v1.3.7_GH0.tar.gz) = 332fca7508c2187e45bc7b3c8f1e7288e9cf8109636945035caa628a347869ff
+SIZE (sebastinas-yafc-v1.3.7_GH0.tar.gz) = 237011
diff --git a/ftp/yafc/files/patch-m4_glib-gettext.m4 b/ftp/yafc/files/patch-m4_glib-gettext.m4
new file mode 100644
index 000000000000..bcaa6c8c458d
--- /dev/null
+++ b/ftp/yafc/files/patch-m4_glib-gettext.m4
@@ -0,0 +1,13 @@
+--- m4/glib-gettext.m4.orig 2020-01-23 10:12:04 UTC
++++ m4/glib-gettext.m4
+@@ -36,8 +36,8 @@ dnl We go to great lengths to make sure that aclocal w
+ dnl try to pull in the installed version of these macros
+ dnl when running aclocal in the glib directory.
+ dnl
+-m4_copy([AC_DEFUN],[glib_DEFUN])
+-m4_copy([AC_REQUIRE],[glib_REQUIRE])
++m4_copy_force([AC_DEFUN],[glib_DEFUN])
++m4_copy_force([AC_REQUIRE],[glib_REQUIRE])
+ dnl
+ dnl At the end, if we're not within glib, we'll define the public
+ dnl definitions in terms of our private definitions.