aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-02-15 14:34:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-02-15 14:34:26 +0000
commite630e52bb5f688a26b92533f2f2b0e17e3b85f33 (patch)
tree921070ae859847e6ad2f11168de4014a9c3571e8 /ftp
parent8b812c1bf4f8270bf585201073f5504abac62e07 (diff)
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile2
-rw-r--r--ftp/php70-curl/Makefile10
-rw-r--r--ftp/php70-ftp/Makefile14
3 files changed, 26 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 413c4a9011c8..918f3960f59b 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -67,6 +67,8 @@
SUBDIR += php55-ftp
SUBDIR += php56-curl
SUBDIR += php56-ftp
+ SUBDIR += php70-curl
+ SUBDIR += php70-ftp
SUBDIR += phpwebftp
SUBDIR += plasma-applet-ftpmonitor
SUBDIR += proftpd
diff --git a/ftp/php70-curl/Makefile b/ftp/php70-curl/Makefile
new file mode 100644
index 000000000000..2c359ab82aca
--- /dev/null
+++ b/ftp/php70-curl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -curl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php70-ftp/Makefile b/ftp/php70-ftp/Makefile
new file mode 100644
index 000000000000..300d5b187c92
--- /dev/null
+++ b/ftp/php70-ftp/Makefile
@@ -0,0 +1,14 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -ftp
+
+post-patch:
+ @${REINPLACE_CMD} s/HAVE_OPENSSL_EXT/__FreeBSD__/ \
+ ${WRKSRC}/ftp.* ${WRKSRC}/php_ftp.*
+
+.include "${MASTERDIR}/Makefile"