aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-02 03:35:05 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-02 03:35:05 +0000
commit145bda6b61fea4c7a1ed6b7c9b95653086c593fb (patch)
tree458b165bb4a860efd1d87b30cbc067bcdc028880 /ftp
parent1224e897fb8c0872856eff1fa5b647282838ad3c (diff)
downloadports-145bda6b61fea4c7a1ed6b7c9b95653086c593fb.tar.gz
ports-145bda6b61fea4c7a1ed6b7c9b95653086c593fb.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile10
-rw-r--r--ftp/proftpd-devel/distinfo2
-rw-r--r--ftp/proftpd-devel/files/patch-ae24
-rw-r--r--ftp/proftpd/Makefile10
-rw-r--r--ftp/proftpd/distinfo2
-rw-r--r--ftp/proftpd/files/patch-ae24
6 files changed, 34 insertions, 38 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index ef44338a3318..59a992d447d8 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: proftpd
-# Version required: 1.0.3pl1
+# Version required: 1.2.0pl3
# Date created: 26 January 1998
# Whom: Stephane Legrand
#
-# $Id: Makefile,v 1.7 1999/02/12 21:55:04 obrien Exp $
+# $Id: Makefile,v 1.8 1999/03/15 02:13:32 steve Exp $
#
-DISTNAME= proftpd-1.2.0pre2
+DISTNAME= proftpd-1.2.0pre3
PKGNAME= proftpd-1.2.0
CATEGORIES= net
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
@@ -20,10 +20,9 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/run \
- --with-modules=mod_ratio
+ --with-modules=mod_ratio
post-configure:
-
@${MV} ${WRKSRC}/src/proftpd.8 ${WRKSRC}/src/proftpd.8.pre_sed
@${SED} -e 's:/etc:${PREFIX}/etc:' \
-e 's:/usr/sbin/proftpd:${PREFIX}/libexec/proftpd:' \
@@ -41,7 +40,6 @@ post-configure:
< ${WRKSRC}/src/ftpcount.1.pre_sed > ${WRKSRC}/src/ftpcount.1
do-install:
-
@${INSTALL_PROGRAM} ${WRKSRC}/ftpcount ${PREFIX}/bin/ftpcount
@${INSTALL_PROGRAM} ${WRKSRC}/proftpd ${PREFIX}/libexec/proftpd
@${INSTALL_PROGRAM} ${WRKSRC}/ftpshut ${PREFIX}/sbin/ftpshut
diff --git a/ftp/proftpd-devel/distinfo b/ftp/proftpd-devel/distinfo
index abb66eef531c..7dd01454b3b6 100644
--- a/ftp/proftpd-devel/distinfo
+++ b/ftp/proftpd-devel/distinfo
@@ -1 +1 @@
-MD5 (proftpd-1.2.0pre2.tar.gz) = 85bed6f9211ba4a33f560312f1090a4b
+MD5 (proftpd-1.2.0pre3.tar.gz) = 60b8dc1ffd656a0c6823e83dc07aaecb
diff --git a/ftp/proftpd-devel/files/patch-ae b/ftp/proftpd-devel/files/patch-ae
index 284fbca2c7f8..b7525289a45a 100644
--- a/ftp/proftpd-devel/files/patch-ae
+++ b/ftp/proftpd-devel/files/patch-ae
@@ -1,15 +1,15 @@
---- modules/mod_auth.c.orig Sat Oct 17 22:24:41 1998
-+++ modules/mod_auth.c Mon Dec 14 15:26:02 1998
-@@ -61,7 +61,7 @@
+--- modules/mod_auth.c.orig Thu Mar 4 18:29:19 1999
++++ modules/mod_auth.c Thu Apr 1 14:36:03 1999
+@@ -65,7 +65,7 @@
/* Is this the proper behavior when timing out? */
send_response_async(R_421,"Login Timeout (%d seconds): closing control connection.",
TimeoutLogin);
-- schedule(main_exit,0,(void*)LOG_NOTICE,"FTP login timed out, disconnected.",
-+ schedule(main_exit,0,(void*)LOG_INFO,"FTP login timed out, disconnected.",
- (void*)0,NULL);
- remove_timer(TIMER_IDLE,ANY_MODULE);
- remove_timer(TIMER_NOXFER,ANY_MODULE);
-@@ -763,13 +763,13 @@
+- main_exit((void*)LOG_NOTICE,"FTP login timed out, disconnected.",
++ main_exit((void*)LOG_INFO,"FTP login timed out, disconnected.",
+ (void*)0,NULL);
+
+ /*
+@@ -787,13 +787,13 @@
resolve_anonymous_dirs(c->subset);
if(c)
@@ -25,7 +25,7 @@
origuser,session.c->remote_name,
inet_ascii(p,session.c->remote_ipaddr),
inet_ascii(p,session.c->local_ipaddr),
-@@ -1132,7 +1132,7 @@
+@@ -1156,7 +1156,7 @@
send_response(R_530,"%s",
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
@@ -34,7 +34,7 @@
max);
end_login(0);
}
-@@ -1156,7 +1156,7 @@
+@@ -1180,7 +1180,7 @@
send_response(R_530,"%s",
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
@@ -43,7 +43,7 @@
max);
end_login(0);
}
-@@ -1243,7 +1243,7 @@
+@@ -1267,7 +1267,7 @@
if(++auth_tries >= max) {
send_response(R_530,"Login incorrect");
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index ef44338a3318..59a992d447d8 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: proftpd
-# Version required: 1.0.3pl1
+# Version required: 1.2.0pl3
# Date created: 26 January 1998
# Whom: Stephane Legrand
#
-# $Id: Makefile,v 1.7 1999/02/12 21:55:04 obrien Exp $
+# $Id: Makefile,v 1.8 1999/03/15 02:13:32 steve Exp $
#
-DISTNAME= proftpd-1.2.0pre2
+DISTNAME= proftpd-1.2.0pre3
PKGNAME= proftpd-1.2.0
CATEGORIES= net
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
@@ -20,10 +20,9 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/run \
- --with-modules=mod_ratio
+ --with-modules=mod_ratio
post-configure:
-
@${MV} ${WRKSRC}/src/proftpd.8 ${WRKSRC}/src/proftpd.8.pre_sed
@${SED} -e 's:/etc:${PREFIX}/etc:' \
-e 's:/usr/sbin/proftpd:${PREFIX}/libexec/proftpd:' \
@@ -41,7 +40,6 @@ post-configure:
< ${WRKSRC}/src/ftpcount.1.pre_sed > ${WRKSRC}/src/ftpcount.1
do-install:
-
@${INSTALL_PROGRAM} ${WRKSRC}/ftpcount ${PREFIX}/bin/ftpcount
@${INSTALL_PROGRAM} ${WRKSRC}/proftpd ${PREFIX}/libexec/proftpd
@${INSTALL_PROGRAM} ${WRKSRC}/ftpshut ${PREFIX}/sbin/ftpshut
diff --git a/ftp/proftpd/distinfo b/ftp/proftpd/distinfo
index abb66eef531c..7dd01454b3b6 100644
--- a/ftp/proftpd/distinfo
+++ b/ftp/proftpd/distinfo
@@ -1 +1 @@
-MD5 (proftpd-1.2.0pre2.tar.gz) = 85bed6f9211ba4a33f560312f1090a4b
+MD5 (proftpd-1.2.0pre3.tar.gz) = 60b8dc1ffd656a0c6823e83dc07aaecb
diff --git a/ftp/proftpd/files/patch-ae b/ftp/proftpd/files/patch-ae
index 284fbca2c7f8..b7525289a45a 100644
--- a/ftp/proftpd/files/patch-ae
+++ b/ftp/proftpd/files/patch-ae
@@ -1,15 +1,15 @@
---- modules/mod_auth.c.orig Sat Oct 17 22:24:41 1998
-+++ modules/mod_auth.c Mon Dec 14 15:26:02 1998
-@@ -61,7 +61,7 @@
+--- modules/mod_auth.c.orig Thu Mar 4 18:29:19 1999
++++ modules/mod_auth.c Thu Apr 1 14:36:03 1999
+@@ -65,7 +65,7 @@
/* Is this the proper behavior when timing out? */
send_response_async(R_421,"Login Timeout (%d seconds): closing control connection.",
TimeoutLogin);
-- schedule(main_exit,0,(void*)LOG_NOTICE,"FTP login timed out, disconnected.",
-+ schedule(main_exit,0,(void*)LOG_INFO,"FTP login timed out, disconnected.",
- (void*)0,NULL);
- remove_timer(TIMER_IDLE,ANY_MODULE);
- remove_timer(TIMER_NOXFER,ANY_MODULE);
-@@ -763,13 +763,13 @@
+- main_exit((void*)LOG_NOTICE,"FTP login timed out, disconnected.",
++ main_exit((void*)LOG_INFO,"FTP login timed out, disconnected.",
+ (void*)0,NULL);
+
+ /*
+@@ -787,13 +787,13 @@
resolve_anonymous_dirs(c->subset);
if(c)
@@ -25,7 +25,7 @@
origuser,session.c->remote_name,
inet_ascii(p,session.c->remote_ipaddr),
inet_ascii(p,session.c->local_ipaddr),
-@@ -1132,7 +1132,7 @@
+@@ -1156,7 +1156,7 @@
send_response(R_530,"%s",
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
@@ -34,7 +34,7 @@
max);
end_login(0);
}
-@@ -1156,7 +1156,7 @@
+@@ -1180,7 +1180,7 @@
send_response(R_530,"%s",
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
@@ -43,7 +43,7 @@
max);
end_login(0);
}
-@@ -1243,7 +1243,7 @@
+@@ -1267,7 +1267,7 @@
if(++auth_tries >= max) {
send_response(R_530,"Login incorrect");