aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2008-12-08 19:33:33 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2008-12-08 19:33:33 +0000
commit1c45538c8fac9ff5b6d11911099c93e199548035 (patch)
tree250234431bfc53108d0833910d0cdfcb506d6f18 /ftp
parentd291f6256b190dfed0263a03151aaf5f35306299 (diff)
downloadports-1c45538c8fac9ff5b6d11911099c93e199548035.tar.gz
ports-1c45538c8fac9ff5b6d11911099c93e199548035.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile2
-rw-r--r--ftp/frox/files/patch-src-cache.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 7c62f7b1e089..cfe2ab16a457 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= frox
PORTVERSION= 0.7.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= http://www.hollo.org/frox/download/ \
http://frox.sourceforge.net/download/ \
diff --git a/ftp/frox/files/patch-src-cache.c b/ftp/frox/files/patch-src-cache.c
new file mode 100644
index 000000000000..0f2ebeab247c
--- /dev/null
+++ b/ftp/frox/files/patch-src-cache.c
@@ -0,0 +1,18 @@
+Apply patch
+
+
+Patch attached with submission follows:
+
+--- src/cache.c.orig 2008-03-12 16:56:10.000000000 +0200
++++ src/cache.c 2008-03-12 16:56:10.000000000 +0200
+@@ -364,7 +364,7 @@
+ int code;
+ sstr *msg;
+
+- if(!strcasecmp(config.cachemod, "Local") || !config.forcehttp) {
++ if(!strcasecmp(config.cachemod, "Local") || config.forcehttp) {
+ send_ccommand("SIZE", sstr_buf(filename));
+ get_message(&code, &msg);
+ if(code / 100 != 2) {
+
+