aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-16 20:50:43 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-16 20:50:43 +0000
commit3c348581cf06544011415070c7c0ad24b7b066b9 (patch)
treebd75693f4815ab1e7f4274de125e81e0bff74a13 /ftp
parent8ff7a739c94584f16ed4b9701059a5084e732c90 (diff)
downloadports-3c348581cf06544011415070c7c0ad24b7b066b9.tar.gz
ports-3c348581cf06544011415070c7c0ad24b7b066b9.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/quftp/Makefile3
-rw-r--r--ftp/quftp/files/patch-Makefile.in15
2 files changed, 17 insertions, 1 deletions
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index 63d78100d1c6..e0479c6a5733 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -22,7 +22,8 @@ PLIST_FILES= bin/quftp man/man1/quftp.1.gz
post-patch:
@${REINPLACE_CMD} -e \
- 's|^CFLAGS|#CFLAGS|' ${WRKSRC}/Makefile.in
+ '/^CFLAGS/s|+=.*|= ${CFLAGS} ${CPPFLAGS}|' \
+ ${WRKSRC}/Makefile.in
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quftp
diff --git a/ftp/quftp/files/patch-Makefile.in b/ftp/quftp/files/patch-Makefile.in
new file mode 100644
index 000000000000..bccce976ad73
--- /dev/null
+++ b/ftp/quftp/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2014-08-16 16:46:25.000000000 -0400
++++ Makefile.in 2014-08-16 16:46:47.000000000 -0400
+@@ -10,10 +10,10 @@
+
+ OBJS=ftp.o ftp_data.o ftp_directory.o ftp_login.o ftp_transfer.o ftp_list.o \
+ text.o rc.o quftp.o log.o
+-LIBS += -lreadline -lncurses
++LIBS += -lreadline -lncurses @LDFLAGS@
+ HEADERS=*.h
+ DEFS = @DEFS@
+-CFLAGS += -g -O6 -Wall
++CFLAGS += -g -O6 -Wall @CPPFLAGS@
+
+ .SUFFIXES:
+ .SUFFIXES: .c .o