aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-30 13:47:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-30 13:47:47 +0000
commit6103c750132834a457070739850d87c0ec2beafb (patch)
treebcf295e555c706dde7bc6d9f987b7a89817746e4 /ftp
parenta30469e69811f0bfa7efc484b35da9d2ace7c57b (diff)
downloadports-6103c750132834a457070739850d87c0ec2beafb.tar.gz
ports-6103c750132834a457070739850d87c0ec2beafb.zip
Update to 7.70.0
Notes
Notes: svn path=/head/; revision=533434
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-lib-easy.c38
3 files changed, 4 insertions, 43 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index e3451377ad69..7ad16a158e4f 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.69.1
-PORTREVISION= 1
+PORTVERSION= 7.70.0
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 53ebc06f4f11..01e9cb4776f2 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1585564806
-SHA256 (curl-7.69.1.tar.xz) = 03c7d5e6697f7b7e40ada1b2256e565a555657398e6c1fcfa4cb251ccd819d4f
-SIZE (curl-7.69.1.tar.xz) = 2467272
+TIMESTAMP = 1588242116
+SHA256 (curl-7.70.0.tar.xz) = 032f43f2674008c761af19bf536374128c16241fb234699a55f9fb603fcfbae7
+SIZE (curl-7.70.0.tar.xz) = 2348780
diff --git a/ftp/curl/files/patch-lib-easy.c b/ftp/curl/files/patch-lib-easy.c
deleted file mode 100644
index 683d5c90ff73..000000000000
--- a/ftp/curl/files/patch-lib-easy.c
+++ /dev/null
@@ -1,38 +0,0 @@
-Obtained from: https://github.com/curl/curl/commit/3bfda07004a5739fb306e55cb9529ba3de35fbdb
-
---- lib/easy.c.orig 2020-03-09 15:31:01 UTC
-+++ lib/easy.c
-@@ -884,14 +884,25 @@ struct Curl_easy *curl_easy_duphandle(struct Curl_easy
- goto fail;
-
- #ifdef USE_ARES
-- if(Curl_set_dns_servers(outcurl, data->set.str[STRING_DNS_SERVERS]))
-- goto fail;
-- if(Curl_set_dns_interface(outcurl, data->set.str[STRING_DNS_INTERFACE]))
-- goto fail;
-- if(Curl_set_dns_local_ip4(outcurl, data->set.str[STRING_DNS_LOCAL_IP4]))
-- goto fail;
-- if(Curl_set_dns_local_ip6(outcurl, data->set.str[STRING_DNS_LOCAL_IP6]))
-- goto fail;
-+ {
-+ CURLcode rc;
-+
-+ rc = Curl_set_dns_servers(outcurl, data->set.str[STRING_DNS_SERVERS]);
-+ if(rc && rc != CURLE_NOT_BUILT_IN)
-+ goto fail;
-+
-+ rc = Curl_set_dns_interface(outcurl, data->set.str[STRING_DNS_INTERFACE]);
-+ if(rc && rc != CURLE_NOT_BUILT_IN)
-+ goto fail;
-+
-+ rc = Curl_set_dns_local_ip4(outcurl, data->set.str[STRING_DNS_LOCAL_IP4]);
-+ if(rc && rc != CURLE_NOT_BUILT_IN)
-+ goto fail;
-+
-+ rc = Curl_set_dns_local_ip6(outcurl, data->set.str[STRING_DNS_LOCAL_IP6]);
-+ if(rc && rc != CURLE_NOT_BUILT_IN)
-+ goto fail;
-+ }
- #endif /* USE_ARES */
-
- Curl_convert_setup(outcurl);