aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-11-16 21:28:18 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-11-16 21:28:18 +0000
commit618de781a9de59b749b9cdbe1a689ac41e2057e4 (patch)
tree8d01ab59bcd81c1e3e000bf3aa4ecd5c211f45bd /ftp
parentfc0113ce8ab3f34c46c373341dfa91a0b8672e17 (diff)
downloadports-618de781a9de59b749b9cdbe1a689ac41e2057e4.tar.gz
ports-618de781a9de59b749b9cdbe1a689ac41e2057e4.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile2
-rw-r--r--ftp/lftp/distinfo6
-rw-r--r--ftp/lftp/files/patch-src-commands.cc10
3 files changed, 14 insertions, 4 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 4c9847bcdbad..638757ed3d5c 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lftp
-PORTVERSION= 3.7.4
+PORTVERSION= 3.7.5
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.wiretapped.net/pub/mirrors/lftp/ \
ftp://ftp.wiretapped.net/pub/mirrors/lftp/old/ \
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index 3bd5831a7042..bea7cf1d7027 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (lftp-3.7.4.tar.bz2) = 56f3b47f13788f4d97ed288857e4282a
-SHA256 (lftp-3.7.4.tar.bz2) = e84e0dec0e1b0abd0cb50427085bff878e9dc44cad0bc3fc3b91f500f9afc4da
-SIZE (lftp-3.7.4.tar.bz2) = 1330956
+MD5 (lftp-3.7.5.tar.bz2) = 08f577dc1fac96bcf24a847e8ce64554
+SHA256 (lftp-3.7.5.tar.bz2) = a4d4960a1679939785849b2179013bca09b08ffb6f04a3737519add64261c2cb
+SIZE (lftp-3.7.5.tar.bz2) = 1339331
diff --git a/ftp/lftp/files/patch-src-commands.cc b/ftp/lftp/files/patch-src-commands.cc
new file mode 100644
index 000000000000..5df69bef75da
--- /dev/null
+++ b/ftp/lftp/files/patch-src-commands.cc
@@ -0,0 +1,10 @@
+--- src/commands.cc.orig 2008-11-17 01:34:09.000000000 +0800
++++ src/commands.cc 2008-11-17 01:34:19.000000000 +0800
+@@ -31,6 +31,7 @@
+ #include <pwd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/wait.h>
+ #include <fcntl.h>
+ #include <assert.h>
+ #ifdef HAVE_DLFCN_H