aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-01 12:21:30 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-01 12:21:30 +0000
commit71ecb265c743b4a015d619ccbe314d318ab08872 (patch)
tree559b70bb404ae5b82bbdb839a08cbfae6b251e27 /ftp
parent236a71ab19ea2f816150fcb61a52f55217e9edde (diff)
downloadports-71ecb265c743b4a015d619ccbe314d318ab08872.tar.gz
ports-71ecb265c743b4a015d619ccbe314d318ab08872.zip
Fix build with clang11
Notes
Notes: svn path=/head/; revision=547268
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ncftp3/Makefile7
-rw-r--r--ftp/ncftp3/files/patch-sh__util_gpshare.c11
2 files changed, 12 insertions, 6 deletions
diff --git a/ftp/ncftp3/Makefile b/ftp/ncftp3/Makefile
index a9a82559679f..052cf0cfcac0 100644
--- a/ftp/ncftp3/Makefile
+++ b/ftp/ncftp3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ncftp
PORTVERSION= 3.2.6
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.ncftp.com/ncftp/ \
ftp://ftp.mirrorservice.org/sites/ftp.ncftp.com/ncftp/
@@ -22,11 +22,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_header_ncurses_h=yes
-CFLAGS+= -fcommon
-
-DEPRECATED= Unmaintained and dead upstream, does not build with -fno-common (llvm 11)
-EXPIRATION_DATE=2021-04-01
-
PORTDOCS= *
LIBNCFTP= libncftp.so.3
diff --git a/ftp/ncftp3/files/patch-sh__util_gpshare.c b/ftp/ncftp3/files/patch-sh__util_gpshare.c
new file mode 100644
index 000000000000..5cdd5f1846c8
--- /dev/null
+++ b/ftp/ncftp3/files/patch-sh__util_gpshare.c
@@ -0,0 +1,11 @@
+--- sh_util/gpshare.c.orig 2016-11-12 23:53:39 UTC
++++ sh_util/gpshare.c
+@@ -28,7 +28,7 @@
+
+ static int gIsAtty1 = 1, gIsAtty2 = 1;
+ extern int gLoadedBm, gBookmarkMatchMode;
+-Bookmark gBm;
++extern Bookmark gBm;
+
+ double
+ FileSize(double size, const char **uStr0, double *uMult0)