aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-21 18:49:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-21 18:49:44 +0000
commita450d3d2e7ed756ca0eadaddf1167a93fd47695a (patch)
treed9bf4fea579dd8c9d9a39205a363d655640cb741 /ftp
parent0f74f0181cf9352d9f2a19d3a991a3bc598ce05b (diff)
downloadports-a450d3d2e7ed756ca0eadaddf1167a93fd47695a.tar.gz
ports-a450d3d2e7ed756ca0eadaddf1167a93fd47695a.zip
- Update to 0.16.1
Notes
Notes: svn path=/head/; revision=542778
Diffstat (limited to 'ftp')
-rw-r--r--ftp/py-aioftp/Makefile7
-rw-r--r--ftp/py-aioftp/distinfo6
-rw-r--r--ftp/py-aioftp/files/patch-tests_test__pathio.py11
3 files changed, 18 insertions, 6 deletions
diff --git a/ftp/py-aioftp/Makefile b/ftp/py-aioftp/Makefile
index 68606977f319..13e3e1b85d73 100644
--- a/ftp/py-aioftp/Makefile
+++ b/ftp/py-aioftp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= aioftp
-PORTVERSION= 0.15.0
+PORTVERSION= 0.16.1
CATEGORIES= ftp python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,13 +17,14 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}trustme>=0:security/py-trustme@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}async_timeout>0:devel/py-async_timeout@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}async_timeout>0:devel/py-async_timeout@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}siosocks>0:net/py-siosocks@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
.include <bsd.port.mk>
diff --git a/ftp/py-aioftp/distinfo b/ftp/py-aioftp/distinfo
index 0fb4e19aad07..13f458c21684 100644
--- a/ftp/py-aioftp/distinfo
+++ b/ftp/py-aioftp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578494689
-SHA256 (aioftp-0.15.0.tar.gz) = dd59b80d2406a99af56229ec743d53ce23c0445dc1f30c267ca3f054178a87a0
-SIZE (aioftp-0.15.0.tar.gz) = 48036
+TIMESTAMP = 1594816546
+SHA256 (aioftp-0.16.1.tar.gz) = 4a0e01a1c310a99b638838784d8fc820defa04d8cd4eaa2503907d8338791f67
+SIZE (aioftp-0.16.1.tar.gz) = 49074
diff --git a/ftp/py-aioftp/files/patch-tests_test__pathio.py b/ftp/py-aioftp/files/patch-tests_test__pathio.py
new file mode 100644
index 000000000000..4d65c2c7a9d2
--- /dev/null
+++ b/ftp/py-aioftp/files/patch-tests_test__pathio.py
@@ -0,0 +1,11 @@
+--- tests/test_pathio.py.orig 2020-07-09 13:12:10 UTC
++++ tests/test_pathio.py
+@@ -252,7 +252,7 @@ async def test_unlink_not_exist(path_io, temp_dir):
+
+ @pytest.mark.asyncio
+ async def test_unlink_on_dir(path_io, temp_dir):
+- with universal_exception_reason(IsADirectoryError):
++ with universal_exception_reason(IsADirectoryError, PermissionError):
+ await path_io.unlink(temp_dir)
+
+