aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2017-09-15 10:07:00 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2017-09-15 10:07:00 +0000
commit7a44acf34be6630a5c491952fafa51aa00bca9ff (patch)
tree78cd69da21b9eee20bbb5882af619dafebd67c85 /ftp
parentb0fe6d2543c5b7edf61c5f5da7c5b72abd12009e (diff)
downloadports-7a44acf34be6630a5c491952fafa51aa00bca9ff.tar.gz
ports-7a44acf34be6630a5c491952fafa51aa00bca9ff.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile6
-rw-r--r--ftp/lftp/distinfo6
-rw-r--r--ftp/lftp/files/patch-src-lftp_ssl.cc13
3 files changed, 5 insertions, 20 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 0eff8b6dc3c7..fada04ec8a06 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lftp
-PORTVERSION= 4.8.0
-PORTREVISION= 1
+PORTVERSION= 4.8.1
CATEGORIES= ftp ipv6
MASTER_SITES= http://lftp.tech/ftp/ \
http://lftp.tech/ftp/old/ \
@@ -21,11 +20,10 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libidn.so:dns/libidn
+ libidn2.so:dns/libidn2
USES= charsetfix iconv libtool localbase readline shebangfix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_type_max_align_t=yes
PORTDOCS= AUTHORS BUGS ChangeLog FAQ FEATURES INSTALL \
MIRRORS NEWS README README.debug-levels README.modules \
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index 282c384c4dca..a11556d4772c 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499756313
-SHA256 (lftp-4.8.0.tar.gz) = 25c0a77da3da606eeca0bc721249f2ae85885f49d03e0f0e778da193e23c72d8
-SIZE (lftp-4.8.0.tar.gz) = 2800410
+TIMESTAMP = 1505324333
+SHA256 (lftp-4.8.1.tar.gz) = 6117866215cd889dab30ff73292cd1d35fe0e12a9af5cd76d093500d07ab65a3
+SIZE (lftp-4.8.1.tar.gz) = 2825304
diff --git a/ftp/lftp/files/patch-src-lftp_ssl.cc b/ftp/lftp/files/patch-src-lftp_ssl.cc
deleted file mode 100644
index c52a9faebf58..000000000000
--- a/ftp/lftp/files/patch-src-lftp_ssl.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix build with LibreSSL
-
---- src/lftp_ssl.cc.orig
-+++ src/lftp_ssl.cc
-@@ -772,7 +772,7 @@
- #elif USE_OPENSSL
- //static int lftp_ssl_passwd_callback(char *buf,int size,int rwflag,void *userdata);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
- // for compatibility with older versions
- X509_OBJECT *X509_OBJECT_new()
- {