aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
commit7fe96c109332ecdb411ceef911efd11085a88346 (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /ftp
parent47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (diff)
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile2
-rw-r--r--ftp/php55-curl/Makefile10
-rw-r--r--ftp/php55-ftp/Makefile14
3 files changed, 26 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index e39cf1adeb2b..f1ba81f177de 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -76,6 +76,8 @@
SUBDIR += php52-ftp
SUBDIR += php53-curl
SUBDIR += php53-ftp
+ SUBDIR += php55-curl
+ SUBDIR += php55-ftp
SUBDIR += phpwebftp
SUBDIR += plasma-applet-ftpmonitor
SUBDIR += proftpd
diff --git a/ftp/php55-curl/Makefile b/ftp/php55-curl/Makefile
new file mode 100644
index 000000000000..6b9199c38170
--- /dev/null
+++ b/ftp/php55-curl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -curl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php55-ftp/Makefile b/ftp/php55-ftp/Makefile
new file mode 100644
index 000000000000..6b0b1f1c0caa
--- /dev/null
+++ b/ftp/php55-ftp/Makefile
@@ -0,0 +1,14 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -ftp
+
+post-patch:
+ @${REINPLACE_CMD} s/HAVE_OPENSSL_EXT/__FreeBSD__/ \
+ ${WRKSRC}/ftp.* ${WRKSRC}/php_ftp.*
+
+.include "${MASTERDIR}/Makefile"