aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-08-28 09:36:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-08-28 09:36:29 +0000
commitb2695200c63b6eb0b69ef6768d8d3feaf258d363 (patch)
tree9cc80ecb7bbaf332cc5e3dc6cf73ba921b2e3443 /ftp
parent9d11c345697d7205d6df317001d99e5c91fbc0f4 (diff)
downloadports-b2695200c63b6eb0b69ef6768d8d3feaf258d363.tar.gz
ports-b2695200c63b6eb0b69ef6768d8d3feaf258d363.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/gollem/Makefile75
-rw-r--r--ftp/gollem/distinfo2
-rw-r--r--ftp/gollem/files/httpd.conf.gollem27
-rw-r--r--ftp/gollem/files/pkg-message.in14
-rw-r--r--ftp/gollem/pkg-deinstall27
-rw-r--r--ftp/gollem/pkg-descr5
-rw-r--r--ftp/gollem/pkg-plist146
-rw-r--r--ftp/horde-gollem/Makefile75
-rw-r--r--ftp/horde-gollem/distinfo2
-rw-r--r--ftp/horde-gollem/files/httpd.conf.gollem27
-rw-r--r--ftp/horde-gollem/files/pkg-message.in14
-rw-r--r--ftp/horde-gollem/pkg-deinstall27
-rw-r--r--ftp/horde-gollem/pkg-descr5
-rw-r--r--ftp/horde-gollem/pkg-plist146
15 files changed, 593 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 71149ecc12da..d3e6a62625b4 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -34,6 +34,7 @@
SUBDIR += ftpsearch
SUBDIR += ftptool
SUBDIR += gftp
+ SUBDIR += gollem
SUBDIR += greed
SUBDIR += gwget
SUBDIR += hsftp
diff --git a/ftp/gollem/Makefile b/ftp/gollem/Makefile
new file mode 100644
index 000000000000..7254b5f4859d
--- /dev/null
+++ b/ftp/gollem/Makefile
@@ -0,0 +1,75 @@
+# Ports collection makefile for: Gollem
+# Date created: Sun Dec 16, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= gollem
+PORTVERSION= 1.0
+CATEGORIES= ftp www
+MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
+ ftp://ftp.planetmirror.com/pub/horde/gollem/ \
+ ftp://ftp.be.horde.org/gollem/ \
+ ftp://ftp.es.horde.org/pub/gollem/ \
+ ftp://ftp.it.horde.org/pub/mirror/horde.org/gollem/ \
+ ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/gollem/ \
+ ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/gollem/\
+ http://ftp.horde.org/pub/gollem/
+DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Gollem is the Horde web-based File Manager
+
+RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
+
+DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
+ docs/RELEASE_NOTES docs/TODO
+CONFFILE= backends.php credentials.php menu.php mime_drivers.php motd.php \
+ prefs.php
+SUB_DIRS= config lib locale po templates themes
+
+LHORDEDIR?= www/horde
+LGOLLEMDIR?= ${LHORDEDIR}/gollem
+
+GOLLEMDIR= ${PREFIX}/${LGOLLEMDIR}
+CONFDIR= ${GOLLEMDIR}/config
+
+HORDE_INC= ${LOCALBASE}/etc/horde
+
+pre-configure:
+ @${SED} -e "s:/home/httpd/html/horde/gollem:${GOLLEMDIR}:g" \
+ ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd.conf.gollem
+
+do-install:
+ @${MKDIR} ${GOLLEMDIR}
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${GOLLEMDIR}
+ @${CP} -p ${WRKSRC}/*.php ${GOLLEMDIR}
+.for FILE in ${CONFFILE}
+ @if [ ! -f ${CONFDIR}/${FILE} ]; then \
+ ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
+ fi
+.endfor
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
+ @${CHMOD} -R o-rwx ${CONFDIR}
+ @${INSTALL_DATA} ${WRKDIR}/httpd.conf.gollem ${HORDE_INC}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/ftp/gollem/distinfo b/ftp/gollem/distinfo
new file mode 100644
index 000000000000..2d390b134bb5
--- /dev/null
+++ b/ftp/gollem/distinfo
@@ -0,0 +1,2 @@
+MD5 (gollem-h3-1.0.tar.gz) = 29f668de08c0672169cbe52a80dc1771
+SIZE (gollem-h3-1.0.tar.gz) = 680558
diff --git a/ftp/gollem/files/httpd.conf.gollem b/ftp/gollem/files/httpd.conf.gollem
new file mode 100644
index 000000000000..1730fcd83411
--- /dev/null
+++ b/ftp/gollem/files/httpd.conf.gollem
@@ -0,0 +1,27 @@
+# This is included in Apache's httpd.conf for Gollem
+#
+# For security, don't serve pages from the Gollem configuration and
+# library directories.
+#
+<Directory "/home/httpd/html/horde/gollem/config">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/lib">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/locale">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/po">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/templates">
+ order deny,allow
+ deny from all
+</Directory>
+# End of Gollem configuration ================
+
diff --git a/ftp/gollem/files/pkg-message.in b/ftp/gollem/files/pkg-message.in
new file mode 100644
index 000000000000..db3eed4e83d1
--- /dev/null
+++ b/ftp/gollem/files/pkg-message.in
@@ -0,0 +1,14 @@
+************************************************************************
+Gollem has been installed in %%GOLLEMDIR%% with your blank
+configuration files.
+
+Horde must be configured; if not, see `pkg_info -D -x horde'.
+
+Note: you have to configure an appropriate backend in
+%%GOLLEMDIR%%/config/backends.php.
+
+Finally, you must login to Horde as a Horde Administrator to finish the
+configuration.
+
+To protect your configuration files, you have to restart Apache.
+************************************************************************
diff --git a/ftp/gollem/pkg-deinstall b/ftp/gollem/pkg-deinstall
new file mode 100644
index 000000000000..c371d1852937
--- /dev/null
+++ b/ftp/gollem/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Gollem config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/gollem/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/ftp/gollem/pkg-descr b/ftp/gollem/pkg-descr
new file mode 100644
index 000000000000..319955592a0d
--- /dev/null
+++ b/ftp/gollem/pkg-descr
@@ -0,0 +1,5 @@
+Gollem is a web-based file manager, providing the ability to fully manage a
+hierarchical file system stored in a variety of backends such as a SQL database,
+as part of a real filesystem, or on an FTP server.
+
+WWW: http://horde.org/gollem/
diff --git a/ftp/gollem/pkg-plist b/ftp/gollem/pkg-plist
new file mode 100644
index 000000000000..1eecb60b7052
--- /dev/null
+++ b/ftp/gollem/pkg-plist
@@ -0,0 +1,146 @@
+etc/horde/httpd.conf.gollem
+%%GOLLEMDIR%%/clipboard.php
+%%GOLLEMDIR%%/config/backends.php
+%%GOLLEMDIR%%/config/backends.php.dist
+%%GOLLEMDIR%%/config/conf.xml
+%%GOLLEMDIR%%/config/credentials.php
+%%GOLLEMDIR%%/config/credentials.php.dist
+%%GOLLEMDIR%%/config/menu.php
+%%GOLLEMDIR%%/config/menu.php.dist
+%%GOLLEMDIR%%/config/mime_drivers.php
+%%GOLLEMDIR%%/config/mime_drivers.php.dist
+%%GOLLEMDIR%%/config/motd.php
+%%GOLLEMDIR%%/config/motd.php.dist
+%%GOLLEMDIR%%/config/prefs.php
+%%GOLLEMDIR%%/config/prefs.php.dist
+%%GOLLEMDIR%%/index.php
+%%GOLLEMDIR%%/lib/Auth/gollem.php
+%%GOLLEMDIR%%/lib/Block/tree_menu.php
+%%GOLLEMDIR%%/lib/Gollem.php
+%%GOLLEMDIR%%/lib/MIME/Viewer/images.php
+%%GOLLEMDIR%%/lib/Session.php
+%%GOLLEMDIR%%/lib/api.php
+%%GOLLEMDIR%%/lib/base.php
+%%GOLLEMDIR%%/lib/prefs.php
+%%GOLLEMDIR%%/lib/version.php
+%%GOLLEMDIR%%/locale/bg_BG/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/cs_CZ/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/de_DE/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/en_US/help.xml
+%%GOLLEMDIR%%/locale/es_ES/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/es_ES/help.xml
+%%GOLLEMDIR%%/locale/fi_FI/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/fi_FI/help.xml
+%%GOLLEMDIR%%/locale/fr_FR/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/hu_HU/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/hu_HU/help.xml
+%%GOLLEMDIR%%/locale/it_IT/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ko_KR/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/lv_LV/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/nl_NL/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/nn_NO/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ro_RO/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ru_RU/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/sv_SE/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/zh_TW/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/zh_TW/help.xml
+%%GOLLEMDIR%%/login.php
+%%GOLLEMDIR%%/manager.php
+%%GOLLEMDIR%%/po/README
+%%GOLLEMDIR%%/po/bg_BG.po
+%%GOLLEMDIR%%/po/cs_CZ.po
+%%GOLLEMDIR%%/po/de_DE.po
+%%GOLLEMDIR%%/po/es_ES.po
+%%GOLLEMDIR%%/po/fi_FI.po
+%%GOLLEMDIR%%/po/fr_FR.po
+%%GOLLEMDIR%%/po/gollem.pot
+%%GOLLEMDIR%%/po/hu_HU.po
+%%GOLLEMDIR%%/po/it_IT.po
+%%GOLLEMDIR%%/po/ko_KR.po
+%%GOLLEMDIR%%/po/lv_LV.po
+%%GOLLEMDIR%%/po/nl_NL.po
+%%GOLLEMDIR%%/po/nn_NO.po
+%%GOLLEMDIR%%/po/ro_RO.po
+%%GOLLEMDIR%%/po/ru_RU.po
+%%GOLLEMDIR%%/po/sv_SE.po
+%%GOLLEMDIR%%/po/zh_TW.po
+%%GOLLEMDIR%%/redirect.php
+%%GOLLEMDIR%%/selectlist.php
+%%GOLLEMDIR%%/templates/clipboard/clipboard.html
+%%GOLLEMDIR%%/templates/common-header.inc
+%%GOLLEMDIR%%/templates/javascript/open_selectlist_win.js
+%%GOLLEMDIR%%/templates/login/login.inc
+%%GOLLEMDIR%%/templates/manager/empty_dir.inc
+%%GOLLEMDIR%%/templates/manager/header.inc
+%%GOLLEMDIR%%/templates/manager/manager.html
+%%GOLLEMDIR%%/templates/menu.inc
+%%GOLLEMDIR%%/templates/prefs/columnselect.inc
+%%GOLLEMDIR%%/templates/selectlist/javascript.inc
+%%GOLLEMDIR%%/templates/selectlist/selectlist.html
+%%GOLLEMDIR%%/test.php
+%%GOLLEMDIR%%/themes/graphics/cd.png
+%%GOLLEMDIR%%/themes/graphics/clipboard.png
+%%GOLLEMDIR%%/themes/graphics/copy.png
+%%GOLLEMDIR%%/themes/graphics/cut.png
+%%GOLLEMDIR%%/themes/graphics/favicon.ico
+%%GOLLEMDIR%%/themes/graphics/gollem.png
+%%GOLLEMDIR%%/themes/graphics/home.png
+%%GOLLEMDIR%%/themes/graphics/manager/folder.png
+%%GOLLEMDIR%%/themes/graphics/manager/symlink.png
+%%GOLLEMDIR%%/themes/graphics/mkdir.png
+%%GOLLEMDIR%%/themes/purple/screen.css
+%%GOLLEMDIR%%/themes/screen.css
+%%GOLLEMDIR%%/view.php
+@dirrm %%GOLLEMDIR%%/themes/purple
+@dirrm %%GOLLEMDIR%%/themes/graphics/manager
+@dirrm %%GOLLEMDIR%%/themes/graphics
+@dirrm %%GOLLEMDIR%%/themes
+@dirrm %%GOLLEMDIR%%/templates/selectlist
+@dirrm %%GOLLEMDIR%%/templates/prefs
+@dirrm %%GOLLEMDIR%%/templates/manager
+@dirrm %%GOLLEMDIR%%/templates/login
+@dirrm %%GOLLEMDIR%%/templates/javascript
+@dirrm %%GOLLEMDIR%%/templates/clipboard
+@dirrm %%GOLLEMDIR%%/templates
+@dirrm %%GOLLEMDIR%%/po
+@dirrm %%GOLLEMDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/zh_TW
+@dirrm %%GOLLEMDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/sv_SE
+@dirrm %%GOLLEMDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ru_RU
+@dirrm %%GOLLEMDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ro_RO
+@dirrm %%GOLLEMDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/nn_NO
+@dirrm %%GOLLEMDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/nl_NL
+@dirrm %%GOLLEMDIR%%/locale/lv_LV/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/lv_LV
+@dirrm %%GOLLEMDIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ko_KR
+@dirrm %%GOLLEMDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/it_IT
+@dirrm %%GOLLEMDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/hu_HU
+@dirrm %%GOLLEMDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/fr_FR
+@dirrm %%GOLLEMDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/fi_FI
+@dirrm %%GOLLEMDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/es_ES
+@dirrm %%GOLLEMDIR%%/locale/en_US
+@dirrm %%GOLLEMDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/de_DE
+@dirrm %%GOLLEMDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/cs_CZ
+@dirrm %%GOLLEMDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/bg_BG
+@dirrm %%GOLLEMDIR%%/locale
+@dirrm %%GOLLEMDIR%%/lib/MIME/Viewer
+@dirrm %%GOLLEMDIR%%/lib/MIME
+@dirrm %%GOLLEMDIR%%/lib/Block
+@dirrm %%GOLLEMDIR%%/lib/Auth
+@dirrm %%GOLLEMDIR%%/lib
+@unexec rmdir %D/%%GOLLEMDIR%%/config 2>/dev/null || true
+@unexec rmdir %D/%%GOLLEMDIR%% 2>/dev/null || true
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
new file mode 100644
index 000000000000..7254b5f4859d
--- /dev/null
+++ b/ftp/horde-gollem/Makefile
@@ -0,0 +1,75 @@
+# Ports collection makefile for: Gollem
+# Date created: Sun Dec 16, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= gollem
+PORTVERSION= 1.0
+CATEGORIES= ftp www
+MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
+ ftp://ftp.planetmirror.com/pub/horde/gollem/ \
+ ftp://ftp.be.horde.org/gollem/ \
+ ftp://ftp.es.horde.org/pub/gollem/ \
+ ftp://ftp.it.horde.org/pub/mirror/horde.org/gollem/ \
+ ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/gollem/ \
+ ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/gollem/\
+ http://ftp.horde.org/pub/gollem/
+DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Gollem is the Horde web-based File Manager
+
+RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
+
+DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
+ docs/RELEASE_NOTES docs/TODO
+CONFFILE= backends.php credentials.php menu.php mime_drivers.php motd.php \
+ prefs.php
+SUB_DIRS= config lib locale po templates themes
+
+LHORDEDIR?= www/horde
+LGOLLEMDIR?= ${LHORDEDIR}/gollem
+
+GOLLEMDIR= ${PREFIX}/${LGOLLEMDIR}
+CONFDIR= ${GOLLEMDIR}/config
+
+HORDE_INC= ${LOCALBASE}/etc/horde
+
+pre-configure:
+ @${SED} -e "s:/home/httpd/html/horde/gollem:${GOLLEMDIR}:g" \
+ ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd.conf.gollem
+
+do-install:
+ @${MKDIR} ${GOLLEMDIR}
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${GOLLEMDIR}
+ @${CP} -p ${WRKSRC}/*.php ${GOLLEMDIR}
+.for FILE in ${CONFFILE}
+ @if [ ! -f ${CONFDIR}/${FILE} ]; then \
+ ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
+ fi
+.endfor
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
+ @${CHMOD} -R o-rwx ${CONFDIR}
+ @${INSTALL_DATA} ${WRKDIR}/httpd.conf.gollem ${HORDE_INC}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/ftp/horde-gollem/distinfo b/ftp/horde-gollem/distinfo
new file mode 100644
index 000000000000..2d390b134bb5
--- /dev/null
+++ b/ftp/horde-gollem/distinfo
@@ -0,0 +1,2 @@
+MD5 (gollem-h3-1.0.tar.gz) = 29f668de08c0672169cbe52a80dc1771
+SIZE (gollem-h3-1.0.tar.gz) = 680558
diff --git a/ftp/horde-gollem/files/httpd.conf.gollem b/ftp/horde-gollem/files/httpd.conf.gollem
new file mode 100644
index 000000000000..1730fcd83411
--- /dev/null
+++ b/ftp/horde-gollem/files/httpd.conf.gollem
@@ -0,0 +1,27 @@
+# This is included in Apache's httpd.conf for Gollem
+#
+# For security, don't serve pages from the Gollem configuration and
+# library directories.
+#
+<Directory "/home/httpd/html/horde/gollem/config">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/lib">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/locale">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/po">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/gollem/templates">
+ order deny,allow
+ deny from all
+</Directory>
+# End of Gollem configuration ================
+
diff --git a/ftp/horde-gollem/files/pkg-message.in b/ftp/horde-gollem/files/pkg-message.in
new file mode 100644
index 000000000000..db3eed4e83d1
--- /dev/null
+++ b/ftp/horde-gollem/files/pkg-message.in
@@ -0,0 +1,14 @@
+************************************************************************
+Gollem has been installed in %%GOLLEMDIR%% with your blank
+configuration files.
+
+Horde must be configured; if not, see `pkg_info -D -x horde'.
+
+Note: you have to configure an appropriate backend in
+%%GOLLEMDIR%%/config/backends.php.
+
+Finally, you must login to Horde as a Horde Administrator to finish the
+configuration.
+
+To protect your configuration files, you have to restart Apache.
+************************************************************************
diff --git a/ftp/horde-gollem/pkg-deinstall b/ftp/horde-gollem/pkg-deinstall
new file mode 100644
index 000000000000..c371d1852937
--- /dev/null
+++ b/ftp/horde-gollem/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Gollem config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/gollem/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/ftp/horde-gollem/pkg-descr b/ftp/horde-gollem/pkg-descr
new file mode 100644
index 000000000000..319955592a0d
--- /dev/null
+++ b/ftp/horde-gollem/pkg-descr
@@ -0,0 +1,5 @@
+Gollem is a web-based file manager, providing the ability to fully manage a
+hierarchical file system stored in a variety of backends such as a SQL database,
+as part of a real filesystem, or on an FTP server.
+
+WWW: http://horde.org/gollem/
diff --git a/ftp/horde-gollem/pkg-plist b/ftp/horde-gollem/pkg-plist
new file mode 100644
index 000000000000..1eecb60b7052
--- /dev/null
+++ b/ftp/horde-gollem/pkg-plist
@@ -0,0 +1,146 @@
+etc/horde/httpd.conf.gollem
+%%GOLLEMDIR%%/clipboard.php
+%%GOLLEMDIR%%/config/backends.php
+%%GOLLEMDIR%%/config/backends.php.dist
+%%GOLLEMDIR%%/config/conf.xml
+%%GOLLEMDIR%%/config/credentials.php
+%%GOLLEMDIR%%/config/credentials.php.dist
+%%GOLLEMDIR%%/config/menu.php
+%%GOLLEMDIR%%/config/menu.php.dist
+%%GOLLEMDIR%%/config/mime_drivers.php
+%%GOLLEMDIR%%/config/mime_drivers.php.dist
+%%GOLLEMDIR%%/config/motd.php
+%%GOLLEMDIR%%/config/motd.php.dist
+%%GOLLEMDIR%%/config/prefs.php
+%%GOLLEMDIR%%/config/prefs.php.dist
+%%GOLLEMDIR%%/index.php
+%%GOLLEMDIR%%/lib/Auth/gollem.php
+%%GOLLEMDIR%%/lib/Block/tree_menu.php
+%%GOLLEMDIR%%/lib/Gollem.php
+%%GOLLEMDIR%%/lib/MIME/Viewer/images.php
+%%GOLLEMDIR%%/lib/Session.php
+%%GOLLEMDIR%%/lib/api.php
+%%GOLLEMDIR%%/lib/base.php
+%%GOLLEMDIR%%/lib/prefs.php
+%%GOLLEMDIR%%/lib/version.php
+%%GOLLEMDIR%%/locale/bg_BG/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/cs_CZ/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/de_DE/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/en_US/help.xml
+%%GOLLEMDIR%%/locale/es_ES/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/es_ES/help.xml
+%%GOLLEMDIR%%/locale/fi_FI/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/fi_FI/help.xml
+%%GOLLEMDIR%%/locale/fr_FR/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/hu_HU/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/hu_HU/help.xml
+%%GOLLEMDIR%%/locale/it_IT/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ko_KR/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/lv_LV/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/nl_NL/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/nn_NO/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ro_RO/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/ru_RU/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/sv_SE/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/zh_TW/LC_MESSAGES/gollem.mo
+%%GOLLEMDIR%%/locale/zh_TW/help.xml
+%%GOLLEMDIR%%/login.php
+%%GOLLEMDIR%%/manager.php
+%%GOLLEMDIR%%/po/README
+%%GOLLEMDIR%%/po/bg_BG.po
+%%GOLLEMDIR%%/po/cs_CZ.po
+%%GOLLEMDIR%%/po/de_DE.po
+%%GOLLEMDIR%%/po/es_ES.po
+%%GOLLEMDIR%%/po/fi_FI.po
+%%GOLLEMDIR%%/po/fr_FR.po
+%%GOLLEMDIR%%/po/gollem.pot
+%%GOLLEMDIR%%/po/hu_HU.po
+%%GOLLEMDIR%%/po/it_IT.po
+%%GOLLEMDIR%%/po/ko_KR.po
+%%GOLLEMDIR%%/po/lv_LV.po
+%%GOLLEMDIR%%/po/nl_NL.po
+%%GOLLEMDIR%%/po/nn_NO.po
+%%GOLLEMDIR%%/po/ro_RO.po
+%%GOLLEMDIR%%/po/ru_RU.po
+%%GOLLEMDIR%%/po/sv_SE.po
+%%GOLLEMDIR%%/po/zh_TW.po
+%%GOLLEMDIR%%/redirect.php
+%%GOLLEMDIR%%/selectlist.php
+%%GOLLEMDIR%%/templates/clipboard/clipboard.html
+%%GOLLEMDIR%%/templates/common-header.inc
+%%GOLLEMDIR%%/templates/javascript/open_selectlist_win.js
+%%GOLLEMDIR%%/templates/login/login.inc
+%%GOLLEMDIR%%/templates/manager/empty_dir.inc
+%%GOLLEMDIR%%/templates/manager/header.inc
+%%GOLLEMDIR%%/templates/manager/manager.html
+%%GOLLEMDIR%%/templates/menu.inc
+%%GOLLEMDIR%%/templates/prefs/columnselect.inc
+%%GOLLEMDIR%%/templates/selectlist/javascript.inc
+%%GOLLEMDIR%%/templates/selectlist/selectlist.html
+%%GOLLEMDIR%%/test.php
+%%GOLLEMDIR%%/themes/graphics/cd.png
+%%GOLLEMDIR%%/themes/graphics/clipboard.png
+%%GOLLEMDIR%%/themes/graphics/copy.png
+%%GOLLEMDIR%%/themes/graphics/cut.png
+%%GOLLEMDIR%%/themes/graphics/favicon.ico
+%%GOLLEMDIR%%/themes/graphics/gollem.png
+%%GOLLEMDIR%%/themes/graphics/home.png
+%%GOLLEMDIR%%/themes/graphics/manager/folder.png
+%%GOLLEMDIR%%/themes/graphics/manager/symlink.png
+%%GOLLEMDIR%%/themes/graphics/mkdir.png
+%%GOLLEMDIR%%/themes/purple/screen.css
+%%GOLLEMDIR%%/themes/screen.css
+%%GOLLEMDIR%%/view.php
+@dirrm %%GOLLEMDIR%%/themes/purple
+@dirrm %%GOLLEMDIR%%/themes/graphics/manager
+@dirrm %%GOLLEMDIR%%/themes/graphics
+@dirrm %%GOLLEMDIR%%/themes
+@dirrm %%GOLLEMDIR%%/templates/selectlist
+@dirrm %%GOLLEMDIR%%/templates/prefs
+@dirrm %%GOLLEMDIR%%/templates/manager
+@dirrm %%GOLLEMDIR%%/templates/login
+@dirrm %%GOLLEMDIR%%/templates/javascript
+@dirrm %%GOLLEMDIR%%/templates/clipboard
+@dirrm %%GOLLEMDIR%%/templates
+@dirrm %%GOLLEMDIR%%/po
+@dirrm %%GOLLEMDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/zh_TW
+@dirrm %%GOLLEMDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/sv_SE
+@dirrm %%GOLLEMDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ru_RU
+@dirrm %%GOLLEMDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ro_RO
+@dirrm %%GOLLEMDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/nn_NO
+@dirrm %%GOLLEMDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/nl_NL
+@dirrm %%GOLLEMDIR%%/locale/lv_LV/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/lv_LV
+@dirrm %%GOLLEMDIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/ko_KR
+@dirrm %%GOLLEMDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/it_IT
+@dirrm %%GOLLEMDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/hu_HU
+@dirrm %%GOLLEMDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/fr_FR
+@dirrm %%GOLLEMDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/fi_FI
+@dirrm %%GOLLEMDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/es_ES
+@dirrm %%GOLLEMDIR%%/locale/en_US
+@dirrm %%GOLLEMDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/de_DE
+@dirrm %%GOLLEMDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/cs_CZ
+@dirrm %%GOLLEMDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%GOLLEMDIR%%/locale/bg_BG
+@dirrm %%GOLLEMDIR%%/locale
+@dirrm %%GOLLEMDIR%%/lib/MIME/Viewer
+@dirrm %%GOLLEMDIR%%/lib/MIME
+@dirrm %%GOLLEMDIR%%/lib/Block
+@dirrm %%GOLLEMDIR%%/lib/Auth
+@dirrm %%GOLLEMDIR%%/lib
+@unexec rmdir %D/%%GOLLEMDIR%%/config 2>/dev/null || true
+@unexec rmdir %D/%%GOLLEMDIR%% 2>/dev/null || true