aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /ftp
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.tar.gz
ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile2
-rw-r--r--ftp/php56-curl/Makefile10
-rw-r--r--ftp/php56-ftp/Makefile14
3 files changed, 26 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 12575512917a..58f0b28dcfca 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -68,6 +68,8 @@
SUBDIR += php53-ftp
SUBDIR += php55-curl
SUBDIR += php55-ftp
+ SUBDIR += php56-curl
+ SUBDIR += php56-ftp
SUBDIR += phpwebftp
SUBDIR += plasma-applet-ftpmonitor
SUBDIR += proftpd
diff --git a/ftp/php56-curl/Makefile b/ftp/php56-curl/Makefile
new file mode 100644
index 000000000000..ec356c2b0428
--- /dev/null
+++ b/ftp/php56-curl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -curl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php56-ftp/Makefile b/ftp/php56-ftp/Makefile
new file mode 100644
index 000000000000..e0f3d951182e
--- /dev/null
+++ b/ftp/php56-ftp/Makefile
@@ -0,0 +1,14 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -ftp
+
+post-patch:
+ @${REINPLACE_CMD} s/HAVE_OPENSSL_EXT/__FreeBSD__/ \
+ ${WRKSRC}/ftp.* ${WRKSRC}/php_ftp.*
+
+.include "${MASTERDIR}/Makefile"