aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-09-10 07:02:52 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-09-10 07:02:52 +0000
commitf90ffe59a02766d774c7f80afff822b420df4578 (patch)
treee78182fe8e8c0b8d4a41dd0bfce687b470e119a9 /ftp
parent6f8098a9a4955f7022d20e02c4608fb4a2daeb75 (diff)
downloadports-f90ffe59a02766d774c7f80afff822b420df4578.tar.gz
ports-f90ffe59a02766d774c7f80afff822b420df4578.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 6dcc80015c52..4df6ca4cd3c5 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -16,7 +16,7 @@ MASTER_SITES= http://curl.haxx.se/download/ \
MASTER_SITE_SUBDIR= curl
MAINTAINER= roam@FreeBSD.org
-COMMENT= "Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers"
+COMMENT= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
MAN1= curl.1 curl-config.1
MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 curl_easy_getinfo.3 \
@@ -51,6 +51,11 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64" || ${ARCH} == "alpha" || ${ARCH} == "ia64" || \
+ ${ARCH} == "powerpc"
+BROKEN= "DNS resolution problems on 64-bit machines"
+.endif
+
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.else
@@ -61,7 +66,7 @@ CONFIGURE_ARGS= --without-ssl
CONFIGURE_ARGS += --with-krb4=/usr
.endif
-# Note: some of these tests seem to intermitently fail on my system.
+# Note: some of these tests seem to intermittently fail on my system.
# I don't know why they would do that, yet.
test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test