aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-17 04:12:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-17 04:12:10 +0000
commitaa55e5e1f3ce84fb16c0b19de7f665390b50a682 (patch)
tree56c6bc145ca6de1d9215f6d764901eb7061ff45d /ftp
parent260fecbd52c3c84e3031aa7a8802a83ac04ba783 (diff)
downloadports-aa55e5e1f3ce84fb16c0b19de7f665390b50a682.tar.gz
ports-aa55e5e1f3ce84fb16c0b19de7f665390b50a682.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/p5-curl/Makefile23
-rw-r--r--ftp/p5-curl/distinfo2
-rw-r--r--ftp/p5-curl/pkg-descr5
-rw-r--r--ftp/p5-curl/pkg-plist12
5 files changed, 43 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index f1ba81f177de..673c9e953ba9 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -66,6 +66,7 @@
SUBDIR += p5-Net-FTPServer
SUBDIR += p5-POE-Component-Client-FTP
SUBDIR += p5-SOAP-Transport-FTP
+ SUBDIR += p5-curl
SUBDIR += paraget
SUBDIR += pavuk
SUBDIR += pear-Net_FTP
diff --git a/ftp/p5-curl/Makefile b/ftp/p5-curl/Makefile
new file mode 100644
index 000000000000..29c5f9f6939e
--- /dev/null
+++ b/ftp/p5-curl/Makefile
@@ -0,0 +1,23 @@
+# Created by: Jason Harris <jharris@widomaker.com>
+# $FreeBSD$
+
+PORTNAME= p5-curl
+PORTVERSION= 4.15
+CATEGORIES= ftp www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SZ/SZBALINT
+DISTNAME= WWW-Curl-${PORTVERSION}${EXTRACT_SUFFIX}
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to libcurl
+
+LICENSE= ART10
+
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Curl.3
+
+.include <bsd.port.mk>
diff --git a/ftp/p5-curl/distinfo b/ftp/p5-curl/distinfo
new file mode 100644
index 000000000000..1655be78b0fd
--- /dev/null
+++ b/ftp/p5-curl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-Curl-4.15.tar.gz) = 3ef40494537a1ce7f848f3b524f5690cf47db458c0bb662e15c4642dc13c5fa1
+SIZE (WWW-Curl-4.15.tar.gz) = 53741
diff --git a/ftp/p5-curl/pkg-descr b/ftp/p5-curl/pkg-descr
new file mode 100644
index 000000000000..e9f863bd9fcf
--- /dev/null
+++ b/ftp/p5-curl/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a Perl interface to libcurl. It is not intended to be
+a standalone module and because of this, the main libcurl documentation
+should be consulted for API details at http://curl.haxx.se/.
+
+WWW: http://search.cpan.org/dist/WWW-Curl/
diff --git a/ftp/p5-curl/pkg-plist b/ftp/p5-curl/pkg-plist
new file mode 100644
index 000000000000..fbf5e4e2157b
--- /dev/null
+++ b/ftp/p5-curl/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl/Easy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl/Form.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl/Multi.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl/Share.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Curl/Curl.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Curl/Curl.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Curl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Curl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/WWW/Curl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/WWW