aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-26 18:39:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-26 18:39:15 +0000
commitf8105b37527ea59431b6085c0c386e13a35228d7 (patch)
tree31c8ec28a593453cb050999ae40b607f4d4d047c /ftp
parentc857393ce1da3e31c9d911bded042a3a0a92b751 (diff)
downloadports-f8105b37527ea59431b6085c0c386e13a35228d7.tar.gz
ports-f8105b37527ea59431b6085c0c386e13a35228d7.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile8
-rw-r--r--ftp/proftpd-devel/files/extra_patch-configure.in37
-rw-r--r--ftp/proftpd/Makefile8
-rw-r--r--ftp/proftpd/files/extra_patch-configure.in37
4 files changed, 82 insertions, 8 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 4147ba2b4386..080195355a9b 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -58,9 +58,9 @@ MODULES?=
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-.if exists (${LOCALBASE}/include/getopt.h)
-BROKEN= Does not build when libgnugetopt is installed
-.endif
+CONFIGURE_ARGS+= --without-getopt
+EXTRA_PATCHES= ${FILESDIR}/extra_patch-configure.in
+USE_AUTOTOOLS= autoconf:259
.endif
.if !defined(WITHOUT_RATIO)
@@ -133,7 +133,7 @@ USE_OPENSSL= yes
PROFTPD_LIBS+= -lssl -lcrypto -L${LOCALBASE}/lib
MODULES:=${MODULES}:mod_tls
.if defined(WITH_LDAP_TLS)
-EXTRA_PATCHES=${FILESDIR}/extra_patch-ldap-tls-mod_ldap.c
+EXTRA_PATCHES+= ${FILESDIR}/extra_patch-ldap-tls-mod_ldap.c
.endif
.endif
diff --git a/ftp/proftpd-devel/files/extra_patch-configure.in b/ftp/proftpd-devel/files/extra_patch-configure.in
new file mode 100644
index 000000000000..c40394099c3b
--- /dev/null
+++ b/ftp/proftpd-devel/files/extra_patch-configure.in
@@ -0,0 +1,37 @@
+--- configure.in Thu Mar 9 09:12:35 2006
++++ configure.in Mon May 22 15:01:23 2006
+@@ -161,12 +161,14 @@
+ [
+ if test "$withval" != "no" ; then
+ LIB_OBJS="$LIB_OBJS getopt.o getopt1.o"
+- AC_CHECK_FUNCS(getopt)
++ AC_CHECK_FUNCS(getopt getopt_long)
++ AC_CHECK_HEADERS(getopt.h)
+ fi
+ ],
+ [
+ LIB_OBJS="$LIB_OBJS getopt.o getopt1.o"
+- AC_CHECK_FUNCS(getopt)
++ AC_CHECK_FUNCS(getopt getopt_long)
++ AC_CHECK_HEADERS(getopt.h)
+ ])
+
+ dnl Modules...'nuff said.
+@@ -850,7 +852,7 @@
+ ac_build_static_modules="modules/mod_cap.o $ac_build_static_modules"
+ fi
+
+-AC_CHECK_HEADERS(ctype.h getopt.h crypt.h bstring.h iconv.h inttypes.h langinfo.h limits.h)
++AC_CHECK_HEADERS(ctype.h crypt.h bstring.h iconv.h inttypes.h langinfo.h limits.h)
+ AC_CHECK_HEADERS(string.h strings.h stropts.h)
+ AC_CHECK_HEADERS(sys/file.h sys/mman.h sys/types.h sys/uio.h)
+
+@@ -1110,7 +1112,7 @@
+ )
+
+ AC_CHECK_FUNCS(getcwd getenv gethostbyname2 gethostname getnameinfo)
+-AC_CHECK_FUNCS(getopt_long gettimeofday hstrerror inet_aton inet_ntop inet_pton)
++AC_CHECK_FUNCS(gettimeofday hstrerror inet_aton inet_ntop inet_pton)
+ AC_CHECK_FUNCS(memcpy mempcpy mkdir mkstemp mlock mlockall munlock munlockall)
+ AC_CHECK_FUNCS(rmdir select setgroups socket statfs strchr strcoll strerror)
+ AC_CHECK_FUNCS(strsep strtol strtoull setprotoent setspent endprotoent)
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 4147ba2b4386..080195355a9b 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -58,9 +58,9 @@ MODULES?=
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-.if exists (${LOCALBASE}/include/getopt.h)
-BROKEN= Does not build when libgnugetopt is installed
-.endif
+CONFIGURE_ARGS+= --without-getopt
+EXTRA_PATCHES= ${FILESDIR}/extra_patch-configure.in
+USE_AUTOTOOLS= autoconf:259
.endif
.if !defined(WITHOUT_RATIO)
@@ -133,7 +133,7 @@ USE_OPENSSL= yes
PROFTPD_LIBS+= -lssl -lcrypto -L${LOCALBASE}/lib
MODULES:=${MODULES}:mod_tls
.if defined(WITH_LDAP_TLS)
-EXTRA_PATCHES=${FILESDIR}/extra_patch-ldap-tls-mod_ldap.c
+EXTRA_PATCHES+= ${FILESDIR}/extra_patch-ldap-tls-mod_ldap.c
.endif
.endif
diff --git a/ftp/proftpd/files/extra_patch-configure.in b/ftp/proftpd/files/extra_patch-configure.in
new file mode 100644
index 000000000000..c40394099c3b
--- /dev/null
+++ b/ftp/proftpd/files/extra_patch-configure.in
@@ -0,0 +1,37 @@
+--- configure.in Thu Mar 9 09:12:35 2006
++++ configure.in Mon May 22 15:01:23 2006
+@@ -161,12 +161,14 @@
+ [
+ if test "$withval" != "no" ; then
+ LIB_OBJS="$LIB_OBJS getopt.o getopt1.o"
+- AC_CHECK_FUNCS(getopt)
++ AC_CHECK_FUNCS(getopt getopt_long)
++ AC_CHECK_HEADERS(getopt.h)
+ fi
+ ],
+ [
+ LIB_OBJS="$LIB_OBJS getopt.o getopt1.o"
+- AC_CHECK_FUNCS(getopt)
++ AC_CHECK_FUNCS(getopt getopt_long)
++ AC_CHECK_HEADERS(getopt.h)
+ ])
+
+ dnl Modules...'nuff said.
+@@ -850,7 +852,7 @@
+ ac_build_static_modules="modules/mod_cap.o $ac_build_static_modules"
+ fi
+
+-AC_CHECK_HEADERS(ctype.h getopt.h crypt.h bstring.h iconv.h inttypes.h langinfo.h limits.h)
++AC_CHECK_HEADERS(ctype.h crypt.h bstring.h iconv.h inttypes.h langinfo.h limits.h)
+ AC_CHECK_HEADERS(string.h strings.h stropts.h)
+ AC_CHECK_HEADERS(sys/file.h sys/mman.h sys/types.h sys/uio.h)
+
+@@ -1110,7 +1112,7 @@
+ )
+
+ AC_CHECK_FUNCS(getcwd getenv gethostbyname2 gethostname getnameinfo)
+-AC_CHECK_FUNCS(getopt_long gettimeofday hstrerror inet_aton inet_ntop inet_pton)
++AC_CHECK_FUNCS(gettimeofday hstrerror inet_aton inet_ntop inet_pton)
+ AC_CHECK_FUNCS(memcpy mempcpy mkdir mkstemp mlock mlockall munlock munlockall)
+ AC_CHECK_FUNCS(rmdir select setgroups socket statfs strchr strcoll strerror)
+ AC_CHECK_FUNCS(strsep strtol strtoull setprotoent setspent endprotoent)