aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-02 17:41:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-02 18:14:05 +0000
commit2cec12a382cab25393dfb8ac288148dd0490964d (patch)
tree2880cae59e00e7c349d446e1311fc9e0a5e80499 /ftp
parent1af2e4eafcf061b42d75371ffd4ac7c75f9bf217 (diff)
downloadports-2cec12a382cab25393dfb8ac288148dd0490964d.tar.gz
ports-2cec12a382cab25393dfb8ac288148dd0490964d.zip
ftp/fineftp-server: New port: C++ minimal FTP server library
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/fineftp-server/Makefile23
-rw-r--r--ftp/fineftp-server/distinfo3
-rw-r--r--ftp/fineftp-server/pkg-descr15
-rw-r--r--ftp/fineftp-server/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 73d4bf20066d..927c8e8f9344 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -14,6 +14,7 @@
SUBDIR += dmachine
SUBDIR += fastdfs
SUBDIR += filezilla
+ SUBDIR += fineftp-server
SUBDIR += fmirror
SUBDIR += fpc-libcurl
SUBDIR += freebsd-ftpd
diff --git a/ftp/fineftp-server/Makefile b/ftp/fineftp-server/Makefile
new file mode 100644
index 000000000000..2191f0dcec08
--- /dev/null
+++ b/ftp/fineftp-server/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= fineftp-server
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.13
+CATEGORIES= ftp
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ minimal FTP server library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= asio>0:net/asio
+RUN_DEPENDS= asio>0:net/asio
+
+USES= cmake compiler:c++14-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= continental
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>
diff --git a/ftp/fineftp-server/distinfo b/ftp/fineftp-server/distinfo
new file mode 100644
index 000000000000..551c112faac6
--- /dev/null
+++ b/ftp/fineftp-server/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630603655
+SHA256 (continental-fineftp-server-v1.0.13_GH0.tar.gz) = 6aaf0748796ac474a2caa9382b9370deb668478e2fd7b583c45f7374fed5b5e2
+SIZE (continental-fineftp-server-v1.0.13_GH0.tar.gz) = 23842
diff --git a/ftp/fineftp-server/pkg-descr b/ftp/fineftp-server/pkg-descr
new file mode 100644
index 000000000000..c38591adffe7
--- /dev/null
+++ b/ftp/fineftp-server/pkg-descr
@@ -0,0 +1,15 @@
+FineFTP is a minimal FTP server library for Windows and Unix flavors.
+
+You can easily embed this library into your own project in order to create an
+embedded FTP Server.
+
+Features:
+* FTP Passive mode (the only mode you need nowadays)
+* Listing directories
+* Uploading and downloading files
+* Creating and removing files and directories
+* User authentication (and anonymous user without authentication)
+* Individual local home path for each user
+* Access control on a per-user-basis
+
+WWW: https://github.com/continental/fineftp-server
diff --git a/ftp/fineftp-server/pkg-plist b/ftp/fineftp-server/pkg-plist
new file mode 100644
index 000000000000..6d39dcdd1b48
--- /dev/null
+++ b/ftp/fineftp-server/pkg-plist
@@ -0,0 +1,8 @@
+include/fineftp/permissions.h
+include/fineftp/server.h
+lib/cmake/fineftp/fineftpConfig.cmake
+lib/cmake/fineftp/fineftpTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/fineftp/fineftpTargets.cmake
+lib/libfineftp-server.so
+lib/libfineftp-server.so.1
+lib/libfineftp-server.so.1.0.11