aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-30 13:46:46 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-30 13:46:46 +0000
commit7906924b7e8c8636f73b8cf2c64f3a83ca7be721 (patch)
treeae8bdb33480eea4f1643428e87ed078aa8b39648 /ftp
parent34ab4f9ae7b2f236f6efa54a10223e174df5d904 (diff)
downloadports-7906924b7e8c8636f73b8cf2c64f3a83ca7be721.tar.gz
ports-7906924b7e8c8636f73b8cf2c64f3a83ca7be721.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/IglooFTP/Makefile3
-rw-r--r--ftp/axyftp/Makefile3
-rw-r--r--ftp/downloader/Makefile4
-rw-r--r--ftp/pavuk/Makefile7
4 files changed, 10 insertions, 7 deletions
diff --git a/ftp/IglooFTP/Makefile b/ftp/IglooFTP/Makefile
index 762fc976bfd1..11eb56fda463 100644
--- a/ftp/IglooFTP/Makefile
+++ b/ftp/IglooFTP/Makefile
@@ -18,7 +18,8 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
post-extract:
@${RM} ${WRKSRC}/../share/docs/LICENSE~
diff --git a/ftp/axyftp/Makefile b/ftp/axyftp/Makefile
index 5ee67842a44e..fe441a74b7ff 100644
--- a/ftp/axyftp/Makefile
+++ b/ftp/axyftp/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= kris@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
MAN1= axyftp.1
diff --git a/ftp/downloader/Makefile b/ftp/downloader/Makefile
index 84e75ceb08b8..9aa736ccc20d 100644
--- a/ftp/downloader/Makefile
+++ b/ftp/downloader/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
USE_REINPLACE= yes
-USE_GTK= yes
-USE_ESOUND= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 esound
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index 8a617649eacc..36a35fb65569 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -20,7 +20,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
USE_REINPLACE= yes
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -32,8 +33,8 @@ MAN1= pavuk.1
.include <bsd.port.pre.mk>
-.if defined(HAVE_GTK)
-USE_GTK= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME= gtk12
CONFIGURE_ARGS+= --with-gtk-config="${GTK_CONFIG}"
.else
CONFIGURE_ARGS+= --disable-gtk