aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-21 17:36:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-21 17:36:35 +0000
commit463f3f9915d61ef02a42455ef5a4aae3ebbd1a94 (patch)
treecfad31893835c1009e7d9ff8dd72952e3868b7d9 /ftp
parentcdfa1a71194178dba67d170ecf5063640bb0caf3 (diff)
downloadports-463f3f9915d61ef02a42455ef5a4aae3ebbd1a94.tar.gz
ports-463f3f9915d61ef02a42455ef5a4aae3ebbd1a94.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 0ec184b86c19..43277ce354e5 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -20,7 +20,7 @@ OPTIONS_SUB= yes
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL=GNUTLS OPENSSL
-OPTIONS_DEFINE= IPV6 NLS IDN PCRE
+OPTIONS_DEFINE= IPV6 NLS IDN METALINK PCRE PSL
OPTIONS_DEFAULT=OPENSSL IDN
PCRE_DESC= Support Perl regular expressions in addition to POSIX
@@ -37,11 +37,17 @@ IDN_LIB_DEPENDS= libidn.so:dns/libidn
IDN_CONFIGURE_ENABLE= iri
IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}
+METALINK_CONFIGURE_WITH=metalink
+METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
+
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PCRE_CPPFLAGS= -I${LOCALBASE}/include
PCRE_LDFLAGS= -L${LOCALBASE}/lib
PCRE_CONFIGURE_ENV_OFF= ac_cv_header_pcre_h=no
+PSL_CONFIGURE_WITH= libpsl
+PSL_LIB_DEPENDS= libpsl.so:dns/libpsl
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}