aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-08 14:23:53 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-08 15:30:55 +0000
commitfecc06b7b1637568a0fe899a3474eade15555f56 (patch)
treebc90668272cdc47bcd6e525dbd30ec0169352c1f /ftp
parentaceb4c1a38f30b98ba489db2f9177c641bfe0a29 (diff)
downloadports-fecc06b7b1637568a0fe899a3474eade15555f56.tar.gz
ports-fecc06b7b1637568a0fe899a3474eade15555f56.zip
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wput/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index f57270f7e485..fa4d05f13416 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -11,24 +11,32 @@ WWW= http://wput.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-PORTDOCS= ABOUT-NLS COPYING ChangeLog INSTALL TODO
-PORTEXAMPLES= USAGE.examples USAGE.resumehandling USAGE.urlhandling \
- passwordfile wputrc
-
USES= tar:tgz
+
GNU_CONFIGURE= yes
+
MAKE_JOBS_UNSAFE=yes
+PORTDOCS= ABOUT-NLS COPYING ChangeLog INSTALL TODO
+PORTEXAMPLES= USAGE.examples USAGE.resumehandling USAGE.urlhandling \
+ passwordfile wputrc
+
OPTIONS_DEFINE= TLS NLS DOCS EXAMPLES
OPTIONS_DEFAULT=TLS
OPTIONS_SUB= yes
-TLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-TLS_CONFIGURE_WITH= ssl
NLS_USES= gettext iconv
+NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_WITH= libintl-prefix=${LOCALBASE}
-NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
+TLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+TLS_CONFIGURE_WITH= ssl
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
pre-configure:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
@@ -43,4 +51,4 @@ post-install:
@${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>