aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2009-06-19 11:36:14 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2009-06-19 11:36:14 +0000
commit99019865cc8fd04060fc0d179db8edc29cc0ae84 (patch)
tree6e9456ff946e7e4fe63e79b5a515862cdb16f843 /ftp
parent803f2e171da2d5727aaedb03f2d56cf522404635 (diff)
downloadports-99019865cc8fd04060fc0d179db8edc29cc0ae84.tar.gz
ports-99019865cc8fd04060fc0d179db8edc29cc0ae84.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/uftp/Makefile5
-rw-r--r--ftp/uftp/distinfo6
-rw-r--r--ftp/uftp/files/patch-Makefile32
3 files changed, 20 insertions, 23 deletions
diff --git a/ftp/uftp/Makefile b/ftp/uftp/Makefile
index 66e58a122a6e..bc33f247877c 100644
--- a/ftp/uftp/Makefile
+++ b/ftp/uftp/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= uftp
-PORTVERSION= 2.9.1
+PORTVERSION= 2.8.1
+PORTEPOCH= 1
CATEGORIES= ftp
MASTER_SITES= http://www.tcnj.edu/~bush/
DISTNAME= uftp
@@ -16,8 +17,6 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
COMMENT= A multicast capable FTP client and server
-USE_GMAKE= yes
-MAKEFILE= makefile
WRKSRC= ${WRKDIR}
PLIST_FILES= bin/uftp bin/uftpd
diff --git a/ftp/uftp/distinfo b/ftp/uftp/distinfo
index 68033078808b..bb6d16434ab7 100644
--- a/ftp/uftp/distinfo
+++ b/ftp/uftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (uftp-2.9.1/uftp.tar) = c8b9b87cac29d66edb168b6917a59289
-SHA256 (uftp-2.9.1/uftp.tar) = 1d3eec68835f7687225c828301cda3f85b9836b086b5f1ca9c4f9f57e36bb6be
-SIZE (uftp-2.9.1/uftp.tar) = 163840
+MD5 (uftp-2.8.1/uftp.tar) = 5873267aa7c3af5576964890231a33ef
+SHA256 (uftp-2.8.1/uftp.tar) = 6bd7a4e7b16a6efc04df45b53d344bb03e30af7e1d0a4ef43d92e9f13b4c0616
+SIZE (uftp-2.8.1/uftp.tar) = 163840
diff --git a/ftp/uftp/files/patch-Makefile b/ftp/uftp/files/patch-Makefile
index 1058b447688e..b695973f8ca6 100644
--- a/ftp/uftp/files/patch-Makefile
+++ b/ftp/uftp/files/patch-Makefile
@@ -1,17 +1,15 @@
---- makefile.orig 2009-06-14 04:29:21.000000000 +0400
-+++ makefile 2009-06-17 13:58:51.000000000 +0400
-@@ -1,10 +1,10 @@
- UNAME_S:=$(shell uname -s)
-
- # defaults
--CC = gcc
--OPTIONS=-g -Wall
--LDLIBS=-lc -lm
--CFLAGS=
-+CC ?= gcc
-+OPTIONS=
-+LDLIBS=-lm
-+CFLAGS?=
-
- # Sun
- ifeq ("SunOS", "$(UNAME_S)")
+*** /dev/null Wed Jun 4 14:07:15 2008
+--- Makefile Wed Jun 4 14:07:49 2008
+***************
+*** 0 ****
+--- 1,10 ----
++ #
++ # Makefile for uftp client and server
++ #
++ all: uftp uftpd
++
++ uftp: uftp.c
++ ${CC} ${CFLAGS} -o $@ $< -lm
++
++ uftpd: uftpd.c
++ ${CC} ${CFLAGS} -o $@ $< -lm