aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2015-03-06 20:00:38 +0000
committerVasil Dimov <vd@FreeBSD.org>2015-03-06 20:00:38 +0000
commit4858b738d590ad094d105d1339e0847184e4fca4 (patch)
tree7f8527e42cdf917620e4946063884fbd822ebe0b /ftp
parentdf0538693a710eb1ae328ba1e0a9af11d38ef2a9 (diff)
downloadports-4858b738d590ad094d105d1339e0847184e4fca4.tar.gz
ports-4858b738d590ad094d105d1339e0847184e4fca4.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile1
-rw-r--r--ftp/wget/files/patch-src__main.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 6ed9b8096ca4..b9f7ae4a4e20 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wget
DISTVERSION= 1.16.2
+PORTREVISION= 1
CATEGORIES= ftp www ipv6
MASTER_SITES= GNU
diff --git a/ftp/wget/files/patch-src__main.c b/ftp/wget/files/patch-src__main.c
new file mode 100644
index 000000000000..b2ba45411b09
--- /dev/null
+++ b/ftp/wget/files/patch-src__main.c
@@ -0,0 +1,12 @@
+--- src/main.c.orig 2015-02-10 23:31:49.000000000 +0200
++++ src/main.c 2015-03-06 21:55:03.975252490 +0200
+@@ -1272,6 +1272,9 @@
+ if (opt.verbose == -1)
+ opt.verbose = !opt.quiet;
+
++ if (opt.quiet && opt.show_progress == -1)
++ opt.show_progress = false;
++
+ /* Sanity checks. */
+ if (opt.verbose && opt.quiet)
+ {