aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-27 20:59:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-27 20:59:10 +0000
commita75096fe230dda21a4b73194facc3f1ab5f467fe (patch)
treea44e7a3af303a6935133eb003eb9fd95d983b9b4 /ftp
parentb238eda0bef00682b5ba37e431053160d524b98d (diff)
downloadports-a75096fe230dda21a4b73194facc3f1ab5f467fe.tar.gz
ports-a75096fe230dda21a4b73194facc3f1ab5f467fe.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile2
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-lib-hostcheck.h10
3 files changed, 13 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 6129fb017185..4fcedfd6b1ee 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.35.0
+PORTVERSION= 7.36.0
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index feb2d6e46ac3..1e5208be7e29 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.35.0.tar.lzma) = 6929640f1e22901cbc853c67c78f25d9e7be0934771a3c3b3582846520678593
-SIZE (curl-7.35.0.tar.lzma) = 2271674
+SHA256 (curl-7.36.0.tar.lzma) = 94126649f4f12d3332ca1185559ec5faca6929227e794387b7b82b73714b388a
+SIZE (curl-7.36.0.tar.lzma) = 2276862
diff --git a/ftp/curl/files/patch-lib-hostcheck.h b/ftp/curl/files/patch-lib-hostcheck.h
new file mode 100644
index 000000000000..af6dd50f0da7
--- /dev/null
+++ b/ftp/curl/files/patch-lib-hostcheck.h
@@ -0,0 +1,10 @@
+--- lib/hostcheck.h.orig 2013-09-09 06:11:15.000000000 +0800
++++ lib/hostcheck.h 2014-03-28 00:39:25.052513814 +0800
+@@ -23,6 +23,7 @@
+ ***************************************************************************/
+
+ #include <curl/curl.h>
++#include <netinet/in.h>
+
+ #define CURL_HOST_NOMATCH 0
+ #define CURL_HOST_MATCH 1