aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2024-03-01 19:11:03 +0000
committerCy Schubert <cy@FreeBSD.org>2024-03-01 21:11:17 +0000
commite9926bc04bd21faf003b2a675178dcf51c87dffc (patch)
treed88c2c117eeea8caf72d989537538275b68a3f8e /ftp
parent2bf0dc40bdce3f025da2fe5467040a4ffde7e34c (diff)
downloadports-e9926bc04bd21faf003b2a675178dcf51c87dffc.tar.gz
ports-e9926bc04bd21faf003b2a675178dcf51c87dffc.zip
ftp/mirror: move man pages
Diffstat (limited to 'ftp')
-rw-r--r--ftp/mirror/Makefile2
-rw-r--r--ftp/mirror/files/patch-makefile125
-rw-r--r--ftp/mirror/pkg-plist4
3 files changed, 55 insertions, 76 deletions
diff --git a/ftp/mirror/Makefile b/ftp/mirror/Makefile
index 63aaf3d1eadd..f12e06c56be2 100644
--- a/ftp/mirror/Makefile
+++ b/ftp/mirror/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mirror
PORTVERSION= 2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp
MASTER_SITES= http://cschubert.com/distfiles/ \
LOCAL/cy
diff --git a/ftp/mirror/files/patch-makefile b/ftp/mirror/files/patch-makefile
index 2022f100181d..5da144956021 100644
--- a/ftp/mirror/files/patch-makefile
+++ b/ftp/mirror/files/patch-makefile
@@ -1,73 +1,52 @@
-*** makefile.orig Mon Jun 1 20:28:47 1998
---- makefile Mon Jun 8 13:59:10 1998
-***************
-*** 41,47 ****
- $(WEBFILES)
-
- all:
-! echo try make mirror.tar
-
- mirror.tar: $(FILES)
- rev=`./mirror.pl -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
---- 41,47 ----
- $(WEBFILES)
-
- all:
-! # echo try make mirror.tar
-
- mirror.tar: $(FILES)
- rev=`./mirror.pl -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
-***************
-*** 65,89 ****
- # mode to install executables
- EXMODE = 755
- # group to own all the files
-! GRP = gnu
- # directory to install .pl (perl library) files
-! PLDIR = /usr/local/perl5/lib/perl5
- # directory to install public executables
-! BINDIR = /usr/local/sbin
- # directory to install man pages
-! MANDIR = /usr/local/man/man1
-
- install:
-! install -m $(PLMODE) -g $(GRP) lchat.pl $(PLDIR)
-! install -m $(PLMODE) -g $(GRP) dateconv.pl $(PLDIR)
-! install -m $(PLMODE) -g $(GRP) ftp.pl $(PLDIR)
-! install -m $(PLMODE) -g $(GRP) lsparse.pl $(PLDIR)
-! install -m $(EXMODE) -g $(GRP) mirror.pl $(BINDIR)/mirror
-! install -m $(EXMODE) -g $(GRP) do_unlinks.pl $(BINDIR)/do_unlinks
-! install -m $(EXMODE) -g $(GRP) pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
-! install -m $(EXMODE) -g $(GRP) mm.pl $(BINDIR)/mirror-master
-! install -m $(PLMODE) -g $(GRP) mirror.man $(MANDIR)/mirror.1
-! install -m $(PLMODE) -g $(GRP) mm.man $(MANDIR)/mirror-master.1
-
- # directory to install .pl (perl library) files for rperl
- RPLDIR = /usr/local/rperl5/lib/perl5
---- 65,89 ----
- # mode to install executables
- EXMODE = 755
- # group to own all the files
-! GRP = bin
- # directory to install .pl (perl library) files
-! PLDIR = ${PREFIX}/lib/mirror
- # directory to install public executables
-! BINDIR = ${PREFIX}/bin
- # directory to install man pages
-! MANDIR = ${PREFIX}/man/man1
-
- install:
-! install -c lchat.pl $(PLDIR)
-! install -c dateconv.pl $(PLDIR)
-! install -c ftp.pl $(PLDIR)
-! install -c lsparse.pl $(PLDIR)
-! install -c mirror.pl $(BINDIR)/mirror
-! install -c do_unlinks.pl $(BINDIR)/do_unlinks
-! install -c pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
-! install -c mm.pl $(BINDIR)/mirror-master
-! install -c mirror.man $(MANDIR)/mirror.1
-! install -c mm.man $(MANDIR)/mirror-master.1
-! install -c mirror.defaults $(PLDIR)/mirror.defaults.sample
-
- # directory to install .pl (perl library) files for rperl
- RPLDIR = /usr/local/rperl5/lib/perl5
+--- makefile.orig 1998-06-01 11:28:47.000000000 -0700
++++ makefile 2024-03-01 11:09:23.957678000 -0800
+@@ -41,7 +41,7 @@
+ $(WEBFILES)
+
+ all:
+- echo try make mirror.tar
++# echo try make mirror.tar
+
+ mirror.tar: $(FILES)
+ rev=`./mirror.pl -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
+@@ -65,25 +65,26 @@
+ # mode to install executables
+ EXMODE = 755
+ # group to own all the files
+-GRP = gnu
++GRP = bin
+ # directory to install .pl (perl library) files
+-PLDIR = /usr/local/perl5/lib/perl5
++PLDIR = ${PREFIX}/lib/mirror
+ # directory to install public executables
+-BINDIR = /usr/local/sbin
++BINDIR = ${PREFIX}/bin
+ # directory to install man pages
+-MANDIR = /usr/local/man/man1
++MANDIR = ${PREFIX}/share/man/man1
+
+ install:
+- install -m $(PLMODE) -g $(GRP) lchat.pl $(PLDIR)
+- install -m $(PLMODE) -g $(GRP) dateconv.pl $(PLDIR)
+- install -m $(PLMODE) -g $(GRP) ftp.pl $(PLDIR)
+- install -m $(PLMODE) -g $(GRP) lsparse.pl $(PLDIR)
+- install -m $(EXMODE) -g $(GRP) mirror.pl $(BINDIR)/mirror
+- install -m $(EXMODE) -g $(GRP) do_unlinks.pl $(BINDIR)/do_unlinks
+- install -m $(EXMODE) -g $(GRP) pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
+- install -m $(EXMODE) -g $(GRP) mm.pl $(BINDIR)/mirror-master
+- install -m $(PLMODE) -g $(GRP) mirror.man $(MANDIR)/mirror.1
+- install -m $(PLMODE) -g $(GRP) mm.man $(MANDIR)/mirror-master.1
++ install -c lchat.pl $(PLDIR)
++ install -c dateconv.pl $(PLDIR)
++ install -c ftp.pl $(PLDIR)
++ install -c lsparse.pl $(PLDIR)
++ install -c mirror.pl $(BINDIR)/mirror
++ install -c do_unlinks.pl $(BINDIR)/do_unlinks
++ install -c pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
++ install -c mm.pl $(BINDIR)/mirror-master
++ install -c mirror.man $(MANDIR)/mirror.1
++ install -c mm.man $(MANDIR)/mirror-master.1
++ install -c mirror.defaults $(PLDIR)/mirror.defaults.sample
+
+ # directory to install .pl (perl library) files for rperl
+ RPLDIR = /usr/local/rperl5/lib/perl5
diff --git a/ftp/mirror/pkg-plist b/ftp/mirror/pkg-plist
index 47e1f0ba8a63..8e012d64e14e 100644
--- a/ftp/mirror/pkg-plist
+++ b/ftp/mirror/pkg-plist
@@ -11,5 +11,5 @@ lib/mirror/dateconv.pl
lib/mirror/ftp.pl
lib/mirror/lsparse.pl
lib/mirror/mirror.defaults.sample
-man/man1/mirror.1.gz
-man/man1/mirror-master.1.gz
+share/man/man1/mirror.1.gz
+share/man/man1/mirror-master.1.gz