aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-19 11:07:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-19 11:07:29 +0000
commit9cdc02a73b1aaccfd28f270a751630d5ba7750d6 (patch)
treec96defa4a1c320b9512e6afa5ecc86b298d92e87 /ftp
parent2161713a0f9db1fd8edf47c86a7ead7d74ae9402 (diff)
downloadports-9cdc02a73b1aaccfd28f270a751630d5ba7750d6.tar.gz
ports-9cdc02a73b1aaccfd28f270a751630d5ba7750d6.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ftp-proxy/Makefile16
-rw-r--r--ftp/ftp-proxy/distinfo6
-rw-r--r--ftp/ftp-proxy/files/ftp-proxy.in25
-rw-r--r--ftp/ftp-proxy/files/ftp-proxy.sh32
-rw-r--r--ftp/ftp-proxy/pkg-descr2
5 files changed, 39 insertions, 42 deletions
diff --git a/ftp/ftp-proxy/Makefile b/ftp/ftp-proxy/Makefile
index f079e17d9b80..e093e1eadd26 100644
--- a/ftp/ftp-proxy/Makefile
+++ b/ftp/ftp-proxy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ftp-proxy
-PORTVERSION= 4.0p0
-PORTREVISION= 1
+PORTVERSION= 4.1p1
CATEGORIES= ftp
MASTER_SITES= http://www.chrissicool.net/projects/ftp-proxy/distfiles/
@@ -19,14 +18,19 @@ LIB_DEPENDS= event-1.3b:${PORTSDIR}/devel/libevent
MAN8= ftp-proxy.8
MANCOMPRESSED= yes
-PLIST_FILES= sbin/ftp-proxy \
- etc/rc.d/ftp-proxy.sh
+PLIST_FILES= sbin/ftp-proxy
+USE_RC_SUBR= ftp-proxy
CFLAGS+= -I${PREFIX}/include
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502106
+IGNORE= only for 5.3 and above
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ftp-proxy ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${FILESDIR}/ftp-proxy.sh ${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/ftp-proxy.8.gz ${PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/ftp-proxy/distinfo b/ftp/ftp-proxy/distinfo
index e46c2f8d7b3a..9f56fab4ebd8 100644
--- a/ftp/ftp-proxy/distinfo
+++ b/ftp/ftp-proxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (ftp-proxy-4.0p0.tar.gz) = 1defe7411ed13966910d1ec25784db86
-SHA256 (ftp-proxy-4.0p0.tar.gz) = cabd125a011d6548f40c72e29a254e71decde306f55ff5d037018cb33901867f
-SIZE (ftp-proxy-4.0p0.tar.gz) = 13381
+MD5 (ftp-proxy-4.1p1.tar.gz) = 6809f67b62f3b38c96077a1ec4fd4f59
+SHA256 (ftp-proxy-4.1p1.tar.gz) = 37854e5a7ccd36dc43d644cba55020114a796430541365f537a6ef2b32376ac5
+SIZE (ftp-proxy-4.1p1.tar.gz) = 12849
diff --git a/ftp/ftp-proxy/files/ftp-proxy.in b/ftp/ftp-proxy/files/ftp-proxy.in
new file mode 100644
index 000000000000..2964fa4ef1c1
--- /dev/null
+++ b/ftp/ftp-proxy/files/ftp-proxy.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# PROVIDE: ftp-proxy
+# REQUIRE: DAEMON pf
+#
+# Add the following lines to /etc/rc.conf to enable ftp-proxy:
+#
+# ftpproxy_enable (bool) Set to "YES" to enable ftp-proxy.
+# Default is "NO".
+# ftpproxy_flags (flags): Set extra flags to ftp-proxy.
+# Default is "". See ftp-proxy(8).
+#
+
+. %%RC_SUBR%%
+
+name="ftpproxy"
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${ftpproxy_enable="NO"}
+
+command="%%PREFIX%%/sbin/ftp-proxy"
+
+run_rc_command "$1"
diff --git a/ftp/ftp-proxy/files/ftp-proxy.sh b/ftp/ftp-proxy/files/ftp-proxy.sh
deleted file mode 100644
index d2c7b904f6a4..000000000000
--- a/ftp/ftp-proxy/files/ftp-proxy.sh
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: ftp-proxy
-# REQUIRE: DAEMON
-#
-# NOTE for FreeBSD 5.0+:
-# If you want this script to start with the base rc scripts
-# move ftp-proxy.sh to /etc/rc.d/ftp-proxy
-# Define these ftp-proxy_* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/ftp-proxy
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-
-ftpproxy_enable=${ftp-proxy_enable:-"NO"} # Enable ftp-proxy
-ftpproxy_flags=${ftp-proxy_flags:-""} # Flags to ftp-proxy program
-#ftpproxy_program="%%PREFIX%%/sbin/ftp-proxy" # Location of ftp-proxy
-
-. %%RC_SUBR%%
-
-name="ftp-proxy"
-rcvar=`set_rcvar`
-command="%%PREFIX%%/sbin/${name}"
-
-load_rc_config $name
-
-run_rc_command "$1"
diff --git a/ftp/ftp-proxy/pkg-descr b/ftp/ftp-proxy/pkg-descr
index 9bd5d64e32b0..2bd152e17afe 100644
--- a/ftp/ftp-proxy/pkg-descr
+++ b/ftp/ftp-proxy/pkg-descr
@@ -1,3 +1,3 @@
A ftp proxy for firewalled connections,using pf's anchors and rules.
-WWW: http://www.openbsd.org/
+WWW: http://www.chrissicool.net/projects/ftp-proxy/