aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
commite23ee358fa1ac94e411715abac088791dc154c19 (patch)
tree2f2d07d89e8f9b0b1bbbaa61fc0a3c53d8b1308c /ftp
parent8931540e0ace91aa22d2f957ccaefa11eb78adca (diff)
downloadports-e23ee358fa1ac94e411715abac088791dc154c19.tar.gz
ports-e23ee358fa1ac94e411715abac088791dc154c19.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/gollem/Makefile19
-rw-r--r--ftp/gollem/files/pkg-deinstall.in (renamed from ftp/gollem/pkg-deinstall)2
-rw-r--r--ftp/gollem/pkg-plist2
-rw-r--r--ftp/horde-gollem/Makefile19
-rw-r--r--ftp/horde-gollem/files/pkg-deinstall.in (renamed from ftp/horde-gollem/pkg-deinstall)2
-rw-r--r--ftp/horde-gollem/pkg-plist2
6 files changed, 30 insertions, 16 deletions
diff --git a/ftp/gollem/Makefile b/ftp/gollem/Makefile
index 9d68649310d3..017d1c74ccec 100644
--- a/ftp/gollem/Makefile
+++ b/ftp/gollem/Makefile
@@ -24,11 +24,12 @@ COMMENT= Gollem is the Horde web-based File Manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
-USE_REINPLACE= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
-PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR}
+PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -43,11 +44,17 @@ LGOLLEMDIR?= ${LHORDEDIR}/gollem
GOLLEMDIR= ${PREFIX}/${LGOLLEMDIR}
CONFDIR= ${GOLLEMDIR}/config
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/gollem:${GOLLEMDIR}:g" \
- ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd.conf.gollem
+ ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd-gollem.conf
do-install:
@${MKDIR} ${GOLLEMDIR}
@@ -60,7 +67,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.gollem ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-gollem.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@@ -72,4 +79,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/gollem/pkg-deinstall b/ftp/gollem/files/pkg-deinstall.in
index c371d1852937..5c399f4c3632 100644
--- a/ftp/gollem/pkg-deinstall
+++ b/ftp/gollem/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/gollem/config/*php`; do
+ for cf in `ls %%GOLLEMDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/ftp/gollem/pkg-plist b/ftp/gollem/pkg-plist
index 90aaceaa683d..33866e40f888 100644
--- a/ftp/gollem/pkg-plist
+++ b/ftp/gollem/pkg-plist
@@ -1,4 +1,4 @@
-etc/horde/httpd.conf.gollem
+%%HORDE_INC%%/httpd-gollem.conf
%%GOLLEMDIR%%/clipboard.php
%%GOLLEMDIR%%/config/backends.php
%%GOLLEMDIR%%/config/backends.php.dist
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
index 9d68649310d3..017d1c74ccec 100644
--- a/ftp/horde-gollem/Makefile
+++ b/ftp/horde-gollem/Makefile
@@ -24,11 +24,12 @@ COMMENT= Gollem is the Horde web-based File Manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
-USE_REINPLACE= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
-PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR}
+PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -43,11 +44,17 @@ LGOLLEMDIR?= ${LHORDEDIR}/gollem
GOLLEMDIR= ${PREFIX}/${LGOLLEMDIR}
CONFDIR= ${GOLLEMDIR}/config
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/gollem:${GOLLEMDIR}:g" \
- ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd.conf.gollem
+ ${FILESDIR}/httpd.conf.gollem > ${WRKDIR}/httpd-gollem.conf
do-install:
@${MKDIR} ${GOLLEMDIR}
@@ -60,7 +67,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.gollem ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-gollem.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@@ -72,4 +79,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/horde-gollem/pkg-deinstall b/ftp/horde-gollem/files/pkg-deinstall.in
index c371d1852937..5c399f4c3632 100644
--- a/ftp/horde-gollem/pkg-deinstall
+++ b/ftp/horde-gollem/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/gollem/config/*php`; do
+ for cf in `ls %%GOLLEMDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/ftp/horde-gollem/pkg-plist b/ftp/horde-gollem/pkg-plist
index 90aaceaa683d..33866e40f888 100644
--- a/ftp/horde-gollem/pkg-plist
+++ b/ftp/horde-gollem/pkg-plist
@@ -1,4 +1,4 @@
-etc/horde/httpd.conf.gollem
+%%HORDE_INC%%/httpd-gollem.conf
%%GOLLEMDIR%%/clipboard.php
%%GOLLEMDIR%%/config/backends.php
%%GOLLEMDIR%%/config/backends.php.dist