aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2002-10-30 12:08:24 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2002-10-30 12:08:24 +0000
commita76838b7701eff85df8d757223c9875251cbe643 (patch)
treede16f831b15bcaab966c01b18149d5f7be611afc /ftp
parentf98326ff7bb2a152c3aeb6d5ba939cef3f2e8861 (diff)
downloadports-a76838b7701eff85df8d757223c9875251cbe643.tar.gz
ports-a76838b7701eff85df8d757223c9875251cbe643.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/ftp-tls/Makefile32
-rw-r--r--ftp/ftp-tls/distinfo1
-rw-r--r--ftp/ftp-tls/files/patch-config.h.in9
-rw-r--r--ftp/ftp-tls/files/patch-configure.in57
-rw-r--r--ftp/ftp-tls/files/patch-ftp.1.TLS78
-rw-r--r--ftp/ftp-tls/files/patch-main.c24
-rw-r--r--ftp/ftp-tls/files/patch-util.c22
-rw-r--r--ftp/ftp-tls/pkg-comment1
-rw-r--r--ftp/ftp-tls/pkg-descr4
-rw-r--r--ftp/ftp-tls/pkg-plist1
11 files changed, 230 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 3e6003b82b44..43e6e336faf5 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -12,6 +12,7 @@
SUBDIR += emirror
SUBDIR += fget
SUBDIR += frox
+ SUBDIR += ftp-tls
SUBDIR += ftpcopy
SUBDIR += ftpcube
SUBDIR += ftpfind
diff --git a/ftp/ftp-tls/Makefile b/ftp/ftp-tls/Makefile
new file mode 100644
index 000000000000..8ce35c0db994
--- /dev/null
+++ b/ftp/ftp-tls/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: ftp-tls
+# Date created: 24 October 2002
+# Whom: marius@alchemy.franken.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftp-tls
+PORTVERSION= 20020906
+CATEGORIES= ftp security
+MASTER_SITES= ftp://ftp.runestig.com/pub/ftp-tls/
+
+MAINTAINER= marius@alchemy.franken.de
+
+USE_AUTOCONF= YES
+GNU_CONFIGURE= YES
+
+USE_OPENSSL= YES
+
+MAN1= ftp-tls.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400000
+BROKEN= "Not supported on systems prior to FreeBSD 4.0 (missing getaddrinfo())"
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ftp ${PREFIX}/bin/ftp-tls
+ @${INSTALL_MAN} ${WRKSRC}/ftp.1.TLS ${PREFIX}/man/man1/ftp-tls.1
+
+.include <bsd.port.post.mk>
diff --git a/ftp/ftp-tls/distinfo b/ftp/ftp-tls/distinfo
new file mode 100644
index 000000000000..1072282e23f1
--- /dev/null
+++ b/ftp/ftp-tls/distinfo
@@ -0,0 +1 @@
+MD5 (ftp-tls-20020906.tar.gz) = 8823a6f9388add4e3fcd4459422d57d8
diff --git a/ftp/ftp-tls/files/patch-config.h.in b/ftp/ftp-tls/files/patch-config.h.in
new file mode 100644
index 000000000000..cde8a56e6d05
--- /dev/null
+++ b/ftp/ftp-tls/files/patch-config.h.in
@@ -0,0 +1,9 @@
+--- config.h.in.orig Fri Oct 25 14:59:53 2002
++++ config.h.in Fri Oct 25 15:02:02 2002
+@@ -338,3 +338,6 @@
+
+ /* Define to `unsigned' if <sys/types.h> does not define. */
+ #undef size_t
++
++/* Define if libedit has the NetBSD enhancements. */
++#undef ENHANCED_LIBEDIT
diff --git a/ftp/ftp-tls/files/patch-configure.in b/ftp/ftp-tls/files/patch-configure.in
new file mode 100644
index 000000000000..bd4d2c05584b
--- /dev/null
+++ b/ftp/ftp-tls/files/patch-configure.in
@@ -0,0 +1,57 @@
+--- configure.in.orig Thu Oct 24 21:28:06 2002
++++ configure.in Fri Oct 25 15:03:04 2002
+@@ -56,6 +56,7 @@
+ AC_CHECK_LIB(nsl, inet_addr)
+ dnl Replace `main' with a function in -lsocks5:
+ dnl AC_CHECK_LIB(socks5, main)
++AC_SEARCH_LIBS(el_init, edit, have_libedit=yes, have_libedit=no)
+
+ # Checks for header files.
+ AC_HEADER_DIRENT
+@@ -302,11 +303,11 @@
+ AC_CHECK_LIB(krb5, krb5_init_context, ,
+ AC_MSG_ERROR(Could not find Kerberos 5 library needed. Try again using --with-krb5-dir=DIR))
+ fi
+- # look for OpenSSL libraries, also in the legacy (strange) place "/usr/local/ssl"
++ # look for OpenSSL libraries
+ AC_CHECK_LIB(crypto, X509_STORE_load_locations, , found_openssl=no)
+ if test "$found_openssl" = no; then
+- CPPFLAGS="$CPPFLAGS -I/usr/local/ssl/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/ssl/lib"
++ CPPFLAGS="$CPPFLAGS -I$OPENSSLINC"
++ LDFLAGS="$LDFLAGS -L$OPENSSLLIB"
+ # remove the cached result of the previous AC_CHECK_LIB()
+ unset ac_cv_lib_crypto_X509_STORE_load_locations
+ AC_CHECK_LIB(crypto, X509_STORE_load_locations, ,
+@@ -336,10 +337,27 @@
+ if test "$enable_small" = yes; then
+ AC_DEFINE(SMALL)
+ else
+- LIBS="-ledit -L./libedit $LIBS"
+- CPPFLAGS="$CPPFLAGS -I./libedit"
+- LIBEDITTARGET=libedit-all
+- MANEDITRC=editrc.5
++ AC_MSG_CHECKING([for libedit])
++ if test $have_libedit = no; then
++ AC_MSG_RESULT([no, using my own])
++ LIBS="./libedit/libedit.a $LIBS"
++ CPPFLAGS="$CPPFLAGS -I./libedit"
++ LIBEDITTARGET=libedit-all
++ MANEDITRC=editrc.5
++ else
++ AC_MSG_RESULT([yes])
++ LIBEDITTARGET=
++
++ AC_MSG_CHECKING([for NetBSD enhancements in libedit])
++ AC_TRY_COMPILE([#include <histedit.h>], [int X = EL_RPROMPT],
++ have_enhanced_libedit=yes)
++ if test "$have_enhanced_libedit" = yes; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE(ENHANCED_LIBEDIT)
++ else
++ AC_MSG_RESULT([no])
++ fi
++ fi
+ fi
+ AC_SUBST(LIBEDITTARGET)
+ AC_SUBST(MANEDITRC)
diff --git a/ftp/ftp-tls/files/patch-ftp.1.TLS b/ftp/ftp-tls/files/patch-ftp.1.TLS
new file mode 100644
index 000000000000..3365961fc79e
--- /dev/null
+++ b/ftp/ftp-tls/files/patch-ftp.1.TLS
@@ -0,0 +1,78 @@
+--- ftp.1.TLS.orig Thu Sep 5 21:00:21 2002
++++ ftp.1.TLS Fri Oct 25 15:28:06 2002
+@@ -38,23 +38,23 @@
+ .Dt FTP 1
+ .Os
+ .Sh NAME
+-.Nm ftp
++.Nm ftp-tls
+ .Nd
+ .Tn ARPANET
+-file transfer program
++file transfer program supporting FTP AUTH TLS
+ .Sh SYNOPSIS
+-.Nm ftp
++.Nm ftp-tls
+ .Op Fl AVadegimnptv
+ .Op Fl o Ar output
+ .Op Fl P Ar port
+ .Op Fl r Ar seconds
+ .Op Fl z Ar TLS option
+ .Op Ar host Op Ar port
+-.Nm ftp
++.Nm ftp-tls
+ ftp://[\fIuser\fR:\fIpassword\fR@]\fIhost\fR[:\fIport\fR]/\fIfile\fR[/]
+-.Nm ftp
++.Nm ftp-tls
+ http://\fIhost\fR[:\fIport\fR]/\fIfile\fR
+-.Nm ftp
++.Nm ftp-tls
+ \fIhost\fR:[/\fIpath\fR/]\fIfile\fR[/]
+ .Sh DESCRIPTION
+ .Nm
+@@ -299,7 +299,7 @@
+ is provided to the user.
+ The following commands are recognized
+ by
+-.Nm ftp :
++.Nm ftp-tls :
+ .Bl -tag -width Fl
+ .It Ic \&! Op Ar command Op Ar args
+ Invoke an interactive shell on the local machine.
+@@ -351,7 +351,7 @@
+ .Tn FTP
+ session with the remote server
+ and exit
+-.Nm ftp .
++.Nm ftp-tls .
+ An end-of-file will also terminate the session and exit.
+ .It Ic case
+ Toggle remote computer file name case mapping during
+@@ -1135,7 +1135,7 @@
+ on remote machine.
+ .It Ic status
+ Show the current status of
+-.Nm ftp .
++.Nm ftp-tls .
+ .It Ic struct Op Ar struct-name
+ Set the file transfer
+ .Ar structure
+@@ -1374,9 +1374,7 @@
+ c.f. the
+ .Ic glob
+ command.
+-If the
+-.Nm
+-command expects a single local file (e.g.,
++If the ftp command expects a single local file (e.g.,
+ .Ic put ) ,
+ only the first filename generated by the
+ .Dq globbing
+@@ -1608,6 +1606,7 @@
+ URL of HTTP proxy to use when making HTTP URL requests.
+ .El
+ .Sh SEE ALSO
++.Xr tftp 1 ,
+ .Xr tftp 1 ,
+ .Xr getservbyname 3 ,
+ .Xr editrc 5 ,
diff --git a/ftp/ftp-tls/files/patch-main.c b/ftp/ftp-tls/files/patch-main.c
new file mode 100644
index 000000000000..0be16c691ad8
--- /dev/null
+++ b/ftp/ftp-tls/files/patch-main.c
@@ -0,0 +1,24 @@
+--- main.c.orig Fri Oct 25 14:15:16 2002
++++ main.c Fri Oct 25 15:05:09 2002
+@@ -518,6 +518,9 @@
+ #ifndef SMALL
+ } else {
+ const char *buf;
++#ifdef ENHANCED_LIBEDIT
++ HistEvent ev;
++#endif
+ cursor_pos = NULL;
+
+ if ((buf = el_gets(el, &num)) == NULL || num == 0)
+@@ -532,7 +535,11 @@
+ }
+ memcpy(line, buf, (size_t)num);
+ line[num] = '\0';
++#ifndef ENHANCED_LIBEDIT
+ history(hist, H_ENTER, buf);
++#else
++ history(hist, &ev, H_ENTER, buf);
++#endif
+ }
+ #endif /* !SMALL */
+
diff --git a/ftp/ftp-tls/files/patch-util.c b/ftp/ftp-tls/files/patch-util.c
new file mode 100644
index 000000000000..007bc5ab50a4
--- /dev/null
+++ b/ftp/ftp-tls/files/patch-util.c
@@ -0,0 +1,22 @@
+--- util.c.orig Fri Oct 25 14:17:24 2002
++++ util.c Fri Oct 25 15:07:39 2002
+@@ -1013,9 +1013,19 @@
+ controlediting()
+ {
+ if (editing && el == NULL && hist == NULL) {
++#ifdef ENHANCED_LIBEDIT
++ HistEvent ev;
++
++ el = el_init(progname, stdin, ttyout, stderr); /* init editline */
++#else
+ el = el_init(progname, stdin, ttyout); /* init editline */
++#endif
+ hist = history_init(); /* init the builtin history */
++#ifndef ENHANCED_LIBEDIT
+ history(hist, H_EVENT, 100); /* remember 100 events */
++#else
++ history(hist, &ev, H_SETSIZE, 100); /* remember 100 events */
++#endif
+ el_set(el, EL_HIST, history, hist); /* use history */
+
+ el_set(el, EL_EDITOR, "emacs"); /* default editor is emacs */
diff --git a/ftp/ftp-tls/pkg-comment b/ftp/ftp-tls/pkg-comment
new file mode 100644
index 000000000000..42913cefc2d3
--- /dev/null
+++ b/ftp/ftp-tls/pkg-comment
@@ -0,0 +1 @@
+Ftp client supporting FTP AUTH TLS
diff --git a/ftp/ftp-tls/pkg-descr b/ftp/ftp-tls/pkg-descr
new file mode 100644
index 000000000000..b4fb3c029a97
--- /dev/null
+++ b/ftp/ftp-tls/pkg-descr
@@ -0,0 +1,4 @@
+Ftp client based on the OpenBSD ftp client code, implements the
+FTP AUTH TLS IETF draft.
+
+WWW: http://www.runestig.com/osp.html
diff --git a/ftp/ftp-tls/pkg-plist b/ftp/ftp-tls/pkg-plist
new file mode 100644
index 000000000000..1843e13515a7
--- /dev/null
+++ b/ftp/ftp-tls/pkg-plist
@@ -0,0 +1 @@
+bin/ftp-tls