aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-07-13 08:54:04 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-07-13 08:54:04 +0000
commitb1b4d524a2617badc9a4676885f46bf29fd1364c (patch)
treee1880f2315ccf63ce0c0801c5335ec0d596d4eb1 /ftp
parentba53b1dd7b74e6cbcea4233bc2b5270259a754b6 (diff)
downloadports-b1b4d524a2617badc9a4676885f46bf29fd1364c.tar.gz
ports-b1b4d524a2617badc9a4676885f46bf29fd1364c.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile45
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-configure10
-rw-r--r--ftp/curl/pkg-plist17
4 files changed, 59 insertions, 19 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 2757b60426e2..df554ef58fe1 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.15.3
+PORTVERSION= 7.15.4
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -19,16 +19,20 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
MAN1= curl.1 curl-config.1
-MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 curl_easy_getinfo.3 \
+MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 \
+ curl_easy_escape.3 curl_easy_getinfo.3 \
curl_easy_init.3 curl_easy_perform.3 curl_easy_reset.3 \
- curl_easy_setopt.3 curl_easy_strerror.3 curl_escape.3 \
+ curl_easy_setopt.3 curl_easy_strerror.3 curl_easy_unescape.3 \
+ curl_escape.3 \
curl_unescape.3 curl_formadd.3 curl_formfree.3 curl_free.3 \
curl_getdate.3 curl_getenv.3 curl_global_init.3 \
curl_global_init_mem.3 curl_global_cleanup.3 curl_mprintf.3 \
curl_multi_add_handle.3 curl_multi_cleanup.3 \
curl_multi_fdset.3 curl_multi_info_read.3 curl_multi_init.3 \
curl_multi_perform.3 curl_multi_remove_handle.3 \
- curl_multi_strerror.3 curl_share_cleanup.3 curl_share_init.3 \
+ curl_multi_setopt.3 curl_multi_socket.3 \
+ curl_multi_strerror.3 curl_multi_timeout.3 \
+ curl_share_cleanup.3 curl_share_init.3 \
curl_share_setopt.3 curl_share_strerror.3 curl_slist_append.3 \
curl_slist_free_all.3 curl_strequal.3 curl_version.3 \
curl_version_info.3 libcurl.3 libcurl-easy.3 libcurl-errors.3 \
@@ -43,10 +47,13 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
-.if defined(WITH_GNUTLS)
-WITHOUT_SSL= yes
-.endif
+OPTIONS= CURL_DEBUG "Enable curl diagnostic output" off \
+ GNUTLS "Use GNU TLS if WITHOUT_SSL is specified" off \
+ KERBEROS4 "Kerberos 4 authentication" off \
+ LIBIDN "Internationalized Domain Names via libidn" off \
+ NTLM "NTLM authentication" off
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
@@ -54,10 +61,18 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
+.if defined(WITH_GNUTLS) && !defined(WITHOUT_SSL)
+IGNORE= may only use GNU TLS if WITHOUT_SSL is defined
+.endif
+
+.if defined(WITH_NTLM) && defined(WITHOUT_SSL)
+IGNORE= only supports NTLM with OpenSSL
+.endif
+
.if !defined(WITHOUT_SSL)
-CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.else
-CONFIGURE_ARGS= --without-ssl
+CONFIGURE_ARGS+= --without-ssl
.endif
.if defined(WITH_GNUTLS)
@@ -75,9 +90,11 @@ PLIST_SUB+= SSL="@comment "
.if exists(/usr/lib/libkrb.a) && defined(WITH_KERBEROS4)
CONFIGURE_ARGS += --with-krb4=/usr
+.else
+CONFIGURE_ARGS += --without-krb4
.endif
-.if !defined(WITHOUT_LIBIDN) && (defined(WITH_LIBIDN) || exists(${LOCALBASE}/lib/libidn.so))
+.if defined(WITH_LIBIDN)
LIB_DEPENDS+= idn.16:${PORTSDIR}/dns/libidn
CONFIGURE_ARGS+= --with-libidn=${LOCALBASE}
.else
@@ -88,6 +105,12 @@ CONFIGURE_ARGS+= --without-libidn
CONFIGURE_ARGS+= --enable-debug
.endif
+.if defined(WITH_NTLM)
+CONFIGURE_ARGS+= --enable-ntlm
+.else
+CONFIGURE_ARGS+= --disable-ntlm
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
@@ -101,6 +124,6 @@ post-install:
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} test
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.post.mk>
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index df8badaa0547..ed6890cc8975 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-MD5 (curl-7.15.3.tar.bz2) = d71b2ee8febfde2c7dc30a43638ec0d9
-SHA256 (curl-7.15.3.tar.bz2) = 77771db616dee02f21b94c409ed423a72fa7f2b2d65c27395137b0f920388440
-SIZE (curl-7.15.3.tar.bz2) = 1467043
+MD5 (curl-7.15.4.tar.bz2) = d9345a55c8bc67eafcd37fa1b728e00e
+SHA256 (curl-7.15.4.tar.bz2) = 11521127e175eb633c046a2c6ed11f97e81816d3aec9e8cac560763457a8e623
+SIZE (curl-7.15.4.tar.bz2) = 1519792
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 3c42e9761ca3..35cea8f421bb 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Fri Sep 2 20:22:43 2005
-+++ configure Fri Sep 2 20:37:36 2005
-@@ -24917,8 +24917,10 @@
+--- configure.orig Thu Jun 8 09:12:53 2006
++++ configure Wed Jul 12 16:44:43 2006
+@@ -26690,8 +26690,10 @@
PKGTEST="no"
PREFIX_OPENSSL=$OPT_SSL
LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
@@ -11,12 +11,12 @@
;;
esac
-@@ -32576,7 +32578,7 @@
+@@ -35638,7 +35640,7 @@
main ()
{
#ifndef basename
- char *p = (char *) basename;
+ char *(*p)(const char *) = basename;
+ return !p;
#endif
- ;
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 39e79d237591..47f3e5ddc442 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -61,6 +61,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/examples/ftpget.c
%%PORTDOCS%%%%DOCSDIR%%/examples/ftpgetresp.c
%%PORTDOCS%%%%DOCSDIR%%/examples/ftpupload.c
+%%PORTDOCS%%%%DOCSDIR%%/examples/ftpuploadresume.c
%%PORTDOCS%%%%DOCSDIR%%/examples/getinfo.c
%%PORTDOCS%%%%DOCSDIR%%/examples/getinmemory.c
%%PORTDOCS%%%%DOCSDIR%%/examples/htmltidy.c
@@ -79,6 +80,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/examples/persistant.c
%%PORTDOCS%%%%DOCSDIR%%/examples/post-callback.c
%%PORTDOCS%%%%DOCSDIR%%/examples/postit2.c
+%%PORTDOCS%%%%DOCSDIR%%/examples/sampleconv.c
%%PORTDOCS%%%%DOCSDIR%%/examples/sepheaders.c
%%PORTDOCS%%%%DOCSDIR%%/examples/simple.c
%%PORTDOCS%%%%DOCSDIR%%/examples/simplepost.c
@@ -94,6 +96,9 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_duphandle.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_duphandle.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_duphandle.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_escape.3
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_escape.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_escape.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_getinfo.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_getinfo.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_getinfo.pdf
@@ -112,6 +117,9 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_strerror.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_strerror.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_strerror.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_unescape.3
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_unescape.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_easy_unescape.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_escape.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_escape.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_escape.pdf
@@ -163,9 +171,18 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_remove_handle.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_remove_handle.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_remove_handle.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_setopt.3
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_setopt.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_setopt.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_socket.3
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_socket.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_socket.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_strerror.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_strerror.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_strerror.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_timeout.3
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_timeout.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_cleanup.3
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_cleanup.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_cleanup.pdf