aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-10-08 19:22:45 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-10-08 19:22:45 +0000
commitbe5309b025139ac0ceb3bc7c837e3fb47c99914a (patch)
treef0f441509b7664f3ef7613cc6e39ec4cde129caa /ftp
parentf53f3376dca7e93b6f44ee8cd317c92bff39d0e6 (diff)
downloadports-be5309b025139ac0ceb3bc7c837e3fb47c99914a.tar.gz
ports-be5309b025139ac0ceb3bc7c837e3fb47c99914a.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile1
-rw-r--r--ftp/proftpd-devel/files/patch-src-auth.c43
-rw-r--r--ftp/proftpd/Makefile1
-rw-r--r--ftp/proftpd/files/patch-src-auth.c43
4 files changed, 88 insertions, 0 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index bf8501c4ef26..e3ab3a76a711 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd-devel/files/patch-src-auth.c b/ftp/proftpd-devel/files/patch-src-auth.c
new file mode 100644
index 000000000000..61386a883e9f
--- /dev/null
+++ b/ftp/proftpd-devel/files/patch-src-auth.c
@@ -0,0 +1,43 @@
+ndex: src/auth.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/auth.c,v
+retrieving revision 1.52
+diff -u -r1.52 auth.c
+--- src/auth.c 5 Oct 2007 17:04:13 -0000 1.52
++++ src/auth.c 8 Oct 2007 18:44:21 -0000
+@@ -503,6 +503,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
+@@ -566,6 +577,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index bf8501c4ef26..e3ab3a76a711 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd/files/patch-src-auth.c b/ftp/proftpd/files/patch-src-auth.c
new file mode 100644
index 000000000000..61386a883e9f
--- /dev/null
+++ b/ftp/proftpd/files/patch-src-auth.c
@@ -0,0 +1,43 @@
+ndex: src/auth.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/auth.c,v
+retrieving revision 1.52
+diff -u -r1.52 auth.c
+--- src/auth.c 5 Oct 2007 17:04:13 -0000 1.52
++++ src/auth.c 8 Oct 2007 18:44:21 -0000
+@@ -503,6 +503,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
+@@ -566,6 +577,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+