aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-09-18 17:53:32 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-09-18 17:53:32 +0000
commitc8a3f218918f5411f2dceda6ee3fb3d03122d6af (patch)
treebfc1bc2a89e9db9ac317d5cc343881fd84f16b41 /ftp
parent6ce3c7939a94b91e9ce1aa987a4f4499a1b047f4 (diff)
downloadports-c8a3f218918f5411f2dceda6ee3fb3d03122d6af.tar.gz
ports-c8a3f218918f5411f2dceda6ee3fb3d03122d6af.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index da55359362d0..dc7229363811 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lftp
PORTVERSION= 3.2.1
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/net/ftp/lftp/ \
ftp://ftp.phear.org/pub/linux/networking/ftp/client/lftp/ \
@@ -36,24 +37,35 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= fm@cross-road.org.ua
COMMENT= Shell-like command line ftp client
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+
USE_BZIP2= yes
USE_GPG?= yes
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.asc
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+OPTIONS= GNUTLS "With GnutTLS support" off \
+ OPENSSL "With OpenSSL support" on \
+ SOCKS4 "With socks4 support" off \
+ SOCKS5 "With socks5 support" off \
+ SOCKS_DANTE "With socksdante support" off \
+ NLS "With i18n support" on
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --with-gnutls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
.if defined(WITH_OPENSSL)
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl
-USE_OPENSSL= yes
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
.if defined(WITH_SOCKS4)
CONFIGURE_ARGS+= --with-socks
.endif
@@ -83,4 +95,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>