aboutsummaryrefslogtreecommitdiff
path: root/games/0ad
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-04-16 17:53:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-04-16 17:53:29 +0000
commitb5260542bd8313948aee5893ef8c7e64f84d15c8 (patch)
treee489704e60a9a330a645e47f9b485c61eab24c75 /games/0ad
parent3140fea8845b33ce67559aadb21028f017f1b0ae (diff)
downloadports-b5260542bd8313948aee5893ef8c7e64f84d15c8.tar.gz
ports-b5260542bd8313948aee5893ef8c7e64f84d15c8.zip
Notes
Diffstat (limited to 'games/0ad')
-rw-r--r--games/0ad/Makefile7
-rw-r--r--games/0ad/distinfo8
-rw-r--r--games/0ad/files/patch-build-premake-premake4.lua16
-rw-r--r--games/0ad/files/patch-libraries-nvtt-src-src-nvtt-squish-CMakeLists.txt11
-rw-r--r--games/0ad/files/patch-libraries-source-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp (renamed from games/0ad/files/patch-libraries-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp)4
-rw-r--r--games/0ad/files/patch-libraries-source-spidermonkey-build.sh (renamed from games/0ad/files/patch-libraries-spidermonkey-build.sh)4
-rw-r--r--games/0ad/files/patch-source-lib-debug.h11
7 files changed, 17 insertions, 44 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index c248f3664632..9fe737987bfc 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= 0ad
-PORTVERSION= 0.0.12
-PORTREVISION= 2
+PORTVERSION= 0.0.13
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
@@ -46,10 +45,6 @@ PORTDATA= *
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800067
-BROKEN= Does not compile on 7.x: Requires wcsnlen(3)
-.endif
-
post-patch:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/build/premake/premake4.lua
diff --git a/games/0ad/distinfo b/games/0ad/distinfo
index a8650c45594d..8689aab1b716 100644
--- a/games/0ad/distinfo
+++ b/games/0ad/distinfo
@@ -1,4 +1,4 @@
-SHA256 (0ad-0.0.12-alpha-unix-build.tar.xz) = 69d01f9ba12bb78f58fc2c567187cfffe20055591f378724b906e6a48ac73877
-SIZE (0ad-0.0.12-alpha-unix-build.tar.xz) = 8693880
-SHA256 (0ad-0.0.12-alpha-unix-data.tar.xz) = 0efd800a149f2fed70d7e133b93a385e82810844b50154771514d17d9a68ee07
-SIZE (0ad-0.0.12-alpha-unix-data.tar.xz) = 388143556
+SHA256 (0ad-0.0.13-alpha-unix-build.tar.xz) = 6694c34341ae2dcf81912b3242619f853216dc3b9447177931e903421e480e18
+SIZE (0ad-0.0.13-alpha-unix-build.tar.xz) = 10152276
+SHA256 (0ad-0.0.13-alpha-unix-data.tar.xz) = 284477ddb14732b48ef6740b804294fc8361460190368e60324ce0e22aca4f7e
+SIZE (0ad-0.0.13-alpha-unix-data.tar.xz) = 420479284
diff --git a/games/0ad/files/patch-build-premake-premake4.lua b/games/0ad/files/patch-build-premake-premake4.lua
index 2433a8e799c9..caacfd65df2f 100644
--- a/games/0ad/files/patch-build-premake-premake4.lua
+++ b/games/0ad/files/patch-build-premake-premake4.lua
@@ -1,6 +1,6 @@
---- build/premake/premake4.lua.orig 2012-10-30 01:56:24.000000000 +0100
-+++ build/premake/premake4.lua 2012-12-26 18:37:28.882327928 +0100
-@@ -134,7 +134,7 @@
+--- build/premake/premake4.lua.orig 2013-03-07 14:49:49.000000000 +0100
++++ build/premake/premake4.lua 2013-04-03 00:14:47.033326555 +0200
+@@ -136,7 +136,7 @@
function project_set_build_flags()
@@ -9,7 +9,7 @@
if not _OPTIONS["icc"] and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
-- adds the -Wall compiler flag
flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
-@@ -215,7 +215,6 @@
+@@ -217,7 +217,6 @@
-- enable security features (stack checking etc) that shouldn't have
-- a significant effect on performance and can catch bugs
@@ -17,18 +17,18 @@
"-D_FORTIFY_SOURCE=2",
-- always enable strict aliasing (useful in debug builds because of the warnings)
-@@ -287,11 +286,11 @@
+@@ -343,11 +342,11 @@
-- X11 includes may be installed in one of a gadzillion of three places
-- Famous last words: "You can't include too much! ;-)"
includedirs {
- "/usr/X11R6/include/X11",
- "/usr/X11R6/include",
-+ "%%LOCALBASE%%/X11",
++ "%%LOCALBASE%%/include/X11",
+ "%%LOCALBASE%%/include",
"/usr/include/X11"
}
- libdirs { "/usr/X11R6/lib" }
+ libdirs { "%%LOCALBASE%%/lib" }
+ end
+ end
- if _OPTIONS["bindir"] then
- defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
diff --git a/games/0ad/files/patch-libraries-nvtt-src-src-nvtt-squish-CMakeLists.txt b/games/0ad/files/patch-libraries-nvtt-src-src-nvtt-squish-CMakeLists.txt
deleted file mode 100644
index 192bc5930d07..000000000000
--- a/games/0ad/files/patch-libraries-nvtt-src-src-nvtt-squish-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- libraries/nvtt/src/src/nvtt/squish/CMakeLists.txt.orig 2012-05-17 23:33:39.561531637 +0200
-+++ libraries/nvtt/src/src/nvtt/squish/CMakeLists.txt 2012-05-17 23:33:51.665531705 +0200
-@@ -22,7 +22,4 @@
-
- ADD_LIBRARY(squish STATIC ${SQUISH_SRCS})
-
--IF(CMAKE_COMPILER_IS_GNUCXX)
-- SET_TARGET_PROPERTIES(squish PROPERTIES COMPILE_FLAGS -fPIC)
--ENDIF(CMAKE_COMPILER_IS_GNUCXX)
--
-+SET_TARGET_PROPERTIES(squish PROPERTIES COMPILE_FLAGS -fPIC)
diff --git a/games/0ad/files/patch-libraries-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp b/games/0ad/files/patch-libraries-source-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp
index 3d3e3802d9af..d01f7a08b497 100644
--- a/games/0ad/files/patch-libraries-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp
+++ b/games/0ad/files/patch-libraries-source-fcollada-src-FCollada-FUtils-FUStringBuilder.hpp
@@ -1,5 +1,5 @@
---- libraries/fcollada/src/FCollada/FUtils/FUStringBuilder.hpp.orig 2012-05-21 22:08:59.267251130 +0200
-+++ libraries/fcollada/src/FCollada/FUtils/FUStringBuilder.hpp 2012-05-21 22:13:05.450463479 +0200
+--- libraries/source/fcollada/src/FCollada/FUtils/FUStringBuilder.hpp.orig 2013-04-03 00:21:34.395291619 +0200
++++ libraries/source/fcollada/src/FCollada/FUtils/FUStringBuilder.hpp 2013-04-03 00:23:23.590274415 +0200
@@ -18,6 +18,42 @@
#include <float.h>
#endif
diff --git a/games/0ad/files/patch-libraries-spidermonkey-build.sh b/games/0ad/files/patch-libraries-source-spidermonkey-build.sh
index 45728197dace..0462783d2d63 100644
--- a/games/0ad/files/patch-libraries-spidermonkey-build.sh
+++ b/games/0ad/files/patch-libraries-source-spidermonkey-build.sh
@@ -1,5 +1,5 @@
---- libraries/spidermonkey/build.sh.orig 2012-06-11 00:39:26.000000000 +0200
-+++ libraries/spidermonkey/build.sh 2012-12-18 10:58:11.343785532 +0100
+--- libraries/source/spidermonkey/build.sh.orig 2013-02-04 01:31:03.000000000 +0100
++++ libraries/source/spidermonkey/build.sh 2013-04-03 00:34:16.221257333 +0200
@@ -53,6 +53,14 @@
cd js-1.8.5/js/src
diff --git a/games/0ad/files/patch-source-lib-debug.h b/games/0ad/files/patch-source-lib-debug.h
deleted file mode 100644
index 9dfccd1bec92..000000000000
--- a/games/0ad/files/patch-source-lib-debug.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/lib/debug.h.orig 2013-01-01 21:48:34.000000000 +0100
-+++ source/lib/debug.h 2013-01-01 21:49:29.000000000 +0100
-@@ -122,7 +122,7 @@
- * debugging the symbol engine.
- * use 0 as the initial value to avoid allocating .rdata space.
- **/
--const atomic_bool DEBUG_SUPPRESS = 0xAB;
-+static const atomic_bool DEBUG_SUPPRESS = 0xAB;
-
- /**
- * choices offered by the error dialog that are returned