aboutsummaryrefslogtreecommitdiff
path: root/games/0ad
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-12-28 21:18:10 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-12-28 21:18:10 +0000
commit005c6f91b23ef10924c7fbadb5d30394a3c85740 (patch)
tree5335ab6d79218323360dedc0d52a1740081f9735 /games/0ad
parentf0c6ef71bbc5e3a57153a50b207bd4e43786aa2b (diff)
downloadports-005c6f91b23ef10924c7fbadb5d30394a3c85740.tar.gz
ports-005c6f91b23ef10924c7fbadb5d30394a3c85740.zip
Notes
Diffstat (limited to 'games/0ad')
-rw-r--r--games/0ad/Makefile2
-rw-r--r--games/0ad/distinfo8
-rw-r--r--games/0ad/files/patch-build-premake-premake4.lua23
-rw-r--r--games/0ad/files/patch-libraries-spidermonkey-build.sh9
-rw-r--r--games/0ad/files/patch-source-lib-debug.cpp11
-rw-r--r--games/0ad/files/patch-source-lib-debug.h11
6 files changed, 49 insertions, 15 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 9f831e9efb20..b654217ddbe9 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= 0ad
-PORTVERSION= 0.0.11
+PORTVERSION= 0.0.12
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
diff --git a/games/0ad/distinfo b/games/0ad/distinfo
index 8e36a9cc6251..a8650c45594d 100644
--- a/games/0ad/distinfo
+++ b/games/0ad/distinfo
@@ -1,4 +1,4 @@
-SHA256 (0ad-0.0.11-alpha-unix-build.tar.xz) = a218c42bce111d0bcb02b3a18eb14d7c06a839b8863df362083ebd0835d3c6a3
-SIZE (0ad-0.0.11-alpha-unix-build.tar.xz) = 8682272
-SHA256 (0ad-0.0.11-alpha-unix-data.tar.xz) = a28dd9160637bc1345223ec6f9c36bb693350e9dcc35a3194f43ed463b3ba20e
-SIZE (0ad-0.0.11-alpha-unix-data.tar.xz) = 350967036
+SHA256 (0ad-0.0.12-alpha-unix-build.tar.xz) = 69d01f9ba12bb78f58fc2c567187cfffe20055591f378724b906e6a48ac73877
+SIZE (0ad-0.0.12-alpha-unix-build.tar.xz) = 8693880
+SHA256 (0ad-0.0.12-alpha-unix-data.tar.xz) = 0efd800a149f2fed70d7e133b93a385e82810844b50154771514d17d9a68ee07
+SIZE (0ad-0.0.12-alpha-unix-data.tar.xz) = 388143556
diff --git a/games/0ad/files/patch-build-premake-premake4.lua b/games/0ad/files/patch-build-premake-premake4.lua
index ba2d912fd2af..22c3eb72e81b 100644
--- a/games/0ad/files/patch-build-premake-premake4.lua
+++ b/games/0ad/files/patch-build-premake-premake4.lua
@@ -1,6 +1,15 @@
---- build/premake/premake4.lua.orig 2012-08-15 02:10:44.000000000 +0200
-+++ build/premake/premake4.lua 2012-09-13 04:13:10.184743291 +0200
-@@ -220,7 +220,6 @@
+--- build/premake/premake4.lua.orig 2012-10-30 01:56:24.000000000 +0100
++++ build/premake/premake4.lua 2012-12-26 18:37:28.882327928 +0100
+@@ -134,7 +134,7 @@
+
+ function project_set_build_flags()
+
+- flags { "Symbols", "NoEditAndContinue" }
++ flags { "NoEditAndContinue" }
+ if not _OPTIONS["icc"] and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
+ -- adds the -Wall compiler flag
+ flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
+@@ -215,7 +215,6 @@
-- enable security features (stack checking etc) that shouldn't have
-- a significant effect on performance and can catch bugs
@@ -8,18 +17,18 @@
"-D_FORTIFY_SOURCE=2",
-- always enable strict aliasing (useful in debug builds because of the warnings)
-@@ -292,11 +291,11 @@
+@@ -287,11 +286,11 @@
-- X11 includes may be installed in one of a gadzillion of three places
-- Famous last words: "You can't include too much! ;-)"
includedirs {
- "/usr/X11R6/include/X11",
- "/usr/X11R6/include",
-+ "%%LOCALBASE%%/X11",
-+ "%%LOCALBASE%%/include",
++ "/usr/local/X11",
++ "/usr/local/include",
"/usr/include/X11"
}
- libdirs { "/usr/X11R6/lib" }
-+ libdirs { "%%LOCALBASE%%/lib" }
++ libdirs { "/usr/local/lib" }
if _OPTIONS["bindir"] then
defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
diff --git a/games/0ad/files/patch-libraries-spidermonkey-build.sh b/games/0ad/files/patch-libraries-spidermonkey-build.sh
index ef671b4c5d3c..45728197dace 100644
--- a/games/0ad/files/patch-libraries-spidermonkey-build.sh
+++ b/games/0ad/files/patch-libraries-spidermonkey-build.sh
@@ -1,6 +1,6 @@
---- libraries/spidermonkey/build.sh.orig 2012-01-31 01:06:56.000000000 +0100
-+++ libraries/spidermonkey/build.sh 2012-05-03 15:49:34.640969629 +0200
-@@ -49,6 +49,11 @@
+--- libraries/spidermonkey/build.sh.orig 2012-06-11 00:39:26.000000000 +0200
++++ libraries/spidermonkey/build.sh 2012-12-18 10:58:11.343785532 +0100
+@@ -53,6 +53,14 @@
cd js-1.8.5/js/src
@@ -9,6 +9,9 @@
+#include <pthread_np.h>\
+#pragma GCC visibility pop/' jsnativestack.cpp.orig >jsnativestack.cpp
+
++cp configure configure.orig
++sed 's/"$ac_cv_have_visibility_class_bug" = "no"; then/"$ac_cv_have_visibility_class_bug" = "no" -a "$OS_ARCH" != "FreeBSD" ; then/' configure.orig >configure
++
# We want separate debug/release versions of the library, so we have to change
# the LIBRARY_NAME for each build.
# (We use perl instead of sed so that it works with MozillaBuild on Windows,
diff --git a/games/0ad/files/patch-source-lib-debug.cpp b/games/0ad/files/patch-source-lib-debug.cpp
new file mode 100644
index 000000000000..486c277fef21
--- /dev/null
+++ b/games/0ad/files/patch-source-lib-debug.cpp
@@ -0,0 +1,11 @@
+--- source/lib/debug.cpp.orig 2012-12-27 22:33:04.665325819 +0100
++++ source/lib/debug.cpp 2012-12-27 22:34:32.369332795 +0100
+@@ -353,6 +353,8 @@
+ // exit really doesn't want to see any more messages.
+ static atomic_bool isExiting;
+
++const atomic_bool DEBUG_SUPPRESS = 0xAB;
++
+ // this logic is applicable to any type of error. special cases such as
+ // suppressing certain expected WARN_ERRs are done there.
+ static bool ShouldSuppressError(atomic_bool* suppress)
diff --git a/games/0ad/files/patch-source-lib-debug.h b/games/0ad/files/patch-source-lib-debug.h
new file mode 100644
index 000000000000..e0d7b0df804a
--- /dev/null
+++ b/games/0ad/files/patch-source-lib-debug.h
@@ -0,0 +1,11 @@
+--- source/lib/debug.h.orig 2012-12-27 22:32:56.384331917 +0100
++++ source/lib/debug.h 2012-12-27 22:33:41.699327215 +0100
+@@ -122,7 +122,7 @@
+ * debugging the symbol engine.
+ * use 0 as the initial value to avoid allocating .rdata space.
+ **/
+-const atomic_bool DEBUG_SUPPRESS = 0xAB;
++extern const atomic_bool DEBUG_SUPPRESS;
+
+ /**
+ * choices offered by the error dialog that are returned