aboutsummaryrefslogtreecommitdiff
path: root/games/0verkill
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2014-02-10 11:14:37 +0000
committerMichael Landin <mich@FreeBSD.org>2014-02-10 11:14:37 +0000
commitbc476217bafc2f8eb78c266a2d84a31de364bc99 (patch)
tree45c1f8d8b2c7c480b543e90f9265d51a03582c60 /games/0verkill
parent238e16c36311a196fbccb2097adc93da7731be87 (diff)
Notes
Diffstat (limited to 'games/0verkill')
-rw-r--r--games/0verkill/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/games/0verkill/Makefile b/games/0verkill/Makefile
index 53b28265f8d6..03fdfe8a1874 100644
--- a/games/0verkill/Makefile
+++ b/games/0verkill/Makefile
@@ -31,23 +31,26 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/0verkill ${STAGEDIR}${PREFIX}/bin
-.for file in avi bot editor server test_server
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} \
- ${STAGEDIR}${PREFIX}/bin/0verkill-${file}
+.for filename in avi bot editor server test_server
+ ${INSTALL_PROGRAM} ${WRKSRC}/${filename} \
+ ${STAGEDIR}${PREFIX}/bin/0verkill-${filename}
.endfor
.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} ${WRKSRC}/x0verkill ${STAGEDIR}${PREFIX}/bin
-.for file in avi editor
- ${INSTALL_PROGRAM} ${WRKSRC}/x${file} \
- ${STAGEDIR}${PREFIX}/bin/x0verkill-${file}
+.for filename in avi editor
+ ${INSTALL_PROGRAM} ${WRKSRC}/x${filename} \
+ ${STAGEDIR}${PREFIX}/bin/x0verkill-${filename}
.endfor
.endif
.for dir in data grx
cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
.endfor
+
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for file in AUTHORS README.html avi.txt bot.txt doc.html
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
+.for filename in AUTHORS README.html avi.txt bot.txt doc.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/${filename} ${STAGEDIR}${DOCSDIR}
.endfor
+.endif
.include <bsd.port.mk>