aboutsummaryrefslogtreecommitdiff
path: root/games/2048-qt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-05-31 17:41:43 +0000
committerSteve Wills <swills@FreeBSD.org>2015-05-31 17:41:43 +0000
commit0576206bfc8603c113022c5b43f818c8c9b2442f (patch)
tree6db416732231291c5c751abb38e5757b3c524be4 /games/2048-qt
parentb15986fc249d52347e94df9d69030ac3194ef99e (diff)
downloadports-0576206bfc8603c113022c5b43f818c8c9b2442f.tar.gz
ports-0576206bfc8603c113022c5b43f818c8c9b2442f.zip
Notes
Diffstat (limited to 'games/2048-qt')
-rw-r--r--games/2048-qt/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/2048-qt/Makefile b/games/2048-qt/Makefile
index 79193117ba0e..c4de4d16e9ab 100644
--- a/games/2048-qt/Makefile
+++ b/games/2048-qt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= 2048-qt
PORTVERSION= 0.1.5
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= GH
@@ -14,11 +15,15 @@ GH_ACCOUNT= xiaoyong
GH_PROJECT= 2048-Qt
USES= gmake pkgconfig qmake tar:bzip2
-USE_QT5= core gui network widgets qml quick buildtools quickcontrols
+USE_QT5= core gui network widgets qml quick buildtools_build quickcontrols
-PLIST_FILES= bin/2048-qt
+PLIST_FILES= bin/2048-qt ${DESKTOPDIR}/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/2048-qt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/icons/256x256/apps/2048-qt.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>