aboutsummaryrefslogtreecommitdiff
path: root/games/3dc/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 15:30:11 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 15:30:11 +0000
commit43bf815f1612c76ba601905a9de36b14614abdcd (patch)
tree64ef68d249a87c09a81058dc7c63a172025def14 /games/3dc/Makefile
parentf692f32ad8df8f0d659937ad25dedb11f6fc026a (diff)
downloadports-43bf815f1612c76ba601905a9de36b14614abdcd.tar.gz
ports-43bf815f1612c76ba601905a9de36b14614abdcd.zip
Notes
Diffstat (limited to 'games/3dc/Makefile')
-rw-r--r--games/3dc/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index f646c87544cf..20d301b3d012 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -14,14 +14,15 @@ COMMENT= 3-Dimensional Chess for X Window System
LICENSE= GPLv2
-LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
USES= perl5
USE_PERL5= build
USE_XORG= x11 xaw xext xmu xpm xt
WRKSRC= ${WRKDIR}/3Dc/src
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
.for file in init.c main.c piece.c stack.c xif.c
@${REINPLACE_CMD} -i '' -e 's|malloc.h|stdlib.h|' \
@@ -29,12 +30,10 @@ post-patch:
.endfor
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/3Dc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/3Dc
+ ${INSTALL_PROGRAM} ${WRKSRC}/3Dc ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/3Dc
.for file in 3Dc-rules.html ACKNOWLEDGEMENTS GPL README TODO
- @ ${INSTALL_DATA} ${WRKSRC}/../${file} ${PREFIX}/share/doc/3Dc
+ ${INSTALL_DATA} ${WRKSRC}/../${file} ${STAGEDIR}${PREFIX}/share/doc/3Dc
.endfor
-.endif
.include <bsd.port.mk>