aboutsummaryrefslogtreecommitdiff
path: root/games/3dpong
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:21:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:21:20 +0000
commit0c70864fbc4b4e55defca0bf53ba035e2b0ca635 (patch)
tree9c5b0e0f1ba5743a88f1bd59059a15c26a6ef7b0 /games/3dpong
parent08c0128817ed46d3e85946ca76e59b215354df1b (diff)
downloadports-0c70864fbc4b4e55defca0bf53ba035e2b0ca635.tar.gz
ports-0c70864fbc4b4e55defca0bf53ba035e2b0ca635.zip
Notes
Diffstat (limited to 'games/3dpong')
-rw-r--r--games/3dpong/Makefile14
-rw-r--r--games/3dpong/distinfo4
-rw-r--r--games/3dpong/files/patch-aa93
-rw-r--r--games/3dpong/files/patch-ab11
-rw-r--r--games/3dpong/pkg-descr8
-rw-r--r--games/3dpong/pkg-plist4
6 files changed, 19 insertions, 115 deletions
diff --git a/games/3dpong/Makefile b/games/3dpong/Makefile
index 816cf3a2be4b..d42fdc1d3ae0 100644
--- a/games/3dpong/Makefile
+++ b/games/3dpong/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= 3dpong
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= games
MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/3dpong/src/
@@ -15,11 +15,13 @@ COMMENT= X Window 3D Pong game for 1 or 2 players with a ball and paddles
USE_X_PREFIX= yes
USE_REINPLACE= yes
-MAKEFILE= makefile
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${X11BASE}/include" \
+ XLIB="-L${X11BASE}/lib -lX11"
post-patch:
- @${REINPLACE_CMD} -e 's. chmod . ${CHMOD} .g' \
- ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e \
+ 's|cat sounds/|cat ${DATADIR}/|g' ${WRKSRC}/src/3dpong.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/3dpong ${PREFIX}/bin
@@ -27,7 +29,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.for file in AUTHORS.txt CHANGES.txt INSTALL.txt README.txt TODO.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/games/3dpong/distinfo b/games/3dpong/distinfo
index 39b112bd7867..044bc4413869 100644
--- a/games/3dpong/distinfo
+++ b/games/3dpong/distinfo
@@ -1,2 +1,2 @@
-MD5 (3dpong-0.4.tar.gz) = 9f90508b260b43f6cb6514b18fb17acb
-SIZE (3dpong-0.4.tar.gz) = 33910
+MD5 (3dpong-0.5.tar.gz) = 91594c0fd5def93053d911e037f5a383
+SIZE (3dpong-0.5.tar.gz) = 37004
diff --git a/games/3dpong/files/patch-aa b/games/3dpong/files/patch-aa
deleted file mode 100644
index 0f2acf02676f..000000000000
--- a/games/3dpong/files/patch-aa
+++ /dev/null
@@ -1,93 +0,0 @@
---- makefile.orig Sat Mar 14 20:43:34 1998
-+++ makefile Sun Jun 10 17:32:36 2001
-@@ -11,11 +11,28 @@
-
- # Makefile user-definable variables
-
--CC=gcc -I/usr/X11R6/include
-+# C compiler
-+CC?=cc
-+
-+# C compiler options
-+CFLAGS?=-Wall
-+
-+# X Window base directory
-+X11BASE?=/usr/X11R6
-+
-+# Include directory
-+INCLUDE=-I$(X11BASE)/include
-+
-+# Installation directory
-+PREFIX?=$(X11BASE)
-+
-+# Defines
-+DEFINE=-DPREFIX=\"$(PREFIX)\"
-+
- MATHLIB=-lm
-
--# adjust according to target
--XLIB=-L/usr/X11R6/lib -lX11
-+# X library
-+XLIB=-L$(X11BASE)/lib -lX11
-
- # uncomment for sunos/solaris
- #XLIB=-L/usr/openwin/lib -lX11
-@@ -33,7 +50,7 @@
- # Makefile commands:
-
- all: 3dpong
-- chmod 755 go handball sounds
-+ chmod 755 sounds
- chmod 644 *.c *.h makefile sounds/*.au *.txt
-
- clean:
-@@ -43,7 +60,7 @@
- # Application:
-
- 3dpong: $(OBJECTS)
-- $(CC) $(OBJECTS) $(XLIB) $(MATHLIB) -o 3dpong
-+ $(CC) $(CFLAGS) $(OBJECTS) $(XLIB) $(MATHLIB) -o 3dpong
- chmod 755 3dpong
- strip 3dpong
-
-@@ -52,31 +69,31 @@
-
- 3dpong.o: 3dpong.c window.h connect.h hints.h visual.h gc.h color.h \
- randnum.h text.h
-- $(CC) 3dpong.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) 3dpong.c -c
-
-
- # Library objects:
-
- window.o: window.c window.h
-- $(CC) window.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) window.c -c
-
- connect.o: connect.c connect.h
-- $(CC) connect.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) connect.c -c
-
- hints.o: hints.c hints.h
-- $(CC) hints.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) hints.c -c
-
- visual.o: visual.c visual.h
-- $(CC) visual.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) visual.c -c
-
- gc.o: gc.c gc.h
-- $(CC) gc.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) gc.c -c
-
- color.o: color.c color.h
-- $(CC) color.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) color.c -c
-
- randnum.o: randnum.c randnum.h
-- $(CC) randnum.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) randnum.c -c
-
- text.o: text.c text.h
-- $(CC) text.c -c
-+ $(CC) $(CFLAGS) $(INCLUDE) $(DEFINE) text.c -c
diff --git a/games/3dpong/files/patch-ab b/games/3dpong/files/patch-ab
deleted file mode 100644
index b30a68d537b6..000000000000
--- a/games/3dpong/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- 3dpong.c Mon Jan 26 20:33:47 1998
-+++ /home/andy/tmp/wrk/3dpong.c Tue Mar 10 20:58:20 1998
-@@ -1651,7 +1651,7 @@
-
- if (use_sound == 1)
- {
-- sprintf(cmd, "/bin/cat sounds/%s.au > /dev/audio &", aufile);
-+ sprintf(cmd, "/bin/cat " PREFIX "/share/3dpong/%s.au > /dev/audio &", aufile);
-
- system(cmd);
- }
diff --git a/games/3dpong/pkg-descr b/games/3dpong/pkg-descr
index 42414e225a36..a793e5aad553 100644
--- a/games/3dpong/pkg-descr
+++ b/games/3dpong/pkg-descr
@@ -1,7 +1,7 @@
- 3D Pong is an X Window game for 1 or 2 players. It's a 3D game based
-on the first arcade game, "Pong." Like "Pong," it's a game played with
-a ball and paddles. The object is to hit the ball and get it in the
-other player's goal. Use your paddle to deflect the ball and keep it
+3D Pong is an X Window game for 1 or 2 players. It's a 3D game based
+on the first arcade game, "Pong." Like "Pong," it's a game played with
+a ball and paddles. The object is to hit the ball and get it in the
+other player's goal. Use your paddle to deflect the ball and keep it
from getting in your goal.
WWW: http://www.newbreedsoftware.com/3dpong/
diff --git a/games/3dpong/pkg-plist b/games/3dpong/pkg-plist
index 820afa5a424d..3bfce1e13f7c 100644
--- a/games/3dpong/pkg-plist
+++ b/games/3dpong/pkg-plist
@@ -2,6 +2,10 @@ bin/3dpong
%%DATADIR%%/hit.au
%%DATADIR%%/score.au
%%DATADIR%%/wall.au
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%