aboutsummaryrefslogtreecommitdiff
path: root/games/44bsd-hunt
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-10-26 06:23:20 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-10-26 06:23:20 +0000
commit4ea770acd9ad9ac71b48224ac0d36c0be565d42d (patch)
tree9aead22aa78c46c0e002761a1c3e011afe25c94c /games/44bsd-hunt
parent53377c4b1ce78f85216deadf9696e6ef18a39cf4 (diff)
downloadports-4ea770acd9ad9ac71b48224ac0d36c0be565d42d.tar.gz
ports-4ea770acd9ad9ac71b48224ac0d36c0be565d42d.zip
Notes
Diffstat (limited to 'games/44bsd-hunt')
-rw-r--r--games/44bsd-hunt/Makefile8
-rw-r--r--games/44bsd-hunt/files/patch-driver.c21
2 files changed, 22 insertions, 7 deletions
diff --git a/games/44bsd-hunt/Makefile b/games/44bsd-hunt/Makefile
index 88f1638c1d84..5cad662259f6 100644
--- a/games/44bsd-hunt/Makefile
+++ b/games/44bsd-hunt/Makefile
@@ -14,10 +14,4 @@ COMMENT= Rogue-like multiplayer game
MAN6= hunt.6 huntd.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/44bsd-hunt/files/patch-driver.c b/games/44bsd-hunt/files/patch-driver.c
new file mode 100644
index 000000000000..daf2ad678e45
--- /dev/null
+++ b/games/44bsd-hunt/files/patch-driver.c
@@ -0,0 +1,21 @@
+$FreeBSD$
+
+--- driver.c.orig Sat Oct 25 23:20:56 2003
++++ driver.c Sat Oct 25 23:21:54 2003
+@@ -9,6 +9,7 @@
+ # include <errno.h>
+ # include <sys/ioctl.h>
+ # include <sys/time.h>
++# include <err.h>
+
+ # ifndef pdp11
+ # define RN (((Seed = Seed * 11109 + 13849) >> 16) & 0xffff)
+@@ -653,7 +654,7 @@
+ if (np->p_flying < 0)
+ break;
+ if (np >= &Boot[NBOOTS])
+- abort(1, "Too many boots");
++ errx(1, "Too many boots");
+ np->p_undershot = FALSE;
+ np->p_x = pp->p_x;
+ np->p_y = pp->p_y;