aboutsummaryrefslogtreecommitdiff
path: root/games/7kaa
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-04 00:31:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-04 00:31:07 +0000
commitd8e0232469cae56fe1f3c168bc6de3618d0c0e08 (patch)
tree56d061c4981d5417dcb5eb210aba44f4e462984d /games/7kaa
parent0003650a1ccfc2a6190e7d01c276f8ff48c97725 (diff)
downloadports-d8e0232469cae56fe1f3c168bc6de3618d0c0e08.tar.gz
ports-d8e0232469cae56fe1f3c168bc6de3618d0c0e08.zip
Notes
Diffstat (limited to 'games/7kaa')
-rw-r--r--games/7kaa/Makefile9
-rw-r--r--games/7kaa/distinfo5
-rw-r--r--games/7kaa/files/patch-src_common_OMISC.cpp25
3 files changed, 6 insertions, 33 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index 8117fa36c5ff..dae1589eb957 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= 7kaa
-PORTVERSION= 2.14.5
+PORTVERSION= 2.14.6
CATEGORIES= games
MASTER_SITES= SF/skfans/7KAA%20${PORTVERSION}
@@ -14,14 +14,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libenet.so:net/enet
+USES= gmake localbase openal:al tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls # no translations ATM
-USES= gmake openal:al tar:xz
USE_SDL= sdl2
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= *
PORTDATA= *
@@ -29,6 +26,6 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
post-install:
- ${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
+ @${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
.include <bsd.port.mk>
diff --git a/games/7kaa/distinfo b/games/7kaa/distinfo
index 6c6337c3d3db..f6bf5a053880 100644
--- a/games/7kaa/distinfo
+++ b/games/7kaa/distinfo
@@ -1,2 +1,3 @@
-SHA256 (7kaa-2.14.5.tar.xz) = c7f04fa640d324ed8f1523da49945acd0f1ee2a99e3ee82ee29b52d2f735e464
-SIZE (7kaa-2.14.5.tar.xz) = 31223408
+TIMESTAMP = 1473115708
+SHA256 (7kaa-2.14.6.tar.xz) = fcbe2d7fc12fab7a2c08a14317264c9f96a6ebca18b28f3fee78925442bdd573
+SIZE (7kaa-2.14.6.tar.xz) = 31220676
diff --git a/games/7kaa/files/patch-src_common_OMISC.cpp b/games/7kaa/files/patch-src_common_OMISC.cpp
deleted file mode 100644
index fb3b6bbc0e5b..000000000000
--- a/games/7kaa/files/patch-src_common_OMISC.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/common/OMISC.cpp.orig 2015-05-19 01:00:20 UTC
-+++ src/common/OMISC.cpp
-@@ -37,6 +37,7 @@
- #include <stdlib.h>
- #include <time.h>
- #include <ctype.h>
-+#include <math.h>
-
- #include <ALL.h>
- #include <OSTR.h>
-@@ -755,10 +756,13 @@ char* Misc::format(double inNum, int for
-
- static char outBuf[35];
- char *outPtr=outBuf;
-+ char floatBuf[35];
- char *floatStr;
- int i, intDigit, sign; // intDigit = no. of integer digits
-
-- floatStr = fcvt( inNum, MONEY_DEC_PLACE, &intDigit, &sign );
-+ intDigit = snprintf(floatBuf, sizeof(floatBuf), "%.0lf", fabs(inNum) * 100.0);
-+ intDigit -= 2;
-+ floatStr = floatBuf;
-
- #ifdef DEBUG
- if( intDigit > 29 ) // integer digits can't exceed 29