aboutsummaryrefslogtreecommitdiff
path: root/games/BillardGL
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-13 18:58:57 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-13 18:58:57 +0000
commit957a11558e3b173bb5b28c5d88442e08407bd71c (patch)
treef8392fa46ee13f57484f7b0087b0f8217342b555 /games/BillardGL
parenteb86ce03de743c2c0bd452dae66f5cc58aecd723 (diff)
downloadports-957a11558e3b173bb5b28c5d88442e08407bd71c.tar.gz
ports-957a11558e3b173bb5b28c5d88442e08407bd71c.zip
Notes
Diffstat (limited to 'games/BillardGL')
-rw-r--r--games/BillardGL/Makefile35
-rw-r--r--games/BillardGL/pkg-plist134
2 files changed, 151 insertions, 18 deletions
diff --git a/games/BillardGL/Makefile b/games/BillardGL/Makefile
index e86dca25f135..06101ec50c54 100644
--- a/games/BillardGL/Makefile
+++ b/games/BillardGL/Makefile
@@ -1,4 +1,4 @@
-# Created By: Igor Pokrovsky <tiamat@comset.net>
+# Created by: Igor Pokrovsky <tiamat@comset.net>
# $FreeBSD$
PORTNAME= BillardGL
@@ -26,36 +26,34 @@ USE_GMAKE= yes
USE_XORG= xmu xext x11 xi
USE_GL= glut
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png \
- share/icons/hicolor/32x32/apps/${PORTNAME}.png \
- share/icons/hicolor/48x48/apps/${PORTNAME}.png \
- share/icons/hicolor/64x64/apps/${PORTNAME}.png \
- share/icons/hicolor/72x72/apps/${PORTNAME}.png \
- share/icons/hicolor/96x96/apps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= README
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
-DESKTOP_ENTRIES="BillardGL" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+DESKTOP_ENTRIES="BillardGL" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
OPTIONS_DEFINE= LANG
-LANG_DESC= Install additional Language
-OPTIONS_DEFAULT= LANG
+OPTIONS_DEFAULT=LANG
+LANG_DESC= Install Language
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MLANG}
+PLIST_SUB+= LANG=""
+.else
+PLIST_SUB+= LANG="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/BillardGL/|${DATADIR}/|' ${WRKSRC}/Namen.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.for d in Texturen lang
+.for d in Texturen
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
.endfor
@@ -65,7 +63,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
@@ -73,7 +71,8 @@ post-install:
.endif
.if ${PORT_OPTIONS:MLANG}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-LP-010/*.lang ${DATADIR}/lang
+ @${MKDIR} ${DATADIR}/lang
+ @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-LP-010/*.lang ${DATADIR}/lang/
.endif
.include <bsd.port.mk>
diff --git a/games/BillardGL/pkg-plist b/games/BillardGL/pkg-plist
new file mode 100644
index 000000000000..6ff3dd3f6f19
--- /dev/null
+++ b/games/BillardGL/pkg-plist
@@ -0,0 +1,134 @@
+bin/BillardGL
+%%DATADIR%%/Texturen/1/1.bmp
+%%DATADIR%%/Texturen/1/10.bmp
+%%DATADIR%%/Texturen/1/11.bmp
+%%DATADIR%%/Texturen/1/12.bmp
+%%DATADIR%%/Texturen/1/13.bmp
+%%DATADIR%%/Texturen/1/14.bmp
+%%DATADIR%%/Texturen/1/15.bmp
+%%DATADIR%%/Texturen/1/2.bmp
+%%DATADIR%%/Texturen/1/3.bmp
+%%DATADIR%%/Texturen/1/4.bmp
+%%DATADIR%%/Texturen/1/5.bmp
+%%DATADIR%%/Texturen/1/6.bmp
+%%DATADIR%%/Texturen/1/7.bmp
+%%DATADIR%%/Texturen/1/8.bmp
+%%DATADIR%%/Texturen/1/9.bmp
+%%DATADIR%%/Texturen/1/a00.bmp
+%%DATADIR%%/Texturen/1/a1.bmp
+%%DATADIR%%/Texturen/1/a10.bmp
+%%DATADIR%%/Texturen/1/a11.bmp
+%%DATADIR%%/Texturen/1/a12.bmp
+%%DATADIR%%/Texturen/1/a13.bmp
+%%DATADIR%%/Texturen/1/a14.bmp
+%%DATADIR%%/Texturen/1/a15.bmp
+%%DATADIR%%/Texturen/1/a2.bmp
+%%DATADIR%%/Texturen/1/a3.bmp
+%%DATADIR%%/Texturen/1/a4.bmp
+%%DATADIR%%/Texturen/1/a5.bmp
+%%DATADIR%%/Texturen/1/a6.bmp
+%%DATADIR%%/Texturen/1/a7.bmp
+%%DATADIR%%/Texturen/1/a8.bmp
+%%DATADIR%%/Texturen/1/a9.bmp
+%%DATADIR%%/Texturen/1/aalpha.bmp
+%%DATADIR%%/Texturen/1/aalpha2.bmp
+%%DATADIR%%/Texturen/1/buchstaben.bmp
+%%DATADIR%%/Texturen/1/buchstabenalpha.bmp
+%%DATADIR%%/Texturen/1/dreizehn.bmp
+%%DATADIR%%/Texturen/1/filzkachel.bmp
+%%DATADIR%%/Texturen/1/halbe.bmp
+%%DATADIR%%/Texturen/1/holz.bmp
+%%DATADIR%%/Texturen/1/logo.bmp
+%%DATADIR%%/Texturen/1/volle.bmp
+%%DATADIR%%/Texturen/2/1.bmp
+%%DATADIR%%/Texturen/2/10.bmp
+%%DATADIR%%/Texturen/2/11.bmp
+%%DATADIR%%/Texturen/2/12.bmp
+%%DATADIR%%/Texturen/2/13.bmp
+%%DATADIR%%/Texturen/2/14.bmp
+%%DATADIR%%/Texturen/2/15.bmp
+%%DATADIR%%/Texturen/2/2.bmp
+%%DATADIR%%/Texturen/2/3.bmp
+%%DATADIR%%/Texturen/2/4.bmp
+%%DATADIR%%/Texturen/2/5.bmp
+%%DATADIR%%/Texturen/2/6.bmp
+%%DATADIR%%/Texturen/2/7.bmp
+%%DATADIR%%/Texturen/2/8.bmp
+%%DATADIR%%/Texturen/2/9.bmp
+%%DATADIR%%/Texturen/2/aalpha2.bmp
+%%DATADIR%%/Texturen/2/buchstaben.bmp
+%%DATADIR%%/Texturen/2/buchstabenalpha.bmp
+%%DATADIR%%/Texturen/2/filzkachel.bmp
+%%DATADIR%%/Texturen/2/halbe.bmp
+%%DATADIR%%/Texturen/2/holz.bmp
+%%DATADIR%%/Texturen/2/volle.bmp
+%%DATADIR%%/Texturen/4/1.bmp
+%%DATADIR%%/Texturen/4/10.bmp
+%%DATADIR%%/Texturen/4/11.bmp
+%%DATADIR%%/Texturen/4/12.bmp
+%%DATADIR%%/Texturen/4/13.bmp
+%%DATADIR%%/Texturen/4/14.bmp
+%%DATADIR%%/Texturen/4/15.bmp
+%%DATADIR%%/Texturen/4/2.bmp
+%%DATADIR%%/Texturen/4/3.bmp
+%%DATADIR%%/Texturen/4/4.bmp
+%%DATADIR%%/Texturen/4/5.bmp
+%%DATADIR%%/Texturen/4/6.bmp
+%%DATADIR%%/Texturen/4/7.bmp
+%%DATADIR%%/Texturen/4/8.bmp
+%%DATADIR%%/Texturen/4/9.bmp
+%%DATADIR%%/Texturen/4/holz.bmp
+%%DATADIR%%/Texturen/8/1.bmp
+%%DATADIR%%/Texturen/8/10.bmp
+%%DATADIR%%/Texturen/8/11.bmp
+%%DATADIR%%/Texturen/8/12.bmp
+%%DATADIR%%/Texturen/8/13.bmp
+%%DATADIR%%/Texturen/8/14.bmp
+%%DATADIR%%/Texturen/8/15.bmp
+%%DATADIR%%/Texturen/8/2.bmp
+%%DATADIR%%/Texturen/8/3.bmp
+%%DATADIR%%/Texturen/8/4.bmp
+%%DATADIR%%/Texturen/8/5.bmp
+%%DATADIR%%/Texturen/8/6.bmp
+%%DATADIR%%/Texturen/8/7.bmp
+%%DATADIR%%/Texturen/8/8.bmp
+%%DATADIR%%/Texturen/8/9.bmp
+%%DATADIR%%/Texturen/8/holz.bmp
+%%LANG%%%%DATADIR%%/lang/900.lang
+%%LANG%%%%DATADIR%%/lang/901.lang
+%%LANG%%%%DATADIR%%/lang/903.lang
+%%LANG%%%%DATADIR%%/lang/904.lang
+%%LANG%%%%DATADIR%%/lang/905.lang
+%%LANG%%%%DATADIR%%/lang/906.lang
+%%LANG%%%%DATADIR%%/lang/907.lang
+%%LANG%%%%DATADIR%%/lang/908.lang
+%%LANG%%%%DATADIR%%/lang/909.lang
+%%LANG%%%%DATADIR%%/lang/910.lang
+%%LANG%%%%DATADIR%%/lang/911.lang
+%%LANG%%%%DATADIR%%/lang/912.lang
+%%LANG%%%%DATADIR%%/lang/999.lang
+share/icons/hicolor/32x32/apps/BillardGL.png
+share/icons/hicolor/48x48/apps/BillardGL.png
+share/icons/hicolor/64x64/apps/BillardGL.png
+share/icons/hicolor/72x72/apps/BillardGL.png
+share/icons/hicolor/96x96/apps/BillardGL.png
+share/pixmaps/BillardGL.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+%%LANG%%@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%/Texturen/8
+@dirrm %%DATADIR%%/Texturen/4
+@dirrm %%DATADIR%%/Texturen/2
+@dirrm %%DATADIR%%/Texturen/1
+@dirrm %%DATADIR%%/Texturen
+@dirrm %%DATADIR%%