aboutsummaryrefslogtreecommitdiff
path: root/games/HeroesOfMightAndMagic
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-11-28 21:27:24 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-11-28 21:27:24 +0000
commit7d2662e3400d7e22eef5d9e3177a7333bd02a5ef (patch)
tree68ebcbadb026663c994fa56c8189b6d7ec6a8530 /games/HeroesOfMightAndMagic
parente53a32eee68e8ca2f8fa5ebd484108d51aac791d (diff)
downloadports-7d2662e3400d7e22eef5d9e3177a7333bd02a5ef.tar.gz
ports-7d2662e3400d7e22eef5d9e3177a7333bd02a5ef.zip
Notes
Diffstat (limited to 'games/HeroesOfMightAndMagic')
-rw-r--r--games/HeroesOfMightAndMagic/Makefile41
-rw-r--r--games/HeroesOfMightAndMagic/files/pkg-plist.base11
-rw-r--r--games/HeroesOfMightAndMagic/files/pkg-plist.music49
-rw-r--r--games/HeroesOfMightAndMagic/files/pkg-plist.scenario50
-rw-r--r--games/HeroesOfMightAndMagic/files/pkg-plist.tail2
-rw-r--r--games/HeroesOfMightAndMagic/files/pkg-plist.video56
-rw-r--r--games/HeroesOfMightAndMagic/pkg-plist171
-rw-r--r--games/HeroesOfMightAndMagic/scripts/configure91
-rw-r--r--games/HeroesOfMightAndMagic/scripts/do-install98
9 files changed, 201 insertions, 368 deletions
diff --git a/games/HeroesOfMightAndMagic/Makefile b/games/HeroesOfMightAndMagic/Makefile
index a2555bbdde6e..20ececb06ee9 100644
--- a/games/HeroesOfMightAndMagic/Makefile
+++ b/games/HeroesOfMightAndMagic/Makefile
@@ -11,25 +11,44 @@ DISTFILES=
MAINTAINER= mva@FreeBSD.org
COMMENT= BSD Installation of the Linux game "Heroes of Might and Magic III"
-DEPRECATED= Depends on deprecated Linux GTK1
-EXPIRATION_DATE=2013-12-01
-
-PLIST= ${WRKDIR}/PLIST
-IS_INTERACTIVE= yes
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= gtk
NO_BUILD= yes
NO_WRKSUBDIR= yes
NO_CDROM= Software is commercial
NO_PACKAGE= Software is commercial
+NO_STAGE= yes # NO_PACKAGE does not go well with STAGEDIR and pkg_tools
GAMESUBDIR= games/Heroes3
-GAMEDIR= ${PREFIX}/${GAMESUBDIR}
-SCRIPTS_ENV+= INSTALL_DATA="${INSTALL_DATA}" PLIST=${PLIST} PKGDIR=${PKGDIR}
+GAMEDIR= ${STAGEDIR}${PREFIX}/${GAMESUBDIR}
+
+GAMEFILES= README Heroes_III_Tutorial.pdf icon.bmp icon.xpm
+DATAFILES= *.lod *.snd
+
+.if !defined(CDROM_MOUNT)
+BROKEN= ${PKGNAME} requires CDROM_MOUNT to be set to the mount point of the CD
+.endif
-NO_STAGE= yes
do-install:
- @cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/do-install
+ ${MKDIR} ${GAMEDIR}/bin
+ ${INSTALL_PROGRAM} ${CDROM_MOUNT}/bin/x86/heroes3 ${GAMEDIR}
+ ${BRANDELF} -t Linux ${GAMEDIR}/heroes3
+ ${LN} -sf ${PREFIX}/${GAMESUBDIR}/heroes3 ${STAGEDIR}${PREFIX}/bin/heroes3
+.for f in ${GAMEFILES}
+ ${INSTALL_DATA} ${CDROM_MOUNT}/${f} ${GAMEDIR}
+.endfor
+ ${MKDIR} ${GAMEDIR}/data
+ ${TOUCH} ${GAMEDIR}/data/hiscore.dat
+ ${CHMOD} 666 ${GAMEDIR}/data/hiscore.dat
+.for f in ${DATAFILES}
+ ${INSTALL_DATA} ${CDROM_MOUNT}/data/${f} ${GAMEDIR}/data
+.endfor
+ ${MKDIR} ${GAMEDIR}/maps
+ ${INSTALL_DATA} ${CDROM_MOUNT}/maps/* ${GAMEDIR}/maps
+ ${MKDIR} ${GAMEDIR}/data/video
+ ${INSTALL_DATA} ${CDROM_MOUNT}/data/video/*.mjpg ${GAMEDIR}/data/video
+ ${INSTALL_DATA} ${CDROM_MOUNT}/data/video/credits.pcx ${GAMEDIR}/data/video
+ ${INSTALL_DATA} ${CDROM_MOUNT}/data/video/*.mpg ${GAMEDIR}/data/video
+ ${MKDIR} ${GAMEDIR}/mp3
+ ${INSTALL_DATA} ${CDROM_MOUNT}/mp3/* ${GAMEDIR}/mp3
.include <bsd.port.mk>
diff --git a/games/HeroesOfMightAndMagic/files/pkg-plist.base b/games/HeroesOfMightAndMagic/files/pkg-plist.base
deleted file mode 100644
index eeb5714b348b..000000000000
--- a/games/HeroesOfMightAndMagic/files/pkg-plist.base
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/heroes3
-games/Heroes3/Heroes_III_Tutorial.pdf
-games/Heroes3/README
-games/Heroes3/heroes3
-games/Heroes3/icon.bmp
-games/Heroes3/icon.xpm
-games/Heroes3/data/hiscore.dat
-games/Heroes3/data/h3bitmap.lod
-games/Heroes3/data/h3sprite.lod
-games/Heroes3/data/heroes3.snd
-games/Heroes3/data/heroes3cd.snd
diff --git a/games/HeroesOfMightAndMagic/files/pkg-plist.music b/games/HeroesOfMightAndMagic/files/pkg-plist.music
deleted file mode 100644
index 566dbb54040a..000000000000
--- a/games/HeroesOfMightAndMagic/files/pkg-plist.music
+++ /dev/null
@@ -1,49 +0,0 @@
-games/Heroes3/mp3/aitheme0.mp3
-games/Heroes3/mp3/aitheme1.mp3
-games/Heroes3/mp3/aitheme2.mp3
-games/Heroes3/mp3/campainmusic01.mp3
-games/Heroes3/mp3/campainmusic02.mp3
-games/Heroes3/mp3/campainmusic03.mp3
-games/Heroes3/mp3/campainmusic04.mp3
-games/Heroes3/mp3/campainmusic05.mp3
-games/Heroes3/mp3/campainmusic06.mp3
-games/Heroes3/mp3/campainmusic07.mp3
-games/Heroes3/mp3/campainmusic08.mp3
-games/Heroes3/mp3/campainmusic09.mp3
-games/Heroes3/mp3/combat01.mp3
-games/Heroes3/mp3/combat02.mp3
-games/Heroes3/mp3/combat03.mp3
-games/Heroes3/mp3/combat04.mp3
-games/Heroes3/mp3/cstletown.mp3
-games/Heroes3/mp3/defend castle.mp3
-games/Heroes3/mp3/dirt.mp3
-games/Heroes3/mp3/dungeon.mp3
-games/Heroes3/mp3/eviltheme.mp3
-games/Heroes3/mp3/fortresstown.mp3
-games/Heroes3/mp3/goodtheme.mp3
-games/Heroes3/mp3/grass.mp3
-games/Heroes3/mp3/infernotown.mp3
-games/Heroes3/mp3/lava.mp3
-games/Heroes3/mp3/looplepr.mp3
-games/Heroes3/mp3/lose campain.mp3
-games/Heroes3/mp3/losecastle.mp3
-games/Heroes3/mp3/losecombat.mp3
-games/Heroes3/mp3/mainmenu.mp3
-games/Heroes3/mp3/necrotown.mp3
-games/Heroes3/mp3/neutraltheme.mp3
-games/Heroes3/mp3/rampart.mp3
-games/Heroes3/mp3/retreat battle.mp3
-games/Heroes3/mp3/rough.mp3
-games/Heroes3/mp3/sand.mp3
-games/Heroes3/mp3/secrettheme.mp3
-games/Heroes3/mp3/snow.mp3
-games/Heroes3/mp3/stronghold.mp3
-games/Heroes3/mp3/surrender battle.mp3
-games/Heroes3/mp3/swamp.mp3
-games/Heroes3/mp3/towertown.mp3
-games/Heroes3/mp3/ultimatelose.mp3
-games/Heroes3/mp3/underground.mp3
-games/Heroes3/mp3/water.mp3
-games/Heroes3/mp3/win battle.mp3
-games/Heroes3/mp3/win scenario.mp3
-@dirrm games/Heroes3/mp3
diff --git a/games/HeroesOfMightAndMagic/files/pkg-plist.scenario b/games/HeroesOfMightAndMagic/files/pkg-plist.scenario
deleted file mode 100644
index 22506bcbe22f..000000000000
--- a/games/HeroesOfMightAndMagic/files/pkg-plist.scenario
+++ /dev/null
@@ -1,50 +0,0 @@
-games/Heroes3/maps/all for one.h3m
-games/Heroes3/maps/ascension.h3m
-games/Heroes3/maps/barbarian breakout.h3m
-games/Heroes3/maps/barbarian breakouta.h3m
-games/Heroes3/maps/buried treasure.h3m
-games/Heroes3/maps/crimson and clover.h3m
-games/Heroes3/maps/crimson and clovera.h3m
-games/Heroes3/maps/dead and buried.h3m
-games/Heroes3/maps/divided loyalties.h3m
-games/Heroes3/maps/divided loyaltiesa.h3m
-games/Heroes3/maps/dragon orb.h3m
-games/Heroes3/maps/emerald isles.h3m
-games/Heroes3/maps/emerald islesa.h3m
-games/Heroes3/maps/free for all.h3m
-games/Heroes3/maps/good to go.h3m
-games/Heroes3/maps/island of fire.h3m
-games/Heroes3/maps/islands and caves.h3m
-games/Heroes3/maps/judgement day.h3m
-games/Heroes3/maps/key to victory.h3m
-games/Heroes3/maps/knee deep in the dead.h3m
-games/Heroes3/maps/knight of darkness.h3m
-games/Heroes3/maps/manifest destiny.h3m
-games/Heroes3/maps/middletown.h3m
-games/Heroes3/maps/myth and legend.h3m
-games/Heroes3/maps/noahs ark.h3m
-games/Heroes3/maps/overthrow thy neighbors.h3m
-games/Heroes3/maps/peacemaker.h3m
-games/Heroes3/maps/pirates.h3m
-games/Heroes3/maps/race for ardintinny.h3m
-games/Heroes3/maps/realm of chaos.h3m
-games/Heroes3/maps/realm of chaosa.h3m
-games/Heroes3/maps/rebellion.h3m
-games/Heroes3/maps/rumble in the bogs.h3m
-games/Heroes3/maps/rumble in the bogsa.h3m
-games/Heroes3/maps/tutorial.tut
-games/Heroes3/maps/search for the grail.h3m
-games/Heroes3/maps/serpents treasure.h3m
-games/Heroes3/maps/southern cross.h3m
-games/Heroes3/maps/the five rings.h3m
-games/Heroes3/maps/the mandate of heaven.h3m
-games/Heroes3/maps/titans winter.h3m
-games/Heroes3/maps/unholy quest.h3m
-games/Heroes3/maps/vial of life.h3m
-games/Heroes3/maps/warlords.h3m
-games/Heroes3/maps/warlordsa.h3m
-games/Heroes3/maps/warmongers.h3m
-games/Heroes3/maps/when dragons clash.h3m
-games/Heroes3/maps/wings of war.h3m
-games/Heroes3/maps/xathras prize.h3m
-@dirrm games/Heroes3/maps
diff --git a/games/HeroesOfMightAndMagic/files/pkg-plist.tail b/games/HeroesOfMightAndMagic/files/pkg-plist.tail
deleted file mode 100644
index e6e9813433a9..000000000000
--- a/games/HeroesOfMightAndMagic/files/pkg-plist.tail
+++ /dev/null
@@ -1,2 +0,0 @@
-@dirrm games/Heroes3/data
-@dirrm games/Heroes3
diff --git a/games/HeroesOfMightAndMagic/files/pkg-plist.video b/games/HeroesOfMightAndMagic/files/pkg-plist.video
deleted file mode 100644
index 3e40a69cfe36..000000000000
--- a/games/HeroesOfMightAndMagic/files/pkg-plist.video
+++ /dev/null
@@ -1,56 +0,0 @@
-games/Heroes3/data/video/cevil1.mjpg
-games/Heroes3/data/video/cevil2.mjpg
-games/Heroes3/data/video/cgood1.mjpg
-games/Heroes3/data/video/cgood2.mjpg
-games/Heroes3/data/video/cgood3.mjpg
-games/Heroes3/data/video/cneutral.mjpg
-games/Heroes3/data/video/credits.mjpg
-games/Heroes3/data/video/credits.pcx
-games/Heroes3/data/video/csecret.mjpg
-games/Heroes3/data/video/defendall.mjpg
-games/Heroes3/data/video/defendloop.mjpg
-games/Heroes3/data/video/lbloop.mjpg
-games/Heroes3/data/video/lbstart.mjpg
-games/Heroes3/data/video/losecslp.mjpg
-games/Heroes3/data/video/losecstl.mjpg
-games/Heroes3/data/video/pgtrnlft.mjpg
-games/Heroes3/data/video/pgtrnrgh.mjpg
-games/Heroes3/data/video/progressbar.mjpg
-games/Heroes3/data/video/rtloop.mjpg
-games/Heroes3/data/video/rtstart.mjpg
-games/Heroes3/data/video/surrender.mjpg
-games/Heroes3/data/video/tavern.mjpg
-games/Heroes3/data/video/win3.mjpg
-games/Heroes3/data/video/3dologo.mpg
-games/Heroes3/data/video/endgame.mpg
-games/Heroes3/data/video/evil1a.mpg
-games/Heroes3/data/video/evil1b.mpg
-games/Heroes3/data/video/evil1c.mpg
-games/Heroes3/data/video/evil2a.mpg
-games/Heroes3/data/video/evil2ap1.mpg
-games/Heroes3/data/video/evil2ap2.mpg
-games/Heroes3/data/video/evil2b.mpg
-games/Heroes3/data/video/evil2c.mpg
-games/Heroes3/data/video/evil2d.mpg
-games/Heroes3/data/video/good1a.mpg
-games/Heroes3/data/video/good1b.mpg
-games/Heroes3/data/video/good1c.mpg
-games/Heroes3/data/video/good2a.mpg
-games/Heroes3/data/video/good2b.mpg
-games/Heroes3/data/video/good2c.mpg
-games/Heroes3/data/video/good2d.mpg
-games/Heroes3/data/video/good3a.mpg
-games/Heroes3/data/video/good3b.mpg
-games/Heroes3/data/video/good3c.mpg
-games/Heroes3/data/video/h3intro.mpg
-games/Heroes3/data/video/hsanim.mpg
-games/Heroes3/data/video/hsloop.mpg
-games/Heroes3/data/video/losegame.mpg
-games/Heroes3/data/video/neutrala.mpg
-games/Heroes3/data/video/neutralb.mpg
-games/Heroes3/data/video/neutralc.mpg
-games/Heroes3/data/video/nwclogo.mpg
-games/Heroes3/data/video/secreta.mpg
-games/Heroes3/data/video/secretb.mpg
-games/Heroes3/data/video/secretc.mpg
-@dirrm games/Heroes3/data/video
diff --git a/games/HeroesOfMightAndMagic/pkg-plist b/games/HeroesOfMightAndMagic/pkg-plist
new file mode 100644
index 000000000000..8ae49c21ba38
--- /dev/null
+++ b/games/HeroesOfMightAndMagic/pkg-plist
@@ -0,0 +1,171 @@
+bin/heroes3
+games/Heroes3/Heroes_III_Tutorial.pdf
+games/Heroes3/README
+games/Heroes3/data/h3bitmap.lod
+games/Heroes3/data/h3sprite.lod
+games/Heroes3/data/heroes3.snd
+games/Heroes3/data/heroes3cd.snd
+games/Heroes3/data/hiscore.dat
+games/Heroes3/data/video/3dologo.mpg
+games/Heroes3/data/video/cevil1.mjpg
+games/Heroes3/data/video/cevil2.mjpg
+games/Heroes3/data/video/cgood1.mjpg
+games/Heroes3/data/video/cgood2.mjpg
+games/Heroes3/data/video/cgood3.mjpg
+games/Heroes3/data/video/cneutral.mjpg
+games/Heroes3/data/video/credits.mjpg
+games/Heroes3/data/video/credits.pcx
+games/Heroes3/data/video/csecret.mjpg
+games/Heroes3/data/video/defendall.mjpg
+games/Heroes3/data/video/defendloop.mjpg
+games/Heroes3/data/video/endgame.mpg
+games/Heroes3/data/video/evil1a.mpg
+games/Heroes3/data/video/evil1b.mpg
+games/Heroes3/data/video/evil1c.mpg
+games/Heroes3/data/video/evil2a.mpg
+games/Heroes3/data/video/evil2ap1.mpg
+games/Heroes3/data/video/evil2ap2.mpg
+games/Heroes3/data/video/evil2b.mpg
+games/Heroes3/data/video/evil2c.mpg
+games/Heroes3/data/video/evil2d.mpg
+games/Heroes3/data/video/good1a.mpg
+games/Heroes3/data/video/good1b.mpg
+games/Heroes3/data/video/good1c.mpg
+games/Heroes3/data/video/good2a.mpg
+games/Heroes3/data/video/good2b.mpg
+games/Heroes3/data/video/good2c.mpg
+games/Heroes3/data/video/good2d.mpg
+games/Heroes3/data/video/good3a.mpg
+games/Heroes3/data/video/good3b.mpg
+games/Heroes3/data/video/good3c.mpg
+games/Heroes3/data/video/h3intro.mpg
+games/Heroes3/data/video/hsanim.mpg
+games/Heroes3/data/video/hsloop.mpg
+games/Heroes3/data/video/lbloop.mjpg
+games/Heroes3/data/video/lbstart.mjpg
+games/Heroes3/data/video/losecslp.mjpg
+games/Heroes3/data/video/losecstl.mjpg
+games/Heroes3/data/video/losegame.mpg
+games/Heroes3/data/video/neutrala.mpg
+games/Heroes3/data/video/neutralb.mpg
+games/Heroes3/data/video/neutralc.mpg
+games/Heroes3/data/video/nwclogo.mpg
+games/Heroes3/data/video/pgtrnlft.mjpg
+games/Heroes3/data/video/pgtrnrgh.mjpg
+games/Heroes3/data/video/progressbar.mjpg
+games/Heroes3/data/video/rtloop.mjpg
+games/Heroes3/data/video/rtstart.mjpg
+games/Heroes3/data/video/secreta.mpg
+games/Heroes3/data/video/secretb.mpg
+games/Heroes3/data/video/secretc.mpg
+games/Heroes3/data/video/surrender.mjpg
+games/Heroes3/data/video/tavern.mjpg
+games/Heroes3/data/video/win3.mjpg
+games/Heroes3/heroes3
+games/Heroes3/icon.bmp
+games/Heroes3/icon.xpm
+games/Heroes3/maps/all for one.h3m
+games/Heroes3/maps/ascension.h3m
+games/Heroes3/maps/barbarian breakout.h3m
+games/Heroes3/maps/barbarian breakouta.h3m
+games/Heroes3/maps/buried treasure.h3m
+games/Heroes3/maps/crimson and clover.h3m
+games/Heroes3/maps/crimson and clovera.h3m
+games/Heroes3/maps/dead and buried.h3m
+games/Heroes3/maps/divided loyalties.h3m
+games/Heroes3/maps/divided loyaltiesa.h3m
+games/Heroes3/maps/dragon orb.h3m
+games/Heroes3/maps/emerald isles.h3m
+games/Heroes3/maps/emerald islesa.h3m
+games/Heroes3/maps/free for all.h3m
+games/Heroes3/maps/good to go.h3m
+games/Heroes3/maps/island of fire.h3m
+games/Heroes3/maps/islands and caves.h3m
+games/Heroes3/maps/judgement day.h3m
+games/Heroes3/maps/key to victory.h3m
+games/Heroes3/maps/knee deep in the dead.h3m
+games/Heroes3/maps/knight of darkness.h3m
+games/Heroes3/maps/manifest destiny.h3m
+games/Heroes3/maps/middletown.h3m
+games/Heroes3/maps/myth and legend.h3m
+games/Heroes3/maps/noahs ark.h3m
+games/Heroes3/maps/overthrow thy neighbors.h3m
+games/Heroes3/maps/peacemaker.h3m
+games/Heroes3/maps/pirates.h3m
+games/Heroes3/maps/race for ardintinny.h3m
+games/Heroes3/maps/realm of chaos.h3m
+games/Heroes3/maps/realm of chaosa.h3m
+games/Heroes3/maps/rebellion.h3m
+games/Heroes3/maps/rumble in the bogs.h3m
+games/Heroes3/maps/rumble in the bogsa.h3m
+games/Heroes3/maps/search for the grail.h3m
+games/Heroes3/maps/serpents treasure.h3m
+games/Heroes3/maps/southern cross.h3m
+games/Heroes3/maps/the five rings.h3m
+games/Heroes3/maps/the mandate of heaven.h3m
+games/Heroes3/maps/titans winter.h3m
+games/Heroes3/maps/tutorial.tut
+games/Heroes3/maps/unholy quest.h3m
+games/Heroes3/maps/vial of life.h3m
+games/Heroes3/maps/warlords.h3m
+games/Heroes3/maps/warlordsa.h3m
+games/Heroes3/maps/warmongers.h3m
+games/Heroes3/maps/when dragons clash.h3m
+games/Heroes3/maps/wings of war.h3m
+games/Heroes3/maps/xathras prize.h3m
+games/Heroes3/mp3/aitheme0.mp3
+games/Heroes3/mp3/aitheme1.mp3
+games/Heroes3/mp3/aitheme2.mp3
+games/Heroes3/mp3/campainmusic01.mp3
+games/Heroes3/mp3/campainmusic02.mp3
+games/Heroes3/mp3/campainmusic03.mp3
+games/Heroes3/mp3/campainmusic04.mp3
+games/Heroes3/mp3/campainmusic05.mp3
+games/Heroes3/mp3/campainmusic06.mp3
+games/Heroes3/mp3/campainmusic07.mp3
+games/Heroes3/mp3/campainmusic08.mp3
+games/Heroes3/mp3/campainmusic09.mp3
+games/Heroes3/mp3/combat01.mp3
+games/Heroes3/mp3/combat02.mp3
+games/Heroes3/mp3/combat03.mp3
+games/Heroes3/mp3/combat04.mp3
+games/Heroes3/mp3/cstletown.mp3
+games/Heroes3/mp3/defend castle.mp3
+games/Heroes3/mp3/dirt.mp3
+games/Heroes3/mp3/dungeon.mp3
+games/Heroes3/mp3/eviltheme.mp3
+games/Heroes3/mp3/fortresstown.mp3
+games/Heroes3/mp3/goodtheme.mp3
+games/Heroes3/mp3/grass.mp3
+games/Heroes3/mp3/infernotown.mp3
+games/Heroes3/mp3/lava.mp3
+games/Heroes3/mp3/looplepr.mp3
+games/Heroes3/mp3/lose campain.mp3
+games/Heroes3/mp3/losecastle.mp3
+games/Heroes3/mp3/losecombat.mp3
+games/Heroes3/mp3/mainmenu.mp3
+games/Heroes3/mp3/necrotown.mp3
+games/Heroes3/mp3/neutraltheme.mp3
+games/Heroes3/mp3/rampart.mp3
+games/Heroes3/mp3/retreat battle.mp3
+games/Heroes3/mp3/rough.mp3
+games/Heroes3/mp3/sand.mp3
+games/Heroes3/mp3/secrettheme.mp3
+games/Heroes3/mp3/snow.mp3
+games/Heroes3/mp3/stronghold.mp3
+games/Heroes3/mp3/surrender battle.mp3
+games/Heroes3/mp3/swamp.mp3
+games/Heroes3/mp3/towertown.mp3
+games/Heroes3/mp3/ultimatelose.mp3
+games/Heroes3/mp3/underground.mp3
+games/Heroes3/mp3/water.mp3
+games/Heroes3/mp3/win battle.mp3
+games/Heroes3/mp3/win scenario.mp3
+@dirrmtry games/Heroes3/mp3
+@dirrmtry games/Heroes3/maps
+@dirrm games/Heroes3/data/video
+@dirrm games/Heroes3/data
+@dirrm games/Heroes3/bin
+@dirrm games/Heroes3
+@dirrmtry games
+
diff --git a/games/HeroesOfMightAndMagic/scripts/configure b/games/HeroesOfMightAndMagic/scripts/configure
deleted file mode 100644
index 159db7c06d48..000000000000
--- a/games/HeroesOfMightAndMagic/scripts/configure
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-# Gently borrowed code from x11/XFree86-4
-
-yesno () {
- answ=X
- while [ $answ = X ]; do
- echo -n "$2 [$1] "
- read answ
- if [ X$answ = X ]; then answ=$1; fi
- case $answ in
- y|yes|Y|YES) answ=YES;;
- n|no|N|NO) answ=NO;;
- *) echo invalid answer
- answ=X
- ;;
- esac
- done
-}
-
-question() {
- echo -n "$2 [$1] "
- read answ
- if [ X$answ = X ]; then answ=$1; fi
-}
-
-F=$WRKDIR/.config
-rm -f $F
-
-cat <<EOF
-Welcome to the Heroes of Might And Magic 3 installer.
-You may now choose to install parts of the distribution on disk.
-If you choose not to install a part, I will make a link to the CDROM
-so you will have them in case you have your CD mounted while you play.
-You must have your CDROM mounted right now.
-
-EOF
-question /cdrom "Where is your CD mounted?"
-if [ ! -f $answ/Heroes_III_Tutorial.pdf ] ; then
- echo "Might and Magic III CD not found. Please mount the CD and retry."
- exit 1
-fi
-echo CD=$answ >> $F
-echo "Do you want to install the Basis game packet?"
-yesno YES "Without this you can't play without CD. (112 MB) "
-echo BASIC=$answ >> $F
-echo "Do you want to install the Graphic packet?"
-yesno YES "Without this you can't play without CD. (14 MB) "
-echo GRAPHIC=$answ >> $F
-yesno YES "Do you want to install the Scenarios (1 MB) "
-echo SCENARIO=$answ >> $F
-yesno NO "Do you want to install Music (64 MB) "
-echo MUSIC=$answ >> $F
-yesno NO "Do you want to install Videos (137 MB) "
-echo VIDEOS=$answ >> $F
-
-. $F
-
-cat ${PKGDIR}/files/pkg-plist.base > ${PLIST}
-
-# Scenario files
-if [ $SCENARIO = YES ]; then
- cat ${PKGDIR}/files/pkg-plist.scenario >> ${PLIST}
-else
- echo ${GAMESUBDIR}/maps >> ${PLIST}
-fi
-
-# Neither sound nor Music, make the whole data tree a link
-if [ $GRAPHIC = NO -a $MUSIC = NO ]; then
- echo ${GAMESUBDIR}/data/video >> ${PLIST}
-else
- cat ${PKGDIR}/files/pkg-plist.video >> ${PLIST}
-fi
-
-# Videos
-if [ $VIDEOS = YES ]; then
- cat ${PKGDIR}/files/pkg-plist.video >> ${PLIST}
-fi
-
-
-
-# Music
-if [ $MUSIC = YES ]; then
- cat ${PKGDIR}/files/pkg-plist.music >> ${PLIST}
-else
- echo ${GAMESUBDIR}/mp3 >> ${PLIST}
-fi
-
-echo @dirrm ${GAMESUBDIR}/data >> ${PLIST}
-echo @dirrm ${GAMESUBDIR} >> ${PLIST}
-
-exit 0
diff --git a/games/HeroesOfMightAndMagic/scripts/do-install b/games/HeroesOfMightAndMagic/scripts/do-install
deleted file mode 100644
index 489da4882cc7..000000000000
--- a/games/HeroesOfMightAndMagic/scripts/do-install
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-
-F=$WRKDIR/.config
-
-. $F
-GAMESUBDIR=games/Heroes3
-GAMEDIR=${LOCALBASE}/${GAMESUBDIR}
-
-if [ ! -f ${CD}/Heroes_III_Tutorial.pdf ] ; then
- echo Might and Magic III CD not found in ${CD}. Please mount the CD
- echo And retry. If you want to specify another CDROM mount point,
- echo rerun the configure script.
- exit 1
-fi
-
-# Base installation
-echo Base installation
-mkdir -p ${GAMEDIR}/data
-${INSTALL_DATA} ${CD}/README ${CD}/Heroes_III_Tutorial.pdf ${GAMEDIR}
-${INSTALL_DATA} ${CD}/icon.bmp ${CD}/icon.xpm ${GAMEDIR}
-
-# INSTALL_PROGRAM (its parameter -s) currupts the file. Using cp.
-cp ${CD}/bin/x86/heroes3 ${GAMEDIR}
-chmod 755 ${GAMEDIR}/heroes3
-brandelf -t Linux ${GAMEDIR}/heroes3
-ln -sf ${GAMEDIR}/heroes3 ${LOCALBASE}/bin/heroes3
-touch ${GAMEDIR}/data/hiscore.dat
-chmod 666 ${GAMEDIR}/data/hiscore.dat
-
-# Basis packet
-if [ $BASIC = YES ]; then
- echo Installing Basic packet
- mkdir -p ${GAMEDIR}/data
- ${INSTALL_DATA} ${CD}/data/*.lod ${CD}/data/*.snd ${GAMEDIR}/data
-else
- for file in h3bitmap.lod h3sprite.lod heroes3.snd heroes3cd.snd; do
- ln -sf ${CD}/data/${file} ${GAMEDIR}/data/${file}
- done
-fi
-
-# Scenario files
-if [ $SCENARIO = YES ]; then
- echo Installing Scenarios
- mkdir -p ${GAMEDIR}/maps
- ${INSTALL_DATA} ${CD}/maps/* ${GAMEDIR}/maps
-else
- ln -sf ${CD}/maps ${GAMEDIR}/maps
-fi
-
-# Neither sound nor Music, make the whole data tree a link
-if [ $GRAPHIC = NO -a $MUSIC = NO ]; then
- ln -sf ${CD}/data/video ${GAMEDIR}/data/video
-fi
-
-# Graphics (recommended)
-if [ $GRAPHIC = YES ]; then
- echo Installing Graphics
- mkdir -p ${GAMEDIR}/data/video
- ${INSTALL_DATA} ${CD}/data/video/credits.pcx ${GAMEDIR}/data/video
- ${INSTALL_DATA} ${CD}/data/video/*.mjpg ${GAMEDIR}/data/video
-elif [ $VIDEOS = YES ]; then
-# Videos are installed, so create links
- cd $CD/data/video
- for file in *.mjpg credits.pcx; do
- ln -sf $CD/data/video/${file} ${GAMEDIR}/data/video/${file}
- done
- cd -
-fi
-
-# Videos
-if [ $VIDEOS = YES ]; then
- echo Installing Videos
- mkdir -p ${GAMEDIR}/data/video
- ${INSTALL_DATA} ${CD}/data/video/*.mpg ${GAMEDIR}/data/video
-elif [ $GRAPHIC = YES ]; then
-# Music is installed, so create links
- cd $CD/data/video
- for file in *.mpg; do
- ln -sf $CD/data/video/${file} ${GAMEDIR}/data/video/${file}
- done
- cd -
-fi
-
-# Music
-if [ $MUSIC = YES ]; then
- echo Installing Music
- mkdir -p ${GAMEDIR}/mp3
- ${INSTALL_DATA} ${CD}/mp3/* ${GAMEDIR}/mp3
-else
- ln -sf ${CD}/mp3 ${GAMEDIR}/mp3
-fi
-
-# Goodbye message
-if [ $BASIC = YES -a $GRAPHIC = YES ]; then
- echo
- echo Congratulation. Remember, with your installation you can also play without CD!
-fi
-exit 0