aboutsummaryrefslogtreecommitdiff
path: root/games/KnightCap/files
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-05-15 12:14:23 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-05-15 12:14:23 +0000
commit8859f559f49e065e92ccc5f4ae520df098fbccef (patch)
tree61ea03e87f1743e7da61cdf7839388e754b5fcd1 /games/KnightCap/files
parentf27a20cecacc861cf8140ec0a6bac47eb34f3ffd (diff)
downloadports-8859f559f49e065e92ccc5f4ae520df098fbccef.tar.gz
ports-8859f559f49e065e92ccc5f4ae520df098fbccef.zip
Notes
Diffstat (limited to 'games/KnightCap/files')
-rw-r--r--games/KnightCap/files/patch-aa34
-rw-r--r--games/KnightCap/files/patch-ab14
2 files changed, 48 insertions, 0 deletions
diff --git a/games/KnightCap/files/patch-aa b/games/KnightCap/files/patch-aa
new file mode 100644
index 000000000000..0cf23bfaaa9f
--- /dev/null
+++ b/games/KnightCap/files/patch-aa
@@ -0,0 +1,34 @@
+--- Makefile Wed Mar 11 21:51:57 1998
++++ /home/andy/tmp/wrk/Makefile Sun May 10 09:54:13 1998
+@@ -2,11 +2,11 @@
+
+ # what C compiler? It better be Ansi-C. Use gcc if you have it.
+ # you may find that KnightCap is very slow if you don't use gcc
+-CC = gcc
++#CC = gcc
+
+ # What compiler switches do you want? These ones work well with gcc
+ #OPT = -O2 -fshort-enums -Wall
+-OPT = -g -fshort-enums -Wall
++OPT = -O2 -fshort-enums -Wall -DPI=M_PI
+
+ # If you don't have gcc then perhaps try this instead. You only need
+ # the null definition for inline if your C compiler doesn't know about
+@@ -21,13 +21,10 @@
+ # display (or you don't have OpenGL and Glut libraries)
+ # If you do have these libs then make sure the first three
+ # lines point at the right places
+-MESA = /usr/local/Mesa-2.1
+-GLUT = /usr/local/Mesa-2.1/glut-3.2
+-X11 = /usr/X11R6
+-GLUT_LIBS = -L$(GLUT)/lib/glut -lglut
+-MESA_LIBS = -L$(MESA)/lib -lMesaGLU -lMesaGL -lm
+-XLIBS = -L$(X11)/lib -lXmu -lXt -lXext -lX11 -lXi
+-DISPLAYFLAGS = -I$(MESA)/include -I$(GLUT) -DRENDERED_DISPLAY=1
++GLUT_LIBS = -L$(X11BASE)/lib -lglut
++MESA_LIBS = -L$(X11BASE)/lib -lMesaGLU -lMesaGL -lm
++XLIBS = -L$(X11BASE)/lib -lXmu -lXt -lXext -lX11 -lXi
++DISPLAYFLAGS = -I$(X11BASE)/include -DRENDERED_DISPLAY=1
+
+ # comment out the following line if you don't want KnightCap's
+ # evaluation function learning turned on.
diff --git a/games/KnightCap/files/patch-ab b/games/KnightCap/files/patch-ab
new file mode 100644
index 000000000000..01dba41e45cb
--- /dev/null
+++ b/games/KnightCap/files/patch-ab
@@ -0,0 +1,14 @@
+--- knightcap.c Wed Mar 11 21:51:58 1998
++++ /home/andy/tmp/wrk/knightcap.c Sun May 10 09:54:22 1998
+@@ -934,7 +934,11 @@
+ reset_board();
+ init_movements();
+
++#ifdef __FreeBSD__
++ signal(SIGCHLD, SIG_IGN);
++#else
+ signal(SIGCLD, SIG_IGN);
++#endif
+
+ pid1 = getpid();
+