aboutsummaryrefslogtreecommitdiff
path: root/games/abuse/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2002-05-11 22:15:32 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2002-05-11 22:15:32 +0000
commitf857a690d92c814d09b4fcf3db0f8e68878b3561 (patch)
tree7335d233299c100d2ebd0d9a4ae2626f25d9eabc /games/abuse/Makefile
parent57562e102f6937a4816c0169dc355ff02d6f5d12 (diff)
downloadports-f857a690d92c814d09b4fcf3db0f8e68878b3561.tar.gz
ports-f857a690d92c814d09b4fcf3db0f8e68878b3561.zip
Notes
Diffstat (limited to 'games/abuse/Makefile')
-rw-r--r--games/abuse/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/abuse/Makefile b/games/abuse/Makefile
new file mode 100644
index 000000000000..764723122895
--- /dev/null
+++ b/games/abuse/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: abuse_data
+# Date created: 11 May 2002
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= abuse
+PORTVERSION= 2.0
+CATEGORIES= games
+MASTER_SITES= http://www.labyrinth.net.au/~trandor/abuse/files/
+DISTFILES= abuse_datafiles.tar.gz
+EXTRACT_ONLY= # empty
+
+MAINTAINER= des@freebsd.org
+
+RUN_DEPENDS= abuse.sdl:${PORTSDIR}/games/abuse_sdl
+
+NO_BUILD= YES
+
+do-configure:
+ ${SED} -e 's,%%DATADIR%%,${DATADIR},' \
+ ${FILESDIR}/abuse.sh >${WRKDIR}/abuse
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/abuse ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for DISTFILE in ${DISTFILES}
+ ${TAR} zxf ${DISTDIR}/${DISTFILE} -C ${DATADIR}
+.endfor
+
+.include <bsd.port.mk>