aboutsummaryrefslogtreecommitdiff
path: root/games/abuse_sdl/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-25 18:46:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-25 18:46:27 +0000
commitcdf256027c64a274a6dccfb4bb4b452976a8418d (patch)
tree5d1f4ebbf625a35bb307e39be052a91b915fe761 /games/abuse_sdl/Makefile
parent9480689d86871e848442e2ce64a11e48ffa87e93 (diff)
Notes
Diffstat (limited to 'games/abuse_sdl/Makefile')
-rw-r--r--games/abuse_sdl/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index e7e1e2fc9b90..877b299e3be0 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -12,17 +12,20 @@ DISTNAME= abuse-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= SDL port of the Abuse game engine
-LICENSE= GPLv2
-
-USES= pathfix gl sdl
+LICENSE= GPLv2+ PD WTFPL BPRINCE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING.GPL
+LICENSE_FILE_WTFPL= ${WRKSRC}/COPYING.WTFPL
+LICENSE_NAME_BPRINCE= Boby Prince permission for Debian to redistribute music/sfx files
+LICENSE_PERMS_BPRINCE= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
+
+USES= gl localbase:ldflags pathfix sdl
USE_GL= gl
USE_SDL= mixer sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-assetdir=${DATADIR} --enable-release
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
@@ -33,6 +36,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/abuse.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}