aboutsummaryrefslogtreecommitdiff
path: root/games/acm
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 19:07:46 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 19:07:46 +0000
commit077fbccf15ee1b642207f3e6c04799bd785c2537 (patch)
treeafcabe323255b2bd49545422a26c1589c538d392 /games/acm
parent28fea4be663026f0dfcc10c87633af004b830aa4 (diff)
downloadports-077fbccf15ee1b642207f3e6c04799bd785c2537.tar.gz
ports-077fbccf15ee1b642207f3e6c04799bd785c2537.zip
Notes
Diffstat (limited to 'games/acm')
-rw-r--r--games/acm/Makefile22
-rw-r--r--games/acm/pkg-descr31
-rw-r--r--games/acm/pkg-plist81
3 files changed, 68 insertions, 66 deletions
diff --git a/games/acm/Makefile b/games/acm/Makefile
index aa56d7ca822f..618b0c0b3587 100644
--- a/games/acm/Makefile
+++ b/games/acm/Makefile
@@ -5,27 +5,29 @@ PORTNAME= acm
PORTVERSION= 5.0
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= http://www.websimulations.com/download/
+MASTER_SITES= # none
MAINTAINER= ports@FreeBSD.org
-COMMENT= A flight simulator for X11
+COMMENT= Arial combat simulator for X11
LICENSE= GPLv2
+OPTIONS_DEFINE= SOUND
+
USES= perl5
USE_XORG= x11
GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_lib_Xm_XmCreateBulletinBoard=no \
+ ac_cv_lib_gdbm_dbm_fetch=no
USE_PERL5= build
+MAKE_ARGS+= prefix=${STAGEDIR}${PREFIX}/ OBVDIR=${STAGEDIR}${DATADIR}/
-MAN6= acm.6
+SOUND_LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-# Include sound support (Use network audio server (nas))
-.if defined(WITH_SOUND) || (exists(${PREFIX}/lib/libaudio.a) \
- && !defined(WITHOUT_SOUND))
-LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+.if empty(PORT_OPTIONS:MSOUND)
+CONFIGURE_ENV+= ac_cv_lib_audio_AuCloseServer=no
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/acm/pkg-descr b/games/acm/pkg-descr
index 707d3601aa6b..313d0a00fd5c 100644
--- a/games/acm/pkg-descr
+++ b/games/acm/pkg-descr
@@ -1,18 +1,17 @@
-ACM is a LAN-oriented, multiplayer aerial combat simulation. My main design
-objective was to provide source code that could be easily compiled and
-executed on a wide variety of platforms. To that end, acm is written entirely
-in C, exploiting the programming features of Unix, X11, and the BSD socket
-interface.
+ACM is a LAN-oriented, multiplayer aerial combat simulation. My main
+design objective was to provide source code that could be easily
+compiled and executed on a wide variety of platforms. To that end,
+acm is written entirely in C, exploiting the programming features of
+Unix, X11, and the BSD socket interface.
-Players engage in air to air combat against one another using heat seeking
-missiles and cannons.
+Players engage in air to air combat against one another using heat
+seeking missiles and cannons.
-ACM is implemented as two programs. The first, named "acm", is a small
-program that, when invoked, starts a flight session on a given workstation.
-The second component, named "acms", is a server process that manages the
-multiplayer environment. It also manages the flight simulation and
-display management that is required. Most players will prefer to run the
-acms process on a back-end server system on their local area network. Players
-at client workstations can then invoke the acm program to begin play.
-
-WWW: http://www.websimulations.com/
+ACM is implemented as two programs. The first, named "acm", is a small
+program that, when invoked, starts a flight session on a given
+workstation. The second component, named "acms", is a server process
+that manages the multiplayer environment. It also manages the flight
+simulation and display management that is required. Most players will
+prefer to run the acms process on a back-end server system on their
+local area network. Players at client workstations can then invoke the
+acm program to begin play.
diff --git a/games/acm/pkg-plist b/games/acm/pkg-plist
index ca85dc6aa2b9..b8a4d1802c5d 100644
--- a/games/acm/pkg-plist
+++ b/games/acm/pkg-plist
@@ -1,41 +1,42 @@
bin/acm
-share/acm/acmlogo-unix.xwd
-share/acm/aconnon.au
-share/acm/aim9.obv
-share/acm/apglock.au
-share/acm/c172.obv
-share/acm/cannon.au
-share/acm/crash.au
-share/acm/dallas-scene
-share/acm/default-scene
-share/acm/engine.au
-share/acm/f117.dxf
-share/acm/f16.obv
-share/acm/f18.obv
-share/acm/gear_dn.au
-share/acm/gear_up.au
-share/acm/hangar.obv
-share/acm/il78.obv
-share/acm/imarker.au
-share/acm/inventory
-share/acm/kc135.obv
-share/acm/mig23.obv
-share/acm/mig25.obv
-share/acm/mig29.obv
-share/acm/missile.au
-share/acm/mmarker.au
-share/acm/munition-map.txt
-share/acm/object-map.txt
-share/acm/omarker.au
-share/acm/rwr.au
-share/acm/sa10.obv
-share/acm/sa11.obv
-share/acm/sa2.obv
-share/acm/screetch.au
-share/acm/stall.au
-share/acm/su30.obv
-share/acm/surface.obv
-share/acm/telar1.obv
-share/acm/tower.obv
-share/acm/tracer.obv
-@dirrm share/acm
+man/man6/acm.6.gz
+%%DATADIR%%/acmlogo-unix.xwd
+%%DATADIR%%/aconnon.au
+%%DATADIR%%/aim9.obv
+%%DATADIR%%/apglock.au
+%%DATADIR%%/c172.obv
+%%DATADIR%%/cannon.au
+%%DATADIR%%/crash.au
+%%DATADIR%%/dallas-scene
+%%DATADIR%%/default-scene
+%%DATADIR%%/engine.au
+%%DATADIR%%/f117.dxf
+%%DATADIR%%/f16.obv
+%%DATADIR%%/f18.obv
+%%DATADIR%%/gear_dn.au
+%%DATADIR%%/gear_up.au
+%%DATADIR%%/hangar.obv
+%%DATADIR%%/il78.obv
+%%DATADIR%%/imarker.au
+%%DATADIR%%/inventory
+%%DATADIR%%/kc135.obv
+%%DATADIR%%/mig23.obv
+%%DATADIR%%/mig25.obv
+%%DATADIR%%/mig29.obv
+%%DATADIR%%/missile.au
+%%DATADIR%%/mmarker.au
+%%DATADIR%%/munition-map.txt
+%%DATADIR%%/object-map.txt
+%%DATADIR%%/omarker.au
+%%DATADIR%%/rwr.au
+%%DATADIR%%/sa10.obv
+%%DATADIR%%/sa11.obv
+%%DATADIR%%/sa2.obv
+%%DATADIR%%/screetch.au
+%%DATADIR%%/stall.au
+%%DATADIR%%/su30.obv
+%%DATADIR%%/surface.obv
+%%DATADIR%%/telar1.obv
+%%DATADIR%%/tower.obv
+%%DATADIR%%/tracer.obv
+@dirrm %%DATADIR%%