aboutsummaryrefslogtreecommitdiff
path: root/games/adgali/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-27 20:51:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-27 20:51:35 +0000
commit3cf3931ba10fcd8f312951a61c08f71d2eb438ee (patch)
treec1155e0edba000ee8fdb6fdfe6760a2a83024729 /games/adgali/Makefile
parent30856eccfb78344a801ddd1678138add833668da (diff)
downloadports-3cf3931ba10fcd8f312951a61c08f71d2eb438ee.tar.gz
ports-3cf3931ba10fcd8f312951a61c08f71d2eb438ee.zip
Notes
Diffstat (limited to 'games/adgali/Makefile')
-rw-r--r--games/adgali/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 9e857a70ad56..98e037db39c0 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -7,27 +7,27 @@
#
PORTNAME= adgali
-PORTVERSION= 0.2.3
-PORTREVISION= 2
+PORTVERSION= 0.2.4
CATEGORIES= games devel
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://adgali.apiou.org/download/
MAINTAINER= ports@FreeBSD.org
-COMMENT= An open source game library useful for 2D games programmation
+COMMENT= An open source game library useful for 2D game development
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
+USE_BZIP2= yes
USE_SDL= sdl
-USE_GNOME= gnometarget
-USE_REINPLACE= yes
+USE_XPM= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-compile-optim=no
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -36,10 +36,6 @@ INSTALLS_SHLIB= yes
BROKEN= "Configure fails"
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-O3 ||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-release $$(LT_RELEASE)||g' ${WRKSRC}/src/Makefile.in
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}