aboutsummaryrefslogtreecommitdiff
path: root/games/adgali
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/adgali
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/adgali')
-rw-r--r--games/adgali/Makefile4
-rw-r--r--games/adgali/files/patch-src-input-imageio-agl_pngio.c20
2 files changed, 21 insertions, 3 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 78d8c6fa0cfb..1ac19a489301 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -8,7 +8,7 @@
PORTNAME= adgali
PORTVERSION= 0.2.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games devel
MASTER_SITES= http://adgali.apiou.org/download/
@@ -18,7 +18,7 @@ COMMENT= An open source game library useful for 2D game development
LICENSE= GPLv2
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2 \
execinfo.1:${PORTSDIR}/devel/libexecinfo
diff --git a/games/adgali/files/patch-src-input-imageio-agl_pngio.c b/games/adgali/files/patch-src-input-imageio-agl_pngio.c
index 9a7155464ad0..53ad107e4dee 100644
--- a/games/adgali/files/patch-src-input-imageio-agl_pngio.c
+++ b/games/adgali/files/patch-src-input-imageio-agl_pngio.c
@@ -1,5 +1,5 @@
--- src/input/imageio/agl_pngio.c.orig 2003-06-24 01:58:47.000000000 +0200
-+++ src/input/imageio/agl_pngio.c 2010-03-30 11:23:50.000000000 +0200
++++ src/input/imageio/agl_pngio.c 2012-05-01 09:02:25.000000000 +0200
@@ -65,7 +65,7 @@
unsigned char buf[8];
@@ -9,6 +9,15 @@
return 0;
}
+@@ -106,7 +106,7 @@
+ }
+
+ /* standard png error handler */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ agl_error("Error reading the PNG file");
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
@@ -131,7 +131,7 @@
/* see pnglib for these calls */
@@ -18,3 +27,12 @@
if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
png_set_tRNS_to_alpha(png_ptr);
+@@ -171,7 +171,7 @@
+ *rowp = (png_bytep) pixelp;
+ /* standard png error handler redeclared to free the agl image if an
+ * error occurs */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ agl_error("Error reading the PNG file");
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);