aboutsummaryrefslogtreecommitdiff
path: root/games/adonthell
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-02 14:18:58 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-02 14:18:58 +0000
commit9f779a84f27098fd3e9bc0099c16d3a77cf140c6 (patch)
treeba69aff3c3f3b7f725ff5ea43238f999b9fd1c93 /games/adonthell
parent9a758f1909ccbfd9aa2174b4ef27151bb95e01be (diff)
downloadports-9f779a84f27098fd3e9bc0099c16d3a77cf140c6.tar.gz
ports-9f779a84f27098fd3e9bc0099c16d3a77cf140c6.zip
Notes
Diffstat (limited to 'games/adonthell')
-rw-r--r--games/adonthell/files/patch-src_Makefile.in17
-rw-r--r--games/adonthell/files/patch-src_label.cc11
-rw-r--r--games/adonthell/files/patch-src_label.h11
-rw-r--r--games/adonthell/files/patch-src_win__event.cc11
4 files changed, 50 insertions, 0 deletions
diff --git a/games/adonthell/files/patch-src_Makefile.in b/games/adonthell/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..1c150db7c196
--- /dev/null
+++ b/games/adonthell/files/patch-src_Makefile.in
@@ -0,0 +1,17 @@
+--- src/Makefile.in.orig 2008-05-29 19:00:50.000000000 +0000
++++ src/Makefile.in
+@@ -769,13 +769,12 @@ uninstall-am: uninstall-binPROGRAMS
+
+ # Note: adonthell.py is also built by this target.
+ py_adonthell_wrap.cc : py_adonthell.i $(headers)
+- @if test "${P_SWIG}"; then \
++ @if [ "${P_SWIG}" != "no" ]; then \
+ echo ${P_SWIG} -python -modern -shadow ${SDL_CFLAGS} -I$(srcdir) -I$(top_srcdir) -c++ -makedefault -o $(srcdir)/$*.cc $(srcdir)/py_adonthell.i; \
+ ${P_SWIG} -python -modern -shadow ${SDL_CFLAGS} -I$(srcdir) -I$(top_srcdir) -c++ -makedefault -o $(srcdir)/$*.cc $(srcdir)/py_adonthell.i; \
+ mv $(srcdir)/adonthell.py modules/adonthell.py; \
+ else \
+ echo "You need swig >= ${SWIG_MINVER} in order to re-build this file."; \
+- exit 1; \
+ fi;
+
+ lex.prefs.cc : prefs.l
diff --git a/games/adonthell/files/patch-src_label.cc b/games/adonthell/files/patch-src_label.cc
new file mode 100644
index 000000000000..509577a96fee
--- /dev/null
+++ b/games/adonthell/files/patch-src_label.cc
@@ -0,0 +1,11 @@
+--- src/label.cc.orig 2008-05-29 18:42:50.000000000 +0000
++++ src/label.cc
+@@ -645,7 +645,7 @@ void label::cursor_previous ()
+ }
+
+
+-const string label::text_string () const
++const string & label::text_string () const
+ {
+ return my_text_;
+ }
diff --git a/games/adonthell/files/patch-src_label.h b/games/adonthell/files/patch-src_label.h
new file mode 100644
index 000000000000..5362741ad079
--- /dev/null
+++ b/games/adonthell/files/patch-src_label.h
@@ -0,0 +1,11 @@
+--- src/label.h.orig 2005-04-16 17:56:32.000000000 +0000
++++ src/label.h
+@@ -90,7 +90,7 @@ public :
+ /**
+ Get the text in string
+ */
+- const string text_string () const;
++ const string & text_string () const;
+
+
+ /**
diff --git a/games/adonthell/files/patch-src_win__event.cc b/games/adonthell/files/patch-src_win__event.cc
new file mode 100644
index 000000000000..8f028f4d3fab
--- /dev/null
+++ b/games/adonthell/files/patch-src_win__event.cc
@@ -0,0 +1,11 @@
+--- src/win_event.cc.orig 2002-12-16 19:09:54.000000000 +0000
++++ src/win_event.cc
+@@ -35,7 +35,7 @@ void win_event::py_signal_connect (PyObj
+ case DESTROY:
+ {
+ set_callback_destroy (
+- makeFunctor (&Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
++ makeFunctor (new Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
+ break;
+ }
+